4_CamSequenceEdit

Aktion eines aktiven Nockens definieren:

Nach einem Doppelclick in der Spalte Aktion des Nockenschaltwerks wird folgendes Fenster geöffnet:

Um einen Merker für das iMotion Programm zu setzen wählen Sie bitte den "1'ter Merker" oder "2'ter Merker" aus und geben eine Nummer zwischen 0 und 99 an. Zum Setzen eines oder mehrerer Ausgänge bei aktivem Nocken wählen Sie den entsprechenden Ausgang durch "Anklicken" einfach an.

Beachten Sie bitte, daß der ausgewählte Ausgang dem Nockenschaltwerk (z.B.: OS03 := CCOUT (25))zugewiesen werden muß. Die Zuweisung des Ausgang wird in der Maske Ausgänge vorgenommen.

Zur Weiterverarbeitung des Zustands "Nocken gesetzt" in der Ablaufsteuerung "iMotion" wählen Sie die Zeile "1`ter Merker" und/oder "2´ter Merker" und tragen dort die Nummer des gewünschten Merkers ein.

Zurück


4_CamSwitch

Einstellungen Nockenschaltwerk:

Funktionsweise des Nockenschaltwerks

Wann wird das Nockenschaltwerk bearbeitet?

Anfangs und Endposition eines Nockens einstellen:

Zyklus einstellen:

Anzahl der Nocken:

Hysterese zur Vermeidung von Jittereffekten einstellen:

Referenzposition einstellen:

Synchronisation des Nockenschaltwerkes auf die aktuelle Position über iMotion:

Synchronisation des Nockenschaltwerkes auf die aktuelle Position über Klemme:

Versenden von CAN-Telegrammen

Stoppen des Nockenschaltwerkes über iMotion oder Feldbus:

Stoppen des Nockenschaltwerkes über Klemme:

Aktion eines Nockens definieren

Funktionsweise des Nockenschaltwerk

Das im Gerät implementierte Nockenschaltwerk läßt sich am einfachsten als Walze mit radial aufgelegten Erhöhung (Nocken) entlang der Walzenachse beschreiben . Auf der Walze können 16 Nocken mit Anfangs- und Endposition bezogen auf den Walzendurchmesser (Zyklus) beliebig angeordnet werden. Jedem Nocken ist ein Aktionsregister zugeordnet, welches die entsprechenden Aktionen bei Erreichen des Nockens auslöst. Z.B. kann dieser Zustand durch Setzen eines Ausgangs an eine übergeordnete Steuerung gemeldet oder durch Beschreiben eines Merkers in der Ablaufsteuerung "iMotion" weiter verwendet werden.

Die entsprechenden Konfigurationen des Schaltwerkes wird in der obigen Maske vorgenommen.

Zurück zum Anfang des Dokumentes

Wann wird das Nockenschaltwerk bearbeitet?

Wird die Anzahl von Nocken ungleich Null vorgegeben, so wird das Nockenschaltwerk gestartet und bearbeitet.

Zurück zum Anfang des Dokumentes

Anfangs und Endposition eines Nockens einstellen:

Die Nockenpositionen können in beliebiger Reihenfolge vorgegeben werden, müssen sinnvollerweise aber stets innerhalb des Zyklusses liegen.

Es erfolgt keine Prüfung dieser Bedingung!

Zurück zum Anfang des Dokumentes

Zyklus einstellen:

Nach Ablauf des definierten Zyklus, beginnt der Zyklus erneut. Der Zyklus wird in benutzer-spezifischen Einheiten angegeben (lagegeregelt). Ist keine Einheit vorgegeben, wird in Inkrementen gerechnet (drehzahlgeregelt).

Zurück zum Anfang des Dokumentes

Anzahl der Nocken:

Nur die definierte Anzahl von Nocken wird ausgewertet. Ist die definierte Anzahl Null, so wird das Nockenschaltwerk nicht bearbeitet. Es können insgesamt 16 Nocken parametriert werden.

Zurück zum Anfang des Dokumentes

Hysterese zur Vermeidung von Jittereffekten einstellen:

Zur Vermeidung von Jittereffekten kann eine Hysterse angegeben werden. Beim ersten Erreichen des Nockens, wird die Eintrittsposition gespeichert. Wird der Nocken beispielsweise an der gleichen Position verlassen, erfolgt die Deaktivierung des Nockenzustandes erst dann, wenn auch die Hysterese (CHYST) verlassen wird. Damit der Nocken eindeutig detektiert werden kann, ist die Nockenlänge der max. Geschwindigkeit des Antriebes anzupassen (Detektion im 1ms-Takt).
Sinnvollerweise ist die Nockenlänge größer der Hysterese zu wählen.

Zurück zum Anfang des Dokumentes

Referenzposition einstellen:

Hier wird die Positionsquelle, die das Nockenschaltwerkes speist, eingestellt. Folgende Einstellungen sind möglich:

"ENCD [0] = Nockenschaltwerkszyklus über Lagegeber" := Der Zyklus des Nockenschaltwerks wird durch die aktuelle Position des Servos (Lageregler) bestimmt.
"EGEAR [1 = Nockenschaltwerkzyklus über externen Leitgeber" := Der Zyklus des Nockenschaltwerks wird durch den Leitgeber bestimmt.

Zurück zum Anfang des Dokumentes

Synchronisation des Nockenschaltwerkes auf die aktuelle Position über iMotion:

Durch eine positive Flanke des Merkers 75 wird das Nockenschalt auf die aktuelle Position synchronisiert.

Zurück zum Anfang des Dokumentes

Synchronisation des Nockenschaltwerkes auf die aktuelle Position über Klemme:

Mit einer positive Flanke an dem Eingang, der auf Start "ENCAM (36) Start Nockenschaltwerk" parametriert ist, wird das Nockenschaltwerk auf die aktuelle Position synchronisiert.

Zurück zum Anfang des Dokumentes

Versenden von CAN-Telegrammen

Das Nockenschaltwerk selbst versendet keine Can-Telegramme. Durch das Setzen von Merker 98, Merker 99, dem virtuellen Ausgang OV00 und dem virtuellen Ausgang OV01 wird eine Eventhandling zum CAN hergestellt. Siehe auch Aktion eines Nockens definieren

Zurück zum Anfang des Dokumentes

Stoppen des Nockenschaltwerkes über iMotion oder Feldbus:

Wird die Anzahl der Nocken (Parameter "662-CCNUM-Anzahl der verwendeten Nocken") zu Null gesetzt, so wird das Nockenschaltwerk angehalten.

Zurück zum Anfang des Dokumentes

Stoppen des Nockenschaltwerkes über Klemme:

Ist der Eingang in der Bedienmaske "Eingänge/Digital" oder "Eingänge/Digital UM8I4O" auf Nockenschaltwerk parametriert, aber nicht gesetzt, so wird das Nockenschaltwerk nicht bearbeitet.

Aktion eines Nockens definieren

Zur Definition der Aktion eines Nockens klicken Sie bitte mit einem "Doppelklick in die Spalte "Aktion".

Zurück zum Anfang des Dokumentes


Kommutierungsfindung:

Parameter und Verfahren:
Die verschiedenen Verfahren sind über die Bedienmaske "Motor und Geber einstellen / Kommutierungsfindung" in der Bedienebene 6 einstellbar.

Über die Kombibox (Parameter 886-IESEL) sind 5 verschiedene Verfahren anwählbar.

Die Kommutierungsfindung wird im Betrieb einmalig nach dem Einschalten bei der ersten Startfreigabe durchgeführt. Sie kann bei der Inbetriebnahme durch Veränderung eines Parameters, der eine vollständige Regelungsinitialisierung verursacht (z.b. IESEL, ECOFF, CFENC, CFCON u.a.), erzwungen werden.

Parameter

886-IESEL

Funktion
Initialisierung des Encoderoffsets durch

OFF(0)

keine spezielle Initialisierung

IENCC(1)

Mit Bewegung (führt zur Bewegung des Rotors)

  1. Für die Zeitdauer IENCT[1] wird ein Strom mit der Amplitude IENCC[1] in beta-Richtung aufgeschaltet
  2. Nach Ablauf der Zeit IENCT[1]wird für die Zeit IENCT[0] ein Strom mit der Amplitude IENCC[0] in alpha-Richtung aufgeschaltet.
  3. Mit dem Ablauf der Zeit IECNT[0] wird die gerade aktuelle Motorstellung als d-Achse (Flussachse) definiert

Die maximale Zeitdauer für die Kommutierungsfindung (IENCT[0] + IENCT[1]) beträgt 8100ms. Bei Überschreiten wird eine Fehlermeldung ausgegeben

LHMES (2)

Festgebremst (Beruht auf Induktivitätsmessungen)

Einsatzbereich:

Gebremste Maschinen, Maschinen mit großer Massenträgheit J, Sättigungseffekte müssen ausgeprägt sein!

Parametrierung:

IECNT[2] Periodendauer des Testsignal.
(Einstellung 3 führt zu 1/3ms = 333Hz Testsignalfrequenz)

IENCCT[2] Amplitude des Testsignals [A]

Folgende Parameter werden bei der Kommutierungsfindung bestimmt:

Parameter Bedeutung Einheit
Folgende Parameter werden bei der Kommutierungsfindung bestimmt:

Parameter Bedeutung Einheit
SC_V0[0] Rotorlage in I=[-180..0] grd
SC_V0[1] Rotorlage in I=[0..180] grd
SC_V0[2] Rotorlage in I=[-180 .. 180] grd
SC_V0[3] Rotorlage in I=[-0,5 .. 0,5] 1
SC_V1[0] Letzter Meßwert für [image] W
SC_V1[12] [image] (Mittelwert [image]) W
SC_V2[0] Letzter Meßwert für [image] H
SC_V2[3] [image] H
SC_V2[4] [image] H
SC_V2[10] [image] H
SC_V2[11] [image] H
SC_V2[12] [image] (Mittelwert [image]) H

IECSC (3)

Schwingungsanalyse (geringe Rotorauslenkung, im Vorbereitung)

ACHTUNG – VORSICHT – nur Prototyp

Nur für erfahrene Anwender geeignet

Parametrierung:

IECNT[3] Periodendauer des Testsignal.
Einstellung 3 führt zu 1/3ms = 333Hz Testsignalfreguenz
IENCCT[3] Amplitude des Testsignals [A]

Defaulteinstellung:
Werden die Parameter zu Null gesetzt, wird die Defaul-Einstellung gewählt. Der Strom ist abhängig vom Motornennstrom MOCNM:.

IENCT[3] = 10ms, IENCC[3] = 0,2 * MOCNM*SQRT(2)

IECON (4)

Mit minimierter Bewegung:

Ein sinnvoll parametrierter Drehzahlregler ist vor Verwendung des Verfahrens absolut notwendig.

- Für die Zeitdauer IENCT[1] wird ein Strom auf die Amplitude IENCC[1] über eine Rampe erhöht.

- Im Anschluss wird für die Zeitdauer IENCT[0] der Strom auf die Amplitude IENCC[0] wiederum entlang einer Rampe erhöht.

Der Rotor muss sich am Ende der Stromaufschaltung jeweils in Ruhe befinden.

Ziel der Optimierung des Parameters KCGFA ist, die Rotorbewegung zu minimieren.

Zur Beurteilung bietet sich das Scope im DriveManager an:

Aufzuzeichnende Größen: eps_RS, (Ist-)Strom in d-Richtung

Defaulteinstellung:
Alle Parameter zu Null setzen

HALL1 (5)

Hallsensor-Auswertung von zwei um 120 Grad räumlich versetzte Sensoren:

Die Sensoren liefern analoge Ausgangssignale, die am Resolvereingang eingelesen werden. Aus den beiden Spursignalen wird dann mittels Arcus-Tangens-Operation der Kommutierungswinkel bestimmt.

Die Genauigkeit des ermittelten Encoderoffsets hängt von Beschaffenheit des ausgewerteten Magnetfeldes, der Qualität der Sensorsignale und der nachgeschalteten Auswerteelektronik ab.

HALL2 (6)

Hallsensor-Auswertung von zwei um 90 Grad räumlich versetzte Sensoren:

Die Sensoren liefern analoge Ausgangssignale, die am Resolvereingang eingelesen werden. Aus den beiden Spursignalen wird dann mittels Arcus-Tangens-Operation der Kommutierungswinkel bestimmt.

Die Genauigkeit des ermittelten Encoderoffsets hängt von Beschaffenheit des ausgewerteten Magnetfeldes, der Qualität der Sensorsignale und der nachgeschalteten Auswerteelektronik ab.