Einführung

Einsatzgebiet

DerDriveManager V3.x ist für alle c-line Drives der Lust Antriebstechnik geeignet. Mit diesem PC-Programm können Sie die Lust-Antriebsgeräte auf bequeme Weise parametrieren, in Betrieb nehmen, direkt steuern oder Statuswerte aus dem angeschlossenen Gerät abfragen. Die PC-Oberfläche passt sich allen Geräten der c-line Drives automatisch an.


Lieferumfang

Das DriveManager 3.x-Paket beinhaltet eine CD-ROM und den Lizenzkey.

Auf der CD-ROM befinden sich alle Programmdateien, die Motordatenbanken für die Lust-Servomotorreihe, sowie die aktuellen Handbücher zu den Lust Geräte-Baureihen im PDF-Format.


Systemanforderungen

Hardwareanforderungen:
  • ein PC mit Intel® Pentium®- bzw. AMD-Prozessor
  • mind. 80 MB freier Speicherplatz
  • mind. 32 MB RAM
  • CD-ROM Laufwerk
  • serielle Schnittstelle RS232 oder USB - RS232-Konverter*
* Anforderungen: Baudrate <115 200 Baud, USB2.0 Full-Speed kompatibel, Treiber für
Windows 98/ME/2000/XP
Empfohlen: US232B von FTDI (Funktionalität geräteabhängig)


Betriebssystem:
  • Microsoft Windows 95/98/ME oder Windows NT 4.0/2000/XP


Lizenzbedingungen

www.lust-tec.de, info@lust-tec.de


Installation

www.lust-tec.de, info@lust-tec.de


Installation des DriveManagers

Nach dem Einlegen der CD-ROM startet die Installation selbsttätig. Falls dies nicht der Fall sein sollte, starten Sie bitte mit einem Doppelklick die Datei SETUP.EXE im Menü der CD-ROM.
Ein Pop-up-Fenster zur Auswahl der Sprache des DriveManager-Browsers erscheint. Wählen Sie die entsprechende Sprache; der DriveManager-Browser öffnet sich.

Klicken Sie auf „Installieren" und wählen Sie danach die entsprechende Version des DriveManagers.


Alte DriveManager-Version deinstallieren

Ist bereits eine alte Version des DriveManagerss installiert, öffnet sich ein Fenster zur Deinstallation dieser Version. Führen Sie den InstallShield Wizard zur Deinstallation der alten Version aus.


DriveManager neu installieren

Es öffnet sich automatisch ein Fenster, in dem die Sprache des DriveManagers gewählt werden kann. Der InstallShield Wizard führt Sie durch die Installation.

Wählen Sie während der Installation, ob alle Benutzer Ihres PCs oder nur Sie alleine auf den DriveManager zugreifen können.

Weiterhin haben Sie die Wahl zwischen drei Setuptypen:

Klicken Sie anschließend auf den Button „Weiter".

Im nächsten Fenster des InstallShield Wizards legen Sie fest, wie der DriveManager im Windows Start-Menü angezeigt werden soll. Mit dem Bestätigen über den Button „Weiter" startet die Installation (dies kann einige Minuten dauern).

Im nächsten Schritt geben Sie die Nummer der seriellen Schnittstelle Ihres PCs an, über die Sie die Verbindung zum Lust-Antriebsgerät aufnehmen wollen. In der Regel haben Sie COM1 bis COM4 zur Wahl.
Verfügt Ihr Computer nicht über eine RS232-Schnittstelle, kann das Lust-Antriebsgerät über einen USB - RS232-Adapter angeschlossen werden (siehe "Systemanforderungen").

Mit Bestätigung Ihrer Eingabe ist die Installation abgeschlossen.


Installation der Motordatenbank

Alle Servomotoren der Lust Antriebstechnik sind mit ihren elektrischen Eigenschaften bereits ermittelt und in den Motordatenbanken abgelegt. Diese finden Sie im DriveManager-Browser im Menü „Motordaten". In diesem Ordner starten Sie direkt das Setup-Programm und installieren die Datenbank.


Gerät an PC anschließen

Schließen Sie den Lust-Antriebsregler über ein handelsübliches PC-Kabel (D-Sub 9-polig) an der RS232-Schnittstelle Ihres PCs an.
Ggf. verwenden Sie einen USB - RS232-Adapter, falls Ihr PC keine RS232-Schnittstelle aufweist (siehe "Systemanforderungen").


Der DriveManager

DriveManager starten

Mit angeschlossenem Gerät - Online-Betrieb

Schließen Sie den Lust-Antriebsregler wie in Kapitel siehe "Gerät an PC anschließen" an den PC an und schalten Sie den Antriebsregler ein. Starten Sie den DriveManager über die Windows Start-Leiste oder die Verknüpfung auf dem Desktop.
In der Werkseinstellung sucht der DriveManager automatisch nach einem angeschlossenen Gerät. Sollte dies nicht der Fall sein, können Sie die Verbindung zum Antriebsregler manuell herstellen:

Die genaue Vorgehensweise für die Inbetriebnahme der jeweiligen Antriebsregler entnehmen Sie den entsprechenden Betriebsanleitungen.


Ohne angeschlossenes Gerät - Offline-Betrieb

Wird der DriveManager ohne angeschlossenes Gerät gestartet, erscheint in der Grundeinstellung folgendes Fenster:

Klicken Sie auf „Ok" und arbeiten Sie mit einem bereits vorhandenen Datensatz. Dazu gehen Sie wie folgt vor:

Im Ordner „samples" liegen Datensätze zu verschiedenen Mustergeräten ab. Wählen Sie den Ordner der gewünschten Baureihe. Durch Doppelklick auf einen Datensatz öffnet sich ein Funktionsfenster (Funktionsmaske), in dem die Einstellungen zum Mustergerät verändert werden können.


Programmfenster

Das Programmfenster des DriveManagers - im Online-Betrieb - setzt sich aus der Funktionsmaske, der Menü- und Quick-Acces-Leiste und der Status- und Istwerte-Anzeige zusammen.


Funktionsmaske

Mit Hilfe dieser Maske werden alle Einstellungen am aktiven Gerät oder an einem Datensatz durchgeführt. Die Zugriffsrechte auf die verschiedenen Funktionen hängen dabei von der Benutzerebene ab (siehe "Benutzerebene wählen").
Mehr Informationen über die einzelnen Einstellmöglichkeiten entnehmen Sie bitte den jeweiligen Betriebsanleitungen der
c-line Drives-Geräte.


Quick-Access-Leiste

Die unten aufgeführte Quick-Access-Leiste entspricht der Grundeinstellung des DriveManagers. Damit können Sie alle wichtigen Funktionen mit einem Mausklick starten.
Durch Klicken und Ziehen der einzelnen Blöcke können Sie die Anordnung der Quick-Access-Leiste nach Belieben anpassen.

Online
Offline
Arbeiten mit Dateien

Datensatz öffnen
x
x

Datensatz drucken
x
x

bestehendes Digital Scope Bild öffnen
x
x

Geräteeinstellungen vergleichen
x
x
Aktionen mit aktivem Gerät

Einstellungen des aktiven Gerätes ändern
x

Geräteeinstellungen drucken
x

Digital Scope starten
x

Antrieb steuern
x
Kommunikation

Verbindung zum Gerät lösen
x
x

Bus-Initialisierung (Einstellungen ändern)
x
x

Verbindung zum Gerät lösen
x
Datensatzoperationen

Geräteeinstellungen speichern in Datei
x

Geräteeinstellungen von Datei ins Gerät übertragen
x
Geräteliste

Aktives Gerät
x
Benutzerebene

Benutzerebene wählen
x
x


Status- und Istwertanzeige

Die Status- und Istwerte-Anzeige ist nur im Online-Betrieb sichtbar. Auf der linken Seite des Programmfensters werden in der Istwertanzeige die aktuellen Drehzahl, Positions- und Stromwerte des Antriebsreglers und in der Statusanzeige der Betriebsstatus des Gerätes angezeigt. Auf der rechten Seite des Programmfensters wird die Belegung der Ein- und Ausgänge angezeigt. Durch Klicken auf den Button „IO" bzw. „Fct" kann zwischen der Anzeige der Belegung der Ein-/Ausgänge und den Namen der Ein-/Ausgänge umgeschaltet werden.


Funktionen

Verbindungsauf- und abbau

Besteht keine Verbindung zu einem angeschlossenen Antriebsregler kann diese wie folgt hergestellt werden:

Möchten Sie die Verbindung zu den angeschlossenen Geräten oder zu einem einzelnen Gerät abbrechen, gehen Sie folgendermaßen vor:

Wird der DriveManager gestartet, stellt er in der Grundeinstellung automatisch eine Verbindung zum angeschlossenen Gerät her. Sollte dies nicht der Fall sein, kontrollieren Sie bitte folgende Einstellungen:

Weiterhin überprüfen Sie bitte die Steckverbindung zwischen Ihrem PC und dem Antriebsregler.
Kommt keine Verbindung mit einem USB-RS232-Adapter zustande, tauschen Sie diesen aus und stellen Sie die Verbingung erneut her.

Danach starten Sie den Verbindungsaufbau erneut.


Benutzerebene wählen

Zur Einstellung der Benutzerebene gehen Sie bitte wie folgt vor:

In den sechs Ebenen sind verschiedene Zugriffsrechte zu den Parametermasken vergeben. In der Ebene 1 (Beobachter) können die Daten nur eingesehen werden. Die Zugriffsmöglichkeiten werden sukzessive bis zur Benutzerebene 4 (Administrator), in der die vollständigen Zugriffsrechte gewährt werden, erhöht. Die Ebenen 5 und 6 sind den Service-Technikern und Entwicklungsingenieuren der Fa. Lust vorbehalten. Wählen Sie die für Sie zutreffende Benutzerebene zum Bedienen des DriveManagers aus.


Passwort für Benutzerebenen

Für die Benutzerebenen 2-4 sowie für die Steuern-Funktion/Handbetrieb können Passwörter vergeben werden. Dazu klicken Sie in der Funktionsmaske auf „Passwörter" und vergeben für jede Benutzerebene eine Zahlenkombination. Nach dem Speichern der Einstellungen ist die Passwortabfrage aktiv.


Antriebsregler einstellen

Einstellungen ändern

Über die Funktionsmaske können alle Einstellungen am aktiven Gerät durchgeführt werden. Die Zugriffsrechte auf die verschiedenen Funktionen hängen dabei von der Benutzerebene ab (siehe "Benutzerebene wählen").
Mehr Informationen über die einzelnen Einstellmöglichkeiten entnehmen Sie bitte den jeweiligen Betriebsanleitungen der
c-line Drives-Geräte.


Einstellungen speichern

Jede Veränderung in der Funktionsmaske wird direkt in das Gerät geschrieben. Um die Änderungen dauerhaft im Gerät zu speichern klicken Sie auf „Einstellungen im Gerät speichern".
Möchten Sie die Daten des aktiven Gerätes in einer Datei speichern, gehen Sie wie folgt vor:


Einstellungen ins Gerät laden

Um einen bereits bestehenden Datensatz in den aktiven Antriebsregler zu laden, gehen Sie folgendermaßen vor:


Einstellungen mit Datensatz bzw. Werkseinstellung vergleichen

Sie können die aktuellen Einstellungen des Gerätes mit einem bereits vorhandenen Datensatz oder mit der Werkseinstellung vergleichen. Dazu gehen Sie wie folgt vor:

Wählen Sie eine Vergleichsdatei aus. Unter „Optionen" können Sie Einstellungen zur Paramterauswahl und zur Art der Ausgabe der Vergleichsdaten vornehmen. Mit Klick auf „Ok" erstellt der DriveManager eine Liste aller Abweichungen der beiden Datensätze.


Einstellungen drucken

Um die aktuellen Einstellungen (Parameterliste) des Gerätes auszudrucken, gehen Sie bitte folgendermaßen vor:


Parameterliste drucken

Die Druckformat-Einstellungen bedeuten:

  • Standard = alle Parameter werden in einer Klartextliste ausgegeben.
  • Programmierer = alle Parameter werden in einer Liste mit Programmierinformationen (z.B. Hex-Wert, Datentyp, Speicherart etc.) gedruckt.
  • Benutzerdefiniert = über „Formatierung" können einzelne Parameter und Sachgebiete zum Ausdrucken bestimmt werden.


Datensatz

Im Offline-Betrieb oder parallel zu einem angeschlossenen Antriebsregler kann ein Datensatz geöffnet (siehe "Gerät an PC anschließen") und bearbeitet werden. Mit dem Datensatz kann genau wie im Kapitel siehe "Antriebsregler einstellen" verfahren werden:
Der geöffnete Datensatz kann über die Funktionsmaske verändert werden und die Einstellungen gespeichert werden.


Datensätze vergleichen

Es können auch zwei Datensätze miteinander verglichen werden.


Datensatz drucken

Um die Einstellungen (Parameterliste) des Datensatzes auszudrucken, gehen Sie bitte folgendermaßen vor:


Parameterliste drucken

Die Druckformat-Einstellungen bedeuten:

  • Programmierer = alle Parameter werden in einer Liste mit Programmierinformationen (z.B. Hex-Wert, Datentyp, Speicherart etc.) gedruckt.
  • Benutzerdefiniert = über „Formatierung" können einzelne Parameter und Sachgebiete zum Ausdrucken bestimmt werden.


Antriebsregler steuern

Sie können den angeschlossenen Antriebsregler über den DriveManager direkt steuern. Voraussetzung ist, dass über die Steuerklemme des Antriebsgerätes die Hardwarefreigabe (ENPO) erteilt ist (bei Geräten mit Sicherem Halt zuerst Sicheren Halt und dann ENPO erteilen). Gehen Sie folgendermaßen vor:

    1. Wählen Sie die Regelungsart.
    2. Im Feld „Sollwert" geben Sie die Drehfeldfrequenz bzw. die Umdrehungen pro Minute vor.
    3. Mit dem Klicken auf den Button „Starten" fährt Ihr Antrieb hoch.
    4. Am Bargraph „Betrag des Istwertes" können Sie diesen Vorgang beobachten.
    5. Mit dem Klicken auf den Button „Stoppen" bremst der Antrieb auf Drehzahl 0 und sperrt die Endstufe.


Scopefunktion

Mit dem Digital Scope können Sie zeitliche Verläufe von Regelgrößen aufzeichnen. Dies ist nützlich bei der Inbetriebnahme von geregelten Systemen (Sprungantwort) oder zum Erkennen von Fehlern.

Das Digital Scope verfügt über vier Kanäle, denen Sie die gewünschten Messgrößen zuordnen können.

Im Fenster „Trigger" legen Sie fest, auf welches Ereignis die Aufnahme auslösen soll. Mit der Funktion „Pretrigger" beginnt die Aufzeichnung vor dem eigentlichen Triggerzeitpunkt, z.B. 10 % bezogen auf die Aufnahmedauer. Der Button „Manuell Triggern" löst das Ereignis zur Aufnahme aus.

Im Fenster „Zeit" können Sie mit der Funktion

  • Aufnahmefenster (Dauer) die gewünschte Dauer der Aufnahme vorgeben (für zeitlich längere Ereignisse), oder
  • Zeit pro Abtastwert (Basis) den zeitlichen Zyklus in dem die Größen gemessen werden sollen bestimmen (geeignet für sehr schnelle Signaländerungen).

Im Fenster „Aufnahmeserie" wählen Sie, ob Sie nur eine einzelne Aufnahme oder eine Aufnahmeserie machen wollen.

Im Fenster „Optionen" wählen Sie die Darstellungsform der Aufnahme:


Interne Autoscale-Funktion

Die „Interne Autoscale-Funktion" erstellt ein Plot-Fenster. Die Messwerte einer einzelnen Messung werden in einem Graphen dargestellt, der gespeichert und gedruckt werden kann.


Externer Scope Wizard

Der „Externe Scope Wizard" öffnet ein neues Fenster, in dem mehrere Aufnahmen verglichen und überwacht werden können.

Die Darstellung des Graphen kann über die „Zoom"-Werkzeuge beliebig verkleinert und vergrößert werden. Mit dem „Messen"-Werkzeug können zwei Messpunkte gesetzt werden, (Wechsel zwischen den Messpunkten mit Tab-Taste) deren exakte Werte der Scope Wizard anzeigt und deren Differenz berechnet.
Die Achsenbelegung des Graphen kann durch Doppelklick auf das jeweilige Farbkästchen des Kanals beliebig belegt werden. Die Skalierung der Achse passt sich automatisch dem Kanal an.
Die Darstellung des Graphen kann als Referenzdatei abgespeichert werden („Einstellungen\Aktuelle Datei als Default-Datei") und später zum Vergleich mit anderen Messungen wieder aufgerufen werden.
Die Scope Wizard-Datei kann abgespeichert und gedruckt werden.


Aufnahme starten
    1. Einstellungen im Fenster „Digital Scope" vornehmen
    2. Button „Aufnahme starten"
    3. Im Fenster „Steuern" löst der Button „Starten" die Aufnahme aus.


Aufnahme speichern oder drucken

Über das Menü „Datei\sichern als" bzw. „Datei\speichern unter" können Sie Ihr Aufnahmeergebnis speichern.

Wählen Sie im Menü „Datei\Drucken", um das Aufnahmeergebnis zu drucken.


Gerätesoftware laden

Die Gerätesoftware (Firmware) kann über den DriveManager in die jeweiligen Antriebsregler geladen werden. Die jeweils aktuelle Firmware finden Sie auf der Lust-Homepage ( www.lust-tec.de) unter „Service>Downloads".


Firmware von Homepage laden

Von der Lust-Homepage laden Sie die Firmware (ZIP-Datei) auf Ihren PC mit installiertem DriveManager. Entpacken Sie die ZIP-Datei mit einem gebräuchlichen Entpacker wie z. B. WinZip.

In Abhängigkeit des Gerätes besteht die ZIP-Datei aus verschiedenen Dateien. Die Firmware-Datei hat die Endung .HEX. Die erste Ziffer des Dateinamens steht für die Gerätefamilie, die nächsten drei Ziffern für die Softwareversion.

Tabelle: Übersicht Gerätefamilien
Gerätefamilie
Gerätetyp
Version
1
CDE3000
Die Version wird hochgezählt bei Veränderung bzw. Erweiterung von Funktionen und Parametern.
2
CDF3000
3
CDA3000
4
CDD3000
5
CDB3000

Speichern Sie die HEX-Datei im entsprechenden Geräteordner unter „userdata\samples". Ist eine MCW-Datei vorhanden, muss diese im Ordner „firmdata" gespeichert werden. Alle restlichen Dateien wie z. B. .PIT- oder .TXT-Dateien legen Sie bitte im Ordner „language\049" (049 für deutsch) ab.


Firmware in Antriebsregler laden

*Bis DriveManager-Version V3.45 und älter kann in jeder Benutzerebene die Firmware in den Antriebsregler geladen werden.

Schließen Sie den Antriebsregler an Ihren PC mit installiertem DriveManager an (siehe "Gerät an PC anschließen"). Um die benötigte HEX-Datei zu öffnen gehen Sie wie folgt vor:

Die Firmware wird nun in den Antriebsregler geladen. Dies kann einige Minuten dauern.