Front

NAVIGATION: Device Help / Front

Device Help

Single-Axis system

Multi-Axis System

Junior

see: / Legal notice /

see: / Using the Help /

see: / Initial commissioning - Rotary system /

see: / Initial commissioning - Linear system /

Copyright © LTi DRiVES GmbH 2011


Legal notice

  • LTi DRiVES GmbH provides the information and subject area listings contained in the Online Help as a service. LTi DRiVES GmbH gives no guarantee that the information provided will achieve the desired results in your specific application environment.

  • The decision as to whether to use the information provided - and if so, in what form - is entirely yours.

  • The specialist personnel must ensure that the application or usage of the products described conforms to the technical specifications set out in the Installation Guide and the Operation Manual, as well complying with all safety requirements, including applicable laws, rules, regulations and standards.

  • The Online Help was compiled with due diligence. However, the products described are continually being developed and improved. Consequently, the Online Help may not always be fully verified as conforming to the functionality, standards or other features specified.

  • The statements made in this document do not embody a guarantee under the terms of Article 443 of the German Civil Code (BGB) or a specification of contractually required usage under the terms of Article 434 paragraph 1, clause 1, no. 1 BGB.

  • If the Online Help contains any factual or typographical errors, we reserve the right to make changes at any time and without prior notice.

  • The content of this Online Help is provided merely for information purposes. It may be changed without prior notice at any time, and in no way imposes any obligation upon LTi DRiVES GmbH.

  • The information, illustrations and descriptions contained in this document cannot be used as justifiable grounds for modification of already delivered products.

  • Excepting legal liability in respect of wilful intent, gross negligence, fulfilment of guarantee claims, attributable injury to life, limb or health, or in relation to claims pursuant to product liability legislation, any liability of LTi DRiVES GmbH in connection with your use of this information is hereby excluded.

Copyright

  • ©; This Online Help is protected by copyright. It must not be disclosed or distributed, or used by third parties, in whole or in part, without the written consent of LTi DRiVES GmbH.


Using the Help

Content:

The Help is identical in terms of content to the ServoOne Application Manual. It sets out the software functions of the ServoOne device family.

--------------------------------------------------------------------------------

ServoOne device family:

  • ServoOne single-axis system
  • ServoOne multi-axis system
  • ServoOne Junior

The control electronics of the individual devices are identical, and are grouped together in a single Help.

---------------------------------------------------------------------------------

Available output formats:

Help (html, chm, pdf)

Application Manual (pdf)

---------------------------------------------------------------------------------

Additional aids:

DriveManager 5 Help:

----------------------------------------------------------------------------------

Topic structure:

Topics project tree:

The layout of the topics corresponds to the subject areas in the project tree of the DriveManager 5.
This provides transparency for navigation between subject areas (DriveManager 5) and topics (Help).

Navigation bar:

Always displays the path of the current open topic.

If possible, a topic comprises:

  • Descriptive text

  • Screenshots

  • DriveManager 5

    user interface dialog boxes
  • Methodology: It is always in red type, and underlined in grey: The individual steps necessary to perform a function are listed.

  • Parameter table

  • Notes:
    • This presents general points of note, special advisory notices or indications of hazards, dependent on the specific icon.

  • Links to other relevant topics
    (always shown in blue)
    Example:
    see: / Initial commissioning - Rotary system /

----------------------------------------------------------------------------------------

Menu bar:

Key to functions of menu bar icons:

Icon | Function
 | Go forward/back
 | Go to home page
 | Save current topic as favourite Open favourites list
 | Table of contents
 | Index
 | Search function
 | Folders can also be opened by clicking these buttons.


General notes

Dear user,

We are happy that you have made a decision in favour of a product from LTi. In order to

be able to start using your new ServoOne quickly and without problems,

we ask you kindly to read this Operation Manual thoroughly beforehand.

Subject to technical change without notice

The content of our documentation was compiled with the greatest care and attention, and based on the latest information available to us. We should nevertheless point out that this document cannot always be updated in line with ongoing technical developments in our products. Information and specifications may be subject to change at any time.

Please visit www.lt-i.com for details of the latest versions.

The instructions set out below should be read through prior to initial commissioning

in order to prevent injury and/or damage to property. The safety instructions must be

followed at all times.

Read the Operation Manual first!

Follow the safety instructions!

Refer to the user information!

Electric drives are dangerous:

Electrical voltages of 230 V to 890 V
Dangerously high voltages ≥ 50 V may still be present 30 minutes after the power is cut (capacitor charge).

So check that the power has been cut!

Rotating parts

Hot surface

Protection against magnetic and/or electromagnetic fields during installation and operation.

Persons fitted with heart pacemakers, metallic implants and hearing aids etc. must not be allowed access to the following areas:
Areas where drive systems are installed, repaired and operated.
Areas where motors are installed, repaired and operated. Motors with permanent magnets pose a particular hazard.
Note: If it is necessary to access such areas, suitability to do so must be determined beforehand by a doctor

Your qualification:

In order to prevent personal injury and damage to property, only personnel with electrical engineering qualifications may work on the device.

The said qualified personnel must be familiar with the contents of the Operation Manual (cf. IEC 364, DIN VDE 0100).

Awareness of national accident prevention regulations (e.g. BGV A3 in Germany)

During installation observe the following instructions:

Always comply with the connection conditions and technical specifications.

Comply with the standards for electrical installations, such as regarding wire cross-section, protective earth conductor and earth connections.

Do not touch electronic components and contacts (electrostatic discharge may destroy components).


Symbols

Symbols used

The safety instructions detail the following hazard classes.
The hazard class defines the risk posed by failing to comply with the safety notice.

Warning symbols | General explanation | Hazard class to ANSI Z 535
 | ATTENTION! Misoperation may result in damage to the drive or malfunctions. | Serious injury or damage to property may occur.
 | DANGER from electrical tension! Improper behaviour may endanger human life. | Death or serious injury will occur.
 | DANGER from rotating parts! The drive may move automatically. | Death or serious injury will occur.

Intended use

ServoOne drive controllers are built-in units intended for installation in stationary electrical, industrial and commercial plant or machinery.

When installed in machines the commissioning of the drive controller (i.e. start-up of intended operation) is prohibited, unless it has been ascertained that the machine fully complies with the Machinery Directive 2006/42/EC; compliance with EN 60204 is mandatory.

Commissioning - i.e. putting the device to its intended use - is only permitted in compliance with the EMC Directive (2004/108/EC).

The ServoOne drive controller conforms to the Low Voltage Directive 2006/95/EC.

The drive controllers conform to the requirements of the harmonized product standard EN 61800-5-1:2003.

If the drive controller is used for special applications (e.g. in areas subject to explosion hazard), the required standards and regulations (e.g. EN 50014, "General provisions" and EN 50018 "Flameproof enclosure") must always be observed.
Repairs may only be carried out by authorized repair workshops. Unauthorized opening and incorrect intervention could lead to death, physical injury or material damage. The warranty provided by LTi DRiVES GmbH would thereby be rendered void.

Deployment of the drive controllers in non-stationary equipment is classed as non-standard ambient conditions, and is permissible only by special agreement.

Responsibility:

Electronic devices are fundamentally not fail-safe. The company setting up and/or operating the machine or plant is itself responsible for ensuring that the drive is rendered safe if the device fails.

EN 60204-1/DIN VDE 0113 "Safety of machines", in the section on "Electrical equipment of machines", stipulates safety requirements for electrical controls. They are intended to protect personnel and machinery, and to maintain the function capability of the machine or plant concerned, and must be observed.

The function of an emergency off system does not necessarily have to cut the power supply to the drive. To protect against danger, it may be more beneficial to maintain individual drives in operation or to initiate specific safety sequences. Execution of the emergency stop measure is assessed by means of a risk analysis of the machine or plant, including the electrical equipment in accordance with EN ISO 14121 (previously DIN EN 1050), and is determined in accordance with EN ISO 13849-1 (previously DIN EN 954-1), "Safety of machines - Safety-related parts of controls" by selecting the circuit category.


Initial commissioning - Rotary system

The assistant is used for chronological navigation through the subject areas relevant to initial commissioning. Setting the parameters correctly enables controlled movement of the drive by way of the manual mode window.
For highly dynamic drive systems further settings must be made.

Hardware requirements:

  • Correct installation and wiring

    As instructed in the Operation Manual
  • Voltage supply:

    Mains voltage

    24 V control voltage
  • Hardware enable:

    Safe Standstill: ISDSH

    Enable Power: ENPO

If DriveManager 5 is opened with no project, a prompt appears asking if you want to carry out initial commissioning.

If this pop-up does not appear automatically, but you want to carry out commissioning using the assistant, you can also open the commissioning window by clicking the icon or by way of the project tree.

Opening by clicking the commissioning icon:

Opening by way of the project tree:

Select "Initial Commissioning" to open the commissioning window.

Commissioning window:

Click the relevant buttons and follow the on-screen instructions:

If the drive moves in an uncontrolled manner, or does not move at all, the parameter inputs must be checked.

Commissioning instruction

Action

Subject area
  • Selection of motor

 Decision whether to use a synchronous motor (PSM) or an asynchronous motor (ASM).

  • Selection of motor system
 Decision whether to use a rotary or linear motion system.

  • Identification of motor

If the motor data set is known no motor identification is carried out.

Identification:

  • Measurement of:
    Stator resistance
    Rotor resistance
    Leakage inductance
  • Current controller tuning
  • Calculation of nominal flux

  • Motor protection
  • Setting the I2xt monitor
  • Selection of temperature sensor
  • Characteristic setting

  • Encoder setting
  • Encoder selection
  • Channel selection

  • Motor test via
    manual mode window

Opening the manual mode window

  • Control mode VFC (open loop)
  • Move motor at low speed
  • Check direction

  • Control setting
  • Optimize current controller using integrated test signal generator
  • When there is a motor data set the current of the test signal generator is set automatically.
  • Optimize speed controller
  • Determine mass inertia [J]
  • Set speed filter: P 0351 CON_SCALC_TF = WE (0.6 ms) Recommendation: SinCos encoder 0.2 ms - 0.6 ms Resolver 0.6 ms - 1.5 ms
  • Adapt control parameters to mechanism
    (adjust rigidity)
  • Establish marginal conditions
  • Scaling, IOs, field buses, etc.


Initial commissioning - Linear system

The assistant is used for chronological navigation through the subject areas relevant to initial commissioning. Setting the parameters correctly enables subsequent controlled movement of the drive by way of the manual mode window.

For exact adaptation of the drive system to an application, further settings need to be made.

Hardware requirements:

  • Correct installation and wiring

    As instructed in the Operation Manual
  • Voltage supply:

    Mains voltage

    24 V control voltage
  • Hardware enable:

    Safe Standstill: ISDSH

    Enable Power: ENPO

If DriveManager 5 is opened with no project, a prompt appears asking if you want to carry out initial commissioning.

If this pop-up does not appear automatically, but you want to carry out commissioning using the assistant, you can also open the commissioning window by clicking the icon or by way of the project tree.

Opening by clicking the initial commissioning icon:

Opening by way of the project tree:

Select "Initial Commissioning" to open the commissioning window.

Commissioning window:

Click the relevant buttons and follow the on-screen instructions:

If the drive moves in an uncontrolled manner, or does not move at all, the parameter inputs must be checked.

Commissioning instruction

Action

Subject area
  • Selection of motor
  • Parameter P 0450 MOT_Type is automatically set to PSM if parameter P 0490_MOT_IsLinMot = LIN(1).

  • Selection of motor system
  • Selection for a linear motion system with P 0490 = LIN(1).

  • Identification of motor

Data set calculation:

  • Fill out "Calculation of control setup for linear PS motors" dialog box and start calculation.

  • Motor protection
  • Setting of I2xt monitor
  • Selection of temperature sensor
  • Characteristic setting

  • Encoder setting
  • Encoder selection
  • Channel selection

  • Motor test via
    manual mode window

Opening the manual mode window

  • Control mode VFC (open loop)
  • Move motor at low speed
  • Check direction

  • Control setting
  • Optimize current controller (test signal generator)
  • When there is a motor data set the current of the test signal generator is set automatically.
  • Optimize speed controller
  • Determine mass inertia [J] (basic settings)
  • Set speed filter: P 0351 CON_SCALC_TF = (0.6 ms) Recommendation:
    SinCos encoder 0.2 ms - 0.6 ms
    Resolver 0.6 ms - 1.5 ms
  • Adapt control parameters to mechanism
    (adjust rigidity).
  • Establish marginal conditions
  • Scaling, IOs, field buses, etc.


Power stage setting

The power stages of the controller can be operated with different voltages and switching frequencies. The voltage and the switching frequency must be adapted to the conditions. The power stage is adapted to the application conditions by way of the dialog box list boxes.

Power supply

For single-axis applications only the settings (0)-(5) are allowed. All other settings should be used for multi-axis systems. Not all switching frequencies can be used on higher-powered devices. An excessively high switching frequency setting in conjunction with high powers may result in a power reduction.

Switching frequency

The switching frequency is set via P 0302 CON_SwitchFreq. It is advisable initially to operate the drive controller with the default setting.

Increasing the switching frequency can be useful to improve the control dynamism. However, it may under some circumstances result in a temperature-related loss of power. Switching frequency noise decreases as the switching frequency rises (audible range < 12 kHz). For an overview of the currents dependent on the switching frequency refer to the Operation Manual.

The combination of voltage value and switching frequency describes a stored power stage data set.

Any changes to parameters must be saved in the device. The setting is only applied on the device after a power off/on cycle. If the power stage parameters are changed, the rated currents, overload values and brake chopper thresholds may also change.

P. no. | Parameter name/ Setting | Description
P 0302 | CON_SwitchFreq | Power stage switching frequency setting
 | 2 kHz - 16 kHz | It is advisable to operate the drive controller with the default setting. Increasing the switching frequency can be useful to improve the control dynamism. Temperature-related derating may occur. Switching frequency noise decreases as the switching frequency rises (audible range < 12 kHz).
P 0307 | CON_ VoltageSupply | Adaptation to the voltage conditions
 | 1x 230 V(0) |
 | 3x 230 V(1) |
 | 3x 400 V(2) |
 | 3x 460 V(3) |
 | 3x480 V(4) |
 | Safety low voltage 24-60 V(5) |
 | All other settings are only allowed in conjunction with multi-axis systems!


Motor, general

Actuation of synchronous and asynchronous motors

Designs:

  • Rotary motors
  • Linear motors

When using LTi controllers, the actuated motors are protected against thermal damage if they are configured with a temperature sensor connected to the controller.

Selection of temperature sensors:

  • KTY(84)-130
  • PTC(2) = PTC sensor with short-circuit monitoring
  • TSS(3) Switch Klixon
  • PTC(4) PTC sensor without short-circuit monitoring
  • NTC 220 = NTC sensor 220 kΩ (on request)
  • NTC 1000 = NTC sensor 1000 kΩ (on request)

see: / Thermal monitoring /

see: / Characteristic PSM /

see: / Characteristic ASM /

To put a system into operation quickly and easily, and to achieve good control dynamism, it is advisable to use standard motors and encoders from the motors catalogue.

(www.lt-i.com Downloads\Servomotoren\LSH/LST Synchron-Servomotoren\Bestellkatalog)

In the case of third-party motors, basic suitability for operation with LTi controllers must first be verified on the basis of the motor data and the data of any installed encoder. The values of the parameters for adaptation of the controller must be determined specifically for each motor by calculation or identification. The difference between the two methods is that when calculating a motor data set the impedances must be taken from the data sheet. In identification the impedances are measured automatically. Each motor can only be operated if its field model and the control parameters are correctly set.

see: / Initial commissioning - Rotary system /

see: / Initial commissioning - Linear system /

see: / PS motor - standard /

see: / PS motor - rotary /

see: / PS linear motor /

see: / PS third-party motor /

see: / AS motor /


PS motor - rotary

Determining the motor data

There are two methods of determining a motor data set for the rotary synchronous motor.

Variant 1: Motor identification

Variant 2: Motor calculation

Identification

  • Enter motor data
  • Click "Identification" button
  • Current controller tuning: The current controller is automatically optimized.
  • The rotor resistance P 0476 MOT_Rrot and the stator inductance P 0471 MOT_LSig are measured automatically. The measured electrical data of the motor are sufficient to run the motor below its rated current.

Calculation

  • Enter motor data
  • Click the "Calculation" button.
    The motor data relevant to the calculation must be entered manually from the data sheet. Click the "Start calculation" button to determine the rotor resistance P 0476 MOT_Rrot and leakage inductance P 0471 MOT_LSig.
  • If the mass moment of inertia of the motor P 0461 Mot_J is not known, a value roughly corresponding to the motor's mass moment of inertia must be applied. Click the "Calculation" button to start the calculation.
  • The calculation process be observed on the DriveManager 5 by choosing the View, Messages menu.
  • Measurement of the saturation characteristic (table values of the stator inductance P 0472_NMOT_LSigDiff).
    Measurements are taken up to four times rated current, provided the power stage current permits it at standstill. If it does not, the measurement is taken with a correspondingly lower current.
  • Calculation of operating point:
    P 0462 MOT_FLUXNom nominal flux, P 0340 CON_FM_Imag magnetizing current
  • Calculation of: current, speed and position control parameters

Calculated variables:

  • Flux settings (including for torque constant)
  • Control settings for current controller:
    The current controller is dimensioned dependent on the switching frequency setting.
  • Speed controller and position controller gain:
    In this, a moderately rigid mechanism and a 1:1 mass moment of inertia adjustment from the load to the motor are to be assumed.

Recommended:

It is advisable to use motor identification to determine the motor data. The rotor resistance and the leakage inductance do not need to be known for this, as they are measured in this procedure. If motor identification fails, or if the motor is physically not present, motor calculation provides a second sufficiently good method of determining the motor data set.

All existing control parameters are overwritten.

P. no. | Parameter name | Function
P 0490 | MOT_IsLinMot | Selection for rotary or linear system
P 0450 | MOT_Type -> PSM | Motor type (ASM, PSM)
P 0451 | MOT_Name 1) | Freely selectable motor name
P 0455 | MOT_FNom 2) | Rated frequency of the motor
P 0456 | MOT_VNom 2) | Rated voltage of the motor
P 0457 | MOT_CNom 2) | Rated current of the motor
P 0458 | MOT_SNom 2 | Rated speed
P 0459 | MOT_PNom 1) | Rated power
P 0460 | MOT_TNom 2 | Rated torque
P 0461 | MOT_J 2) | Mass inertia of the motor
P 0463 | MOT_PolePairs 2 | Number of pole pairs
P 0470 | MOT_Rstat 2) | Stator resistance: The phase resistance is taken into account in the calculation.
P 0471 | MOT_Lsig 2) | Stator inductance: The stator inductance is taken into account in the calculation.
P1530 | SCD_SetMotor control | Start of calculation
1) The parameters are only of informative nature, but should be set for a complete motor data set. 2) The parameters are used for calculation of controller settings, and have a direct effect on the response of the servocontroller.


PS motor - standard

Motor data (rotary system)

You can obtain the data sets of all standard synchronous motors from the LTi website. On transfer of a standard motor data set the motor name, electrical data and motion mode are loaded. Preset parameters are overwritten. The motor data must then be saved in the device.

The motor parameters specified by the manufacturer ensure that a motor can be subjected to load according to its operational characteristic, provided the corresponding power is supplied by the controller.

Thermal monitoring

Standard motors are thermally monitored by the controller and protected against overheating. To do so, the momentary motor temperature is determined by thermo-sensors built-in to the motor winding.

Consideration must be given to ensuring the matching encoder data and to motor protection.

Procedure: Loading motor data

  • "Select motor data set" button

  • Select data set
  • Enter encoder settings
  • Save data


PS third-party motor

For successful, operationally safe actuation of third-party motors, the following points must be checked:

  • Are the requirements of the motor met by the controller (power, temperature, control performance)
  • Does the encoder evaluation match the controller
  • Is thermal monitoring provided


PS linear motor

Motor data always determined by calculation P 0490 MOT_ISLinRot = LIN(1) The parameter automatically sets the number of pole pairs of the motor to P 0463 Mot_PolrPairs = 1.
Thus one pole pitch unit from north pole to north pole corresponds to one virtual revolution P 049 Mot_MagnetPotch.

The following values are calculated:

  • Translation of the linear nominal quantities into virtual rotary nominal quantities
  • Default values for autocommutation
  • Encoder lines per virtual revolution
  • Flux settings (including for torque constant)
  • Control settings for PI current controller: The current controller is dimensioned dependent on the switching frequency setting.
  • PI-speed controller and position controller amplification: In this, a moderately rigid mechanism and a 1:1 moment of inertia adjustment from the load to the motor are assumed (if total moment of inertia = 0). If the total mass moment is not equal to 0, the calculation assistant is used to calculate the speed controller with the total mass inertia P 1515 SDCD_CON_Design = 100 %.
  • On each change of parameter P 1515 the speed and position controller is recalculated.
  • The default value for speed tracking error monitoring corresponds to 50 % of the nominal speed.
  • V/F characteristic

see: / PS motor - rotary /


AS motor

Electrical data:

For commissioning of AS motors, the rated data and characteristic variables of the motor must be known and be entered manually in the relevant dialog box. When the Identification button is clicked the control parameters are computed. The impedances (stator/leakage impedance) are measured by instrumentation.

If the identification is successful, the torque control is adequately configured. An adjustment to the machine mechanism and to the motion profile is also required.

Electrical data of the ASM

ASM settings

If the mass moment of inertia of the motor P 0461 Mot_J is not exactly known, a value roughly corresponding to the motor's mass moment of inertia must be applied. Click the "Start calculation" button to perform the calculation. The calculation process can be observed on the DriveManager 5 by choosing the View, Messages menu.

Identification sequence:

  • Current controller tuning
  • Measurement of: P 0470 MOT_RST stator resistance, P 0476 MOT_Rrot rotor resistance, P 0471 MOT_LSig leakage inductance
  • Max. effective current Idmax P 0474 MOT_LmagIdNom
  • Calculation of operating point: P 0462 MOT_FLUXNom nominal flux, P 0340 CON_FM_Imag magnetizing current
  • Calculation of: current, speed and position control parameters

All existing motor parameters are overwritten.

Calculation of motor data from rating plate data

Input of rated data as above. Parameter P 0452 MOT_CosPhi must additionally be entered. Start calculation
P 1530 SCD_SetMotorControl = 2

Calculated variables:
Stator resistance P 0470 MOT_Rstat
Leakage inductance P 0471 MOT_Lsig
Main inductance in basic setting range P 0473 MOT_LmagTab
P 0474 MOT_LmagldMax
Flux P 0462 MOT_FluxNom, P 0340 CON_FM_Imag.

see: / Thermal monitoring /


Thermal monitoring

The I2xt monitor enables internally cooled three-phase current motors to be thermally monitored without sensors. No temperature sensor is required. This function does not offer full protection however. I2xt monitoring protects the motor against overheating over its entire speed range. This is especially important for internally cooled motors. When IEC asynchronous standard motors (ASM) are operated for a prolonged period of time at low speed, the cooling provided by the fan and the housing is insufficient. Consequently, for an internally cooled ASM a reduction of the maximum permissible continuous current dependent on the rotation frequency is required. When set correctly, the I2xt monitor replaces a motor circuit-breaker. The characteristic can be adapted to the operating conditions by way of the interpolation points.

I2xt monitor dialog box

P. no. | Parameter name/Setting | Function
P 0731 | MON_MotorTemp_Max | Shut-off threshold for KTY
(0) | Maximum sensor temperature X5 | Factory setting 100 degrees
(1) | Maximum sensor temperature X5 | Factory setting 100 degrees
P 0732 | MON_MotorPTC | Selection of sensor type
(0) | Off(0) | No evaluation
 | KTY(1) | KTY84-130°;
 | PTC(2) | PTC to DIN 44081 with short-circuit monitoring
 | TSS(3) | Klixon switch
 | PTC 1(4) | PTC to DIN 44081 without short-circuit monitoring
 | Not used(5) |
 | NTC 220 (6) | NTC sensor 220 kΩ2)
 | NTC 1000 (7) | NTC sensor 1 MΩ2)
 | NTC 227 (8) | NTC sensor 32 kΩ2)
(1) | Connection | Termination variant
 | X5(0) | Connection of the sensor to terminal X5
 | X6/(1) | Sensor connection is routed in encoder cable
(2) | Off(0) | No evaluation
 | KTY(1) | KTY84-130°;
 | PTC(2) | PTC to DIN 44081 with short-circuit monitoring
 | TSS(3) | Klixon switch
 | PTC 1(4) | PTC to DIN 44081 without short-circuit monitoring
 | Not used(5) | Not used
 | NTC 220 (6) | NTC sensor 220 kΩ2)
 | NTC 1000 (7) | NTC sensor 1 MΩ2)
 | NTC 227 (8) | NTC sensor 32 kΩ2)
P 0733 | MON_MotorI2t | I2t characteristic setting
(0) | Inom [%](0) | Rated current of the motor
(1) | I0 [%](1) | First current interpolation point of motor protection characteristic: Maximum permissible standstill current
(2) | I1 [%](2) | Second current interpolation point of motor protection characteristic referred to maximum characteristic current
(3) | F1 [Hz](3) | First frequency interpolation point of motor protection characteristic
(4) | FN / F(f) [Hz] (4) | Rated frequency
(5) | Imax [%](5) | Max. overload current referred to rated motor current
(6) | Time [sec](6) | Time for which the maximum current may be connected
 | 1) With the ServoOne the temperature sensor cable can be connected to both X6 and X7. 2) Does not apply to the ServoOne Junior

Thermal monitoring by a temperature sensor

The device can evaluate different temperature sensors. With P 0732 MON_MotorPTC the sensor fitted in the motor and the wiring variant are set (sensor cable routed in resolver or separate). In an evaluation via KTY, the shut-off threshold of the motor temperature can additionally be set.

The following temperature sensors are prepared for evaluation:

  • KTY(84)-130
  • PTC(2) = PTC sensor with short-circuit monitoring
  • TSS(3).= Klixon
  • PTC(4) PTC sensor without short-circuit monitoring
  • NTC 220 = NTC sensor 220 kΩ (on request) not for junior
  • NTC 1000 = NTC sensor 1000 kΩ (on request) not for junior
  • NTC 227 = NTC sensor 32 kΩ not for junior


Characteristic ASM

The following diagram shows a typical characteristic setting for an internally cooled asynchronous machine. For third-party motors the motor manufacturer's specifications apply.
It is necessary to adapt the I2xt characteristic because the factory setting mostly does not exactly map the present motor. The difference between the factory setting and the characteristic configured above is shown in the following illustrations.

Frequency | Motor current
f0 = 0 Hz | I0 = 30% of IN
f1 = 25 Hz | I1 = 80% of IN
fN = 50 Hz | IN = 100%

Default setting:

The schwitch-off point to VDE 0530 for IEC asynchronous standard motors corresponds to:

150 % x IN for 120 s.

For servomotors, it is advisable to set a constant characteristic. The switch-off point defines the
permissible current-time area up to switching off.

The limits are specified in the servocontroller as percentages of the rated quantities (e.g. current, torque, speed,...) of the motor. The defaults relate to 100 % of the rated quantities.


Characteristic PSM

Characteristic setting for a permanently excited synchronous motor (PSM)

A synchronous motor by design has lower loss than an ASM ( because permanent magnets replace the magnetizing current). It is normally not internally cooled, but discharges its heat loss by internal convection. For that reason it has a different characteristic to an asynchronous motor.
It is necessary to adapt the I2xt characteristic because the factory setting mostly does not exactly map the present motor. The difference between factory setting and the characteristic configured above is shown in the following illustration.

Typical setting for the synchronous machine

Frequency | Motor current
f0 = 0 Hz | I0 = 133.33 % of IN
f1 = 250 Hz | I1 = 100 % of IN
fN = 250 Hz | IN = 100 %

The following diagram shows a typical setting for the permanently excited synchronous machine.

Default setting:

If the integrator exceeds its limit value, the error E-09-01 is triggered. The current value of the integrator is indicated in parameter P 0701(0) Mon_ActValues.


Channel 2 Resolver X6

Channel 2 evaluates a resolver.

Functions of encoder channel 2:
A 14-bit fine interpolation over one track signal period takes place. The pole pairs are set via P 0560 ENC_CH2_Lines.

P. no. | Parameter name, settings | Function
P 0506 | ENC_CH2_Sel | Interface configuration
(0) | OFF | No evaluation
(1) | RES | Resolver evaluation
(2) | SinCos | Resolver excitation shut-off; evaluation of a SinCos encoder or Hall sensor possible. Only on request!
P 0512 | ENC_CH2_Num | Numerator of gear ratio
P 0513 | ENC_CH2_Denom | Denominator of gear ratio
P 0560 | ENC_CH2_Lines | Parameterization of number of pole pairs of resolver
P 0561 | ENC_CH2_Corr | Activation of encoder correction GPOC
P 0563 | ENC_CH2_EncObsMin | Amplitude monitoring Minimum
P 0564 | ENC_CH2_Info | Encoder name
P 0565 | ENC_CH2_LineDelay | Correction of phase shift with cable lengths > 50 m (only following consultation with LTi).
P 0566 | ENC_CH2_Amplitude | Correction of amplitude with cable lengths > 50 m (only following consultation with LTi).
P 0567 | ENC_CH2_EncObsAct | Amplitude of analog signal

see: / Phase shift of resolver signals /


Pin assignment - terminal X6

X6 | Pin no. | Resolver | Function
 | 1 | Sin + | (S2) Analog differential input track A+
 | 2 | Refsin | (S4) Analog differential input track A
 | 3 | Cos + | (S1) Analog differential input track B+
 | 4 | Us +5 V + 12 V | max 250 mA: In the case of a Hiperface encoder on X7 - that is, when "Us-Switch" are connected via X7.(7) and X7.(12) - +12 V / 100 mA is connected to X7.(7) and X7.(12). ***
 | 5 | ϑ + | PTC, KTY, Klixon
 | 6 | Ref + | (R2) Analog excitation at (8 KHz
 | 7 | Ref - | (R2) Analog excitation
 | 8 | Refcos | (S3) Analog differential input track B
 | 9 | ϑ - | PTC, KTY, Klixon

(***) In the case of a Hiperface encoder on X7 (US Switch jumpered via X7.7 and X7.12), +12 V is connected to X6.4 rather than +5 V.

This may destroy the resolver.


Encoder correction GPOC

Encoder correction (Gain Phase Offset Correction)

For channels 1 and 2 the correction method GPOC can be activated for the analog track signals. This enables the mean systematic gain, phase and offset errors to be detected and corrected. GPOC weights the amplitude of the complex pointer described by the track signals by special correlation methods. The dominant errors can thereby be determined very precisely, with no interference from other encoder errors, and then corrected.

Variants for encoder correction.

CORR: Track signal correction with stored values

ADAPT: Track signal correction with online value tracking

Where multiple encoders are in use, it is advisable to apply the method for the encoder used to determine the speed signal.

Parameters for encoder correction based on the example of channel 1:

P. no. | Parameter name, settings | Function
P 0549 P 0561 P 0586 | ENC_CH1/2/3_Corr | Selection of correction method
(0) | OFF | No method selected
(1) | CORR | Activate correction with stored values
(2) | ADAPT | Autocorrection
(3) | RESET | Reset values
P 0550 P 0562 P 0587 | ENC_CH1/ 2/3_CorrVal | Signal correction /Values obtained
(0) | Offset A | Identified offset of track signal A
(1) | Offset B | Identified offset of track signal B
(2) | Gain A | Identified gain correction factor for track signal A
(3) | Gain B | Identified gain correction factor for track signal B
(4) | Phase | Identified phase correction between track signals A and B

Encoder correction method:

  • Open the manual mode window and set speed-controlled mode.
  • Set the optimization speed
    - Resolver: approx. 1000 to 3000 rpm
    - SinCos encoder: approx. 1 to 5 rpm
  • Switch to "ADAPT" during operation and wait about 1-3 minutes for the compensation algorithms to reach their steady state. The speed ripple should decrease after about 1 minute (observed with scope; actual speed value or observation of values in P 0550, P 0562, P 0587, ENC_CH1/ 2/3_CorrVal).
  • Method 1. Procedure: Access the stored values with "CORR" or
  • Method 2. Procedure: Use current correction values with "ADAPT"
  • With the "Reset" setting the values are restored to their factory defaults.
  • Apply setting and save secure against mains power failure.

The setting made with "ADAPT" applies only to the motor with which the function was executed. If the motor is replaced, this method must be applied again.


Channel 1 SinCos X7

Encoder channel 1 is used for evaluation of high-resolution encoders.

Supported encoder types

Incremental encoders:

  • SinCos
  • TTL

Absolute encoders with digital interface:

  • Hiperface
  • SSI (in combination with SinCos signals)
  • EnDat

A 14-bit fine interpolation over one track signal period takes place.

see: / Encoder correction GPOC /

Parameters:

P. no. | Settings | Function
P 0505 | ENC_CH1_Sel | Configuration of the incremental interface
(0) | Off | No evaluation
(1) | SinCos | High-resolution SinCos encoder with fine interpolation
(2) | SSI | Purely digital encoder via serial communication
(3) | TTL | TTL encoder with zero pulse
P 0540 | ENC_CH1_Abs | Determining protocol type: When starting the device and after changing the encoder parameters, the absolute position of an incremental measuring system is read out via a digital interface.
(0) | Off | No evaluation
(1) | SSI | Serial communication to Heidenhain SSI protocol
(2) | EnDat | To Heidenhain EnDat protocol
(3) | Hiperface | To Stegmann-Hiperface protocol
P 0542 | Encoder Channel 1: Number of Lines SinCos-Encoder Value range 1 - 65535 | Setting of the incremental number of lines. For encoders with EnDat and Hiperface protocols the lines per revolution are read out of the encoder and automatically parameterized1.
P 0543 | ENC_CH1_MultiT | Multiturn: Bit width setting
P 0544 | ENC_CH1_SingleT | Singleturn: Bit width setting
P 0545 | ENC_CH1_Code | Selection of coding: Gray/binary 1)
1) With EnDat and Hiperface the information on Singleturn and Multiturn, coding and lines per revolution is read automatically from the encoder (device must detect encoder product ID).


Pin assignment - terminal X7

X7 | Pin no. | SinCos | SSI / EnDat | Hiperface
 | 1 | COS- (A-) | A- | REFCOS
 | 2 | COS+ (A+) | A+ | +COS
 | 3 | + 5 V / max 250 mA | + 5 V / max 250 mA | Jumper between pins 7 and 12 produces a voltage of 12 V / 100 mA on X7/3 ***
 | 4 | - | Data + | Data +
 | 5 | - | Data - | Data -
 | 6 | SIN- (B-) | B - | REFSIN
 | 7 | - | - | Us-Switch
 | 8 | GND | GND | GND
 | 9 | R- | - | -
 | 10 | R+ | - | -
 | 11 | SIN+ (B +) | B+ | + Sin
 | 12 | Sense+ | Sense+ | Us-Switch
 | 13 | Sense- | Sense- | -
 | 14 |  |  |
 | 15 |  |  |

Interconnecting X7 pin 7 (US-Switch) and X7 pin 12 (Us-Switch) increases the voltage to 11.8 V on X7 pin (only for use of a Hiperface encoder).

In the case of a Hiperface encoder on X7 (US-Switch jumpered via X7.7 and X7.12), +12 V is connected to terminal X6.4 rather than +5 V. This may destroy the resolver.

Encoders with a power supply of 5 V +/- 5 % must have a sense cable connection. The sense cables are required to monitor a drop in supply voltage on the encoder cable. Only use of the sensor cables ensures that the encoder is supplied with the correct voltage. Always connect the sense cables! If a SinCos encoder is not delivering sense signals, connect pins 12 and 13 (+ / -Sense) to pins 3 and 8 (+ 5 V/GND) on the encoder cable end.


Absolute value encoder interface (X7)

Not available at time of going to press!


Hall encoder

Not available at time of going to press!


Increment-coded reference marks CH3

In the case of relative encoders with increment-coded reference marks, multiple reference marks are distributed evenly across the entire travel distance. The absolute position information, relative to a specific zero point of the measurement system, is determined by counting the individual measuring increments between two reference marks. The absolute position of the scale defined by the reference mark is assigned to precisely one measuring increment. So before an absolute reference can be created or the last selected reference point found, the reference mark must be passed over. In the worst-case scenario this requires a rotation of up to 360°;. To determine the reference position over the shortest possible distance, encoders with increment-coded reference marks are supported (HEIDENHAIN ROD 280C).

The reference mark track contains multiple reference marks with defined increment differences. The tracking electronics determines the absolute reference when two adjacent reference marks are passed over - that is to say, after just a few degrees of rotation.

Rotary system:

Increment-coded reference measure B, large increment (1001 lines): P 0631 ENC_CH3_NominalIncrementB

Increment-coded reference measure A, small increment (1000 lines): P 0630 ENC_CH3_NominalIncrementA

Zero point

The lines per revolution are entered in parameter P 0572 ENC_CH3_Lines (e.g. 18x1000). A sector increment difference of +1 and +2 is supported.

Linear system:

Reference marks

Pitch periods (TP): P 0572 ENC_CH3_Number of lines

Increment-coded reference measure A (small reference mark increment): P 0630 ENC_CH3_NominalIncrementA

Increment-coded reference measure B (large reference mark increment): P 0631 ENC_CH3_NominalIncrementB

Homing methods for increment-coded encoders:

Method -6: "Negative direction for increment-coded encoder"

Method -7: "Positive direction for increment-coded encoder"


Setting of encoder channel 3

The interface between the encoder and the control is configured by way of the following parameters:

Parameters for encoder configuration:

P. no. | Designation | Function
P 0520 | ENC_MCon | Selection of encoder channel for commutation angle and torque control. Feedback signal for field-oriented regulation.
P 0521 | ENC_SCon | Selection of encoder channel for speed configuration. Feedback signal for speed controller.
P 0522 | ENC_PCon | Selection of encoder channel for position information. Feedback signal for position controller.
P 0523 | ENC_RefCon | Selection of encoder channel to act as master encoder.
Parameter setting for P 0520, P 0521, P 0522, P 0523
(0) | Off | No encoder selected
(1) | Channel 1 | Channel 1: SinCos, SSI, TTL encoder on X7
(2) | Channel 2 | Channel 2: Resolver on X6
(3) | Channel 3 | Channel 3: SinCos, SSI, TTL encoder on X8/Optional TWINsync possible
(4) | Channel 4 virtual | Field bus DS402, virtual channel

Activation of encoder channel 3

Encodertype selection

By way of parameter P 0570 ENC_CH3_Abs the absolute interface for the encoder variants SSI, EnDat, Hiperface is selected.

With parameter P 0507 ENC_CH3_Sel the incremental interface for the SinCos and TTL encoders is selected.

Structure of encoder evaluation:

Parameters:

P. no. | Parameter name, settings | Function
P 0502 (0) | 00...-FF...hex | Raw single-turn data for testing encoder evaluation. The raw data are processed after the electronic gearing and before the scaling (sketch above). Singleturn P 0502(0) ENC_CH3_ActVal and Multiturn P 0502(1) ENC_CH3_ActVal.
P 0502 (1) | 00...-FF...hex
P 0507 (0) | Off | No evaluation
P 0507 (1) | SinCos encoder | Selection of SinCos encoder without absolute information and zero pulse
P 0507 (2) | SSI | Selection of SSI encoder
P 0507 (3) | TTL | Selection of TTL encoder
P 0514 | Numerator | Numerator of encoder gearing
P 0515 | Denominator | Denominator of encoder gearing
P 0570 | Off | No function
P 0571 | On | Zero evaluation activated
P 0572 | Lines per revolution 1-65535 | Setting of number of lines per motor revolution of optical encoder (max. 65535 lines)
P 0573 | MT-Bits 0-25 | Number of bits of multiturn information
P 0574 | ST-Bits 0-25 | Number of bits of singleturn information
P 0575(0) | Binary | Selection of binary code with which the SSI encoder is to be evaluated.
P 0575(1) | Gray | Selection of Gray code with which the SSI encoder is to be evaluated.
P 0577 | 0-0,5 | Sensitivity of encoder signal monitor
P 0588 | 0-1 | Amplitude of analog signal
P 0630 | 0-65535 | Setting of the increment-coded reference marks. These values are given on the encoder data sheet. Nominal increment A
P 0631 | 0-65535 | Setting of the increment-coded reference marks. These values are given on the encoder data sheet. Nominal increment B


Zero pulse evaluation

Zero pulse evaluation can only be used over encoder channels 1 and 3 in conjunction with SinCos encoders if no absolute interface is activated.

P 0505/P 0507 ENC_CH1/3_Sel = SINCOS

P 0540/P 0570 ENC_CH1/3_Abs = Off

  • SinCos encoder: Zero pulse is only outputted if no absolute interface is selected
  • TTL encoder: The zero pulse is always outputted
  • Resolvers output no zero pulse.

If zero pulse evaluation is active, it can only be triggered by selecting the homing methods designed for it.

Test mode for zero pulse detection

Test mode is activated by parameter P 0541/P 0571 ENC_CH1/3_NpTest =1.

Encoder initialization is triggered manually by MPRO_DRVCOM_Init =1.

Homing runs can also be carried out during test mode.

When homing is complete, or after an error, the detection process is stopped. To reactivate test mode, parameter P 0541 /P 0571 must be reset manually to 0, then from 0 to 1, in order to restart the initialization.

To view the zero pulse with the digital oscilloscope, one channel is set to the measurement variable ID 1014 CH1 Np/ID 1035 CH3-Np-2 (index pulse length 1 ms).

The pulse width of the scope signal does not match the pulse width of the actual zero pulse. The representation on the scope appears wider (1 ms when using measurement variable ID 1014 CH1 Np/ID 1035 CH3-Np-2), enabling better detection of the zero pulse. The decisive factor here is the rising edge of the scope signal.


Pin assignment - SinCos module

The SinCos module enables evaluation of high-resolution encoders. A track signal period is interpolated at a 14-bit resolution (fine interpolation).

Technical data and terminal assignment

The following encoder variants can be evaluated: They are identical to encoder channel 1.

Connection Function

SinCos encoder with zero pulse without absolute information e.g. Heidenhain ERN1381, ROD486

  • U = 5 V +/- 5%
  • I = 250 mA.

Heidenhain SinCos encoder with EnDat interface:
Encoder data are recorded just once on initialization, e.g.

  • 13-bit singleturn encoder ECN1313-EnDat
  • 25-bit multiturn encoder EQN1325-EnDat

When using two identical encoders, so as to obtain optimum control performance the encoder for the speed should be connected to channel 1 and the encoder for the position to channel 3.

Pin assignment

Connection | Terminal X8 pin no. | SinCos encoder function | Absolute encoder EnDat
 | 1 | A- | A-
 | 2 | A+ | A+
 | 3 | +5 V (+/-) 5 %, Imax = 250 mA regulated; a voltage variation on the encoder is passed on via the sense cables to the voltage regulator.
 | 4 | - | Data +
 | 5 | - | Data -
 | 6 | B - | B -
 | 7 | GND | GND
 | 8 | R- | -
 | 9 | R+ | -
 | 10 | B+ | B+
 | 11 | + Sense cable | -
 | 12 | - Sense cable | -
 | 13 | - | CLK+
 | 14 | - | CLK-

The 5 V sense voltage counteracts a voltage drop on the encoder cable. Only by using the sense cable can it be ensured that the encoder is being supplied with the correct voltage. Always connect the sense cable! If a SinCos encoder is not delivering sense signals, connect pins 12 and 13 (+ / -Sense) to pins 3 and 8 (+5 V / GND) on the encoder cable end.


Parity bit

A parity bit can optionally be suffixed after the user data. The parity bit

is transferred after the least significant bit (LSB). The parity bit is

enabled via parameter P 2805 TOPT_SSI_ParityEnable. The parity is set either as "odd" or "even".


Pin assignment - SSI encoder simulation

The pinout for SSI encoder simulation is executed in a 9-pin SUB-D connector with the following assignment:

Pin | Assignment
1 | -
2 | -
3 | GND
4 | CLK-
5 | Data +
6 | -
7 | -
8 | CLK+
9 | Data -


Synchronization of scan cycle

Where the SSI information is scanned at equidistant time intervals it is possible to synchronize the control cycle of the ServoOne to the scan cycle. The synchronization is executed to the first clock edge of a transfer. When using synchronized mode, it is important that the read cycle of the PLC is an integer multiple of the speed control cycle. Synchronized scanning ensurs that actual position values polled at the equidistant time intervals can be transferred to the higher-level PLC.
If multiple synchronized ServoOne units are scanned simultaneously, all actual position values are generated at the same time.
Synchronization is enabled by way of parameter P 2808 TOPT_SSI_SyncUse. Parameter P 2809 TOPT_SSI_InSync displays the synchronization status.


SSI module features

Using SSI encoder simulation, the current actual position of the drive can be read by a higher-level PLC. The ServoOne then behaves like an SSI encoder in relation to the PLC. SSI encoder simulation uses the technology board slot (X8). The technology board is automatically detected.

  • Parameterizable number of multi-turn and single-turn bits (32 bits)
  • Transfer: Binary
  • Clock rates between 200 kBit/s and 1500 kBit/s
    Sampling time: minimum 125 μs
  • Optional transfer with parity bit (Odd/Even)
  • Optional synchronization of control to read cycle
  • Display of synchronization status
  • Encoder monoflop time: approx. 25 μs
  • Clear parameter structure for quick and easy commissioning

Encoder simulation method:

Configuration of polarity and phase

  • The polarity is determined by the resting level of the clock line:
    P 2803 TOPT_SSI_Polarity = False (clock line level Low)
    P 2803 TOPT_SSI_Polarity = True (clock line level High)
  • The phase defines when the data transfer takes place.
    P 2804 TOPT_SSI_Phase = False (clock line resting at Low level)
    P 2804 TOPT_SSI_Phase = True (clock line resting at High level)

  • The source of the position information is the actual value parameter P 0412 CON_PCON_ActPosition (unit: increments)
  • The number of singleturn bits must not exceed the internal resolution (default: 1048576; 20 bits). The resolution is set by parameter P 0270 MPRO_FG_PosNorm.
  • Multiturn resolution 12-bit, singleturn resolution 20-bit


TTL module features

With the TTL module the following operation modes are possible:

  • Evaluation of a TTL encoder
  • Simulation of a TTL encoder (signals from other encoders are converted into TTL signals and made available as output signals for a slave axis)
  • TTL repeater (evaluation and transmission of incoming TTL signals for additional axes)

To obtain adequate position and speed accuracy, the combined method is used. The method is a combination of edge counting and time measurement. At very low rotation speeds especially, precise determination of the position and speed values is essential.


Technology option X8, general

It is possible to use one of the following encoder types by way of the option slot of one of the following modules.

  • SinCos module
  • TTL module
  • SSI module
  • TWINsync module. The TWINsync module is not an encoder module.

SinCos module

The SinCos module enables evaluation of high-resolution incremental encoders.

A track signal period is interpolated at a 12-bit resolution (fine interpolation).

see: / Pin assignment - SinCos module /

SSI module

Using SSI encoder simulation, the current actual position of the drive controlled by the ServoOne is read by a higher-level PLC. The ServoOne then behaves like an SSI encoder in relation to the PLC. SSI encoder simulation uses the technology board slot (X8).
The technology board is automatically detected.

see: / SSI module features /

TTL module

With the TTL module the following operation modes are possible:

  • Evaluation of a TTL encoder
  • Simulation of a TTL encoder (signals from other encoders are converted into TTL signals and made available as output signals (for a slave axis)
  • TTL repeater (evaluation and transmission of incoming TTL signals for additional axes)

see: / TTL module features /

TWINsync module

This enables two ServoOne units to be interconnected. Use of the TWINsync option is intended for applications in which synchronism of two drives is specified or in which one drive is to use I/O or encoder interfaces of another drive. Using the TWINsync option, any process data can be exchanged between two drives (125 s). The data are exchanged bidirectionally with the sampling time of the speed control. The TWINsync communication interface incorporates a synchronization mechanism. The ServoOne configured as the TWINsync master generates a cyclic signal pulse synchronized to its own control cycle on the SYNC OUT line of the interface. The ServoOne configured as the TWINsync slave receives the synchronization signal on its SYNC IN line and synchronizes its own control cycle to the TWINsync master.


Technology option (X8)

The option slot enables one of the following options to be evaluated:

  • SinCos module
  • TTL Module
  • SSI module
  • TwinSync module

SinCos module

The SinCos module enables evaluation of high-resolution encoders. A track signal period is interpolated at a 12-bit resolution (fine interpolation).

For more information refer to the "SinCos Module" specification, ID no.: 1108.01B.0-00.

SSI module

Using SSI Encoder Simulation, the current actual position of the drive controlled by the ServoOne can be read by a higher-level control system. The ServoOne then behaves like an SSI encoder in relation to the PLC. SSI Encoder Simulation uses the technology board slot (X8). The technology board is automatically detected.

Parameterizable number of multiturn and singleturn bits:

  • Binary transfer
  • Clock rates between 200 kBit/s and 1500 kBit/s are supported
  • Fastest possible sampling time: 125 μs
  • Optional transfer with parity bit (Odd/Even)
  • Optional synchronization of control to read cycle
  • Display of synchronization status
  • Encoder monoflop time: ~25 μs
  • Clear parameter structure for quick and easy commissioning

For more information refer to the "SSI Module" specification, ID no.: 1,106.02B.0-00.

TTL module

  • Evaluation of a TTL encoder
  • Simulation of a TTL encoder (signals of other encoders are converted into TTL signals
  • and made available as output signals for a slave axis)
  • TTL repeater (evaluation and transmission of incoming TTL signals for additional axes)

For more information refer to the "TTL Module" specification, ID no.: 1,106.01B.0-00.

TWINsync module

This document describes the TWINsync technology option. The TWINsync technology option is based on a communication interface for the option slot which is optionally available for the controller. This enables two controllers to be interconnected. Use of the TWINsync option is thus intended for applications in which synchronism of two drives is specified or in which one drive is to use I/O or encoder interfaces of another drive. Using the TWINsync option, any process data can be exchanged between two drives. The data are exchanged bidirectionally with the sampling time of the speed control. The TWINsync communication interface incorporates a synchronization mechanism.

The ServoOne configured as the TWINsync master generates a cyclic signal pulse synchronized to its own control cycle on the SYNC OUT line of the interface. The controller configured as the TWINsync slave receives the synchronization signal on its "SYNC IN" line and synchronizes its own control cycle to the TWINsync master.

For more information refer to the "TWINsync Module" specification, ID no.: 1,106.03B.0-00.


Virtual encoder channel 4

Not available at time of going to press!


Increment-coded reference marks

Homing methods for increment-coded encoders:

Method -6: "Negative direction for increment-coded encoders"

Method -7: "Positive direction for increment-coded encoders"

A detailed description of the increment-coded reference marks can be found by following the link below.

see: / Increment-coded reference marks CH3 /


Axis error correction

The actual position value delivered by the encoder system and the real actual position value on the axis may vary for a number of reasons.
Such non-linear inaccuracies can be compensated by axis error correction (using position- and direction-dependent correction values). For this, a correction value table is filled with values for each of the two directions. The respective correction value is produced from the current axis position and the direction of movement by means of cubic, jerk-stabilized interpolation. The actual position value is adapted on the basis of the corrected table. Both tables contain 250 interpolation points.
The correction range is within the value range delimited by parameters P 0591 ENC_ACOR_PosStart "Start position" and P 0592 ENC_ACOR_PosEnd "End position correction". The start position is preset on the user side; the end position is determined on the drive side.

Possible causes of variation:

  • Inaccuracy of the measuring system
  • Transfer inaccuracies in mechanical elements such as the gearing, coupling, feed spindle etc.
  • Thermal expansion of machine components.

P. no. | Parameter name Setting | Function
P 0530 | ENC_Encoder1Sel | Channel selection for the 1st encoder used
P 0531 | ENC_Encoder2Sel | Channel selection for the 2nd encoder used
P 0590 | ENC_ACOR_Sel | Selection of the encoder whose actual position value is to be changed.
(0) | OFF | No encoder selected
(1) | 1st Encoder | 1st encoder selected
(2) | 2nd Encoder | 2nd encoder selected
P 0591 | ENC_ACOR_PosStart | Definition of correction range: The range is defined by parameters P 0591 ENC_ACOR_PosStart Start position and P 0592 ENC_ACOR_PosEnd End position. The start position is user-specified; the end position is determined on the device side from the maximum value of correction table interpolation points used and the interpolation point pitch
P 0592 | ENC_ACOR_PosEnd
P 0593 | ENC_ACOR_PosDelta | Interpolation point pitch: The positions at which the correction interpolation points are plotted are defined via parameters P 0593 ENC_ACOR_PosDelta Interpolation point pitch and P 0591 ENC_ACOR_PosStart Start position. Between the correction interpolation points, the correction values are calculated by cubic spline interpolation.
P 0594 | ENC_ACOR_Val | Actual position
P 0595 | ENC_ACOR_VnegTab | Values of the correction table for negative direction of rotation in user units.
P 0596 | ENC_ACOR_VposTab | Values of the correction table for positive direction of rotation in user units.

Axis error correction method:

  • With P 0530 ENC_Encoder1Sel channel selection for SERCOS: 1st Encoder
  • With P 0531 ENC_Encoder2Sel channel selection for SERCOS: 2nd Encoder
  • Selection of the encoder whose actual position value is to be changed, with P 0590 ENC_ACOR_Sel
  • Enter interpolation point pitch in P 0593 ENC_ACOR_PosDelta
  • The correction values are determined using a reference measurement system (e.g. laser interferometer). The interpolation points for the various directions within the desired correction range are approached one after another and the corresponding position error is measured.
  • The interpolation point-specific correction values are entered manually in tables P 0595 ENC_ACOR_VnegTab (pos. direction) and P 0596 ENC_ACOR_VposTab (neg. direction).
  • Save values
  • Restart
  • P 0592 ENC_ACOR_PosEnd now shows the position end value of the correction range
  • Start control (in position control execute homing) and then move to any position.
  • The momentary correction value is written to P 0594 ENC_ACOR_Val. This value is subtracted from the approached position value. This applies to all positions.

End position = interpolation point pitch multiplied by number of interpolation points (table values) plus start position (only if start position ≠ 0).

Determining the direction of movement

Position control:
The direction of movement is produced when the time-related change in position reference (speed pre-control value) has exceeded the amount of the standstill window in the positive or negative direction.

Speed control:
The direction of movement is produced when the speed reference has exceeded the amount of the standstill window in the positive or negative direction.

  • Parameterization is carried out in the selected user unit for the position as integer values.
  • It is advisable to use the same number of correction interpolation points for the positive and negative directions. The first and last correction values in the table must be zero in order to avoid instability (step changes) of the actual position value. Differing correction values for the positive and negative directions at the same interpolation point will lead to instability in the associated actual position value when the direction is reversed, and so possibly to a step response adjustment to the reference position.


Encoder gearing

For channels 1 and 3 one gear ratio each can be set for the encoder. Using the gear ratio permits adaptation of an encoder mounted on the load side to the motor shaft. For encoder channel 2 it is to be assumed that the resolver is always mounted on the motor shaft. The adjustment range is therefore limited to (+1) or (-1), meaning the encoder signal can only be inverted.

P. no. | Designation | Function
P 0510 | ENC_CH1_Num | Denominator of channel 1
P 0511 | ENC_CH1_Denom | Numerator of channel 1
P 0512 | ENC_CH2_Num | Denominator of channel 2
P 0513 | ENC_CH2_Denom | Numerator of channel 2
P 0514 | ENC_CH3_Num | Denominator of channel 3
P 0515 | ENC_CH3_Denom | Numerator of channel 3


Channel selection

Up to three encoder channels can be evaluated at a time. The evaluation is made via interfaces X6, X7 and - if the option is available - on X8. Channels 1 and 2 are part of the controller's standard on-board configuration. A third channel X8 is optional. This must be taken into consideration in designing the controller.
For third-party motors the encoder offset is determined using an assistant (dialog box below). For the definition the motor is run in "Current control" mode. For a correct definition it is necessary for the motor to be able to align itself freely. It is not necessary to determine the encoder offset for LTi standard motors. A connected brake is automatically vented, provided it is connected to the brake output and the output has been configured for use of ar brake. The process takes about 10 seconds. Then the current value of the offset is entered in the display field and the original parameter setting is restored.

Interface between encoder and control

P. no. | Parameter name | Function
P 0520 | ENC_MCon | Selection of encoder channel for commutation angle (feedback signal for field oriented control)
P 0521 | ENC_SCon | Selection of encoder channel for speed configuration (feedback signal for speed control)
P 0522 | ENC_PCon | Selection of encoder channel for position information (feedback signal for position control)

When an encoder channel is selected, wire break detection is automatically activated.


Zero pulse evaluation - encoder channel

Zero pulse evaluation via encoder channel CH1 is only set "active" for SinCos encoders with no absolute value interface.

Setting:

P 0505 ENC_CH1_Sel (setting "SinCos encoder")

P 0540 ENC_CH1_Abs (setting "OFF": Incremental encoder):

  • SinCos encoders only ever output a zero pulse when no absolute value interface is present.
  • Resolvers output no zero pulse.
  • Zero pulse evaluation only works by selecting the homing methods designed for it.

Test mode for zero pulse detection

Test mode is activated by parameter P 0541 ENC_CH1_Np =1.

Encoder initialization is triggered manually by P 0149 MPRO_DRVCOM_Init =1.

Homing runs can also be carried out during test mode.

When homing is completed, or if an error has occurred, detection is aborted even though parameter P 0541 = 1. To reactivate test mode, parameter P 0541 must be reset from 0 to 1 and re-initialized.

To view the zero pulse with the scope function, the variable CH1-np-2 (index pulse length 1 ms) can be recorded on the digital scope.

The representation of the zero pulse on the scope appears wider (1 ms), enabling better detection of the zero pulse. The decisive factor here is the rising edge of the scope signal.


Phase shift of resolver signals

In the case of long resolver cables, a phase shift occurs between the exciter signal and tracks A/B due to the line inductance. This effect reduces the amplitude of the resolver signals after demodulation and inverts their phase in the case of very long cable lengths.

The phase shift can be equalized with parameter P 0565 ENC_CH2_LineDelay. By way of parameter P 0566 ENC_CH2_Amplitude the amplitude can additionally be adjusted. The functionality is only available with devices of type SO8x.xxx.xxxx.xxxx.1 (see rating plate).

Approvals have been issued for cables up to max. 50 metres. Longer cable lengths are only permitted following explicit approval by LTi.

see: / Channel 2 Resolver X6 /


Overflow in multiturn range

Overflow shift in multiturn range:

With this function the multiturn range is shifted in absolute value initialization so that no unwanted overflow can occur within the travel. The function is available for encoder channels 1 and 3.

Example:

If a portion of the travel distance is to the left of the threshold (MT Base), it is appended to the end of the travel range (to the right of the 2048) via parameter P 0547 ENC_CH1 for encoder channel 1 or P 0584 ENC_CH3 for encoder channel 3 (unit: encoder revolutions incl. gearing).

P. no. | Parameter name | Function
P 0547 | ENC_CH1_MTBase | Input of multiturn position "MTBase" in revolutions incl. gearing for channel 1
P 0584 | ENC_CH3_MTBase | Input of multiturn position "MTBase" in revolutions incl. gearing for channel 3


Use of a multiturn encoder as a singleturn encoder

By way of parameters P 0548 ENC_CH1_MTEnable = 1 and P 0585 ENC_CH3_MTEnable = 1 a multiturn encoder can be run as a singleturn encoder.


Control basic setting

A servocontroller works on the principle of field-oriented regulation. In the motor the current is injected so that the magnetic flux is at the maximum and a maximum torque can be generated on the motor shaft or on the carriage of a linear motor.

Specified attributes of a well configured control:

  • Constant speed (synchronism)
  • Positioning accuracy (absolute and repeatable)
  • High dynamism
  • Constant torque
  • Disturbance adjustment

Control structure: Position control with pre-control

  • When using a LTi DRiVES GmbH standard motor data set, the control parameters are preset for the specific motor model (external mass inertia = motor inertia). If using "third-party motors", a manual setting must be made for the drive by way of the motor identification or by calculation in order to define the appropriate control parameters for the motor model.

  • Speed control loop:
    The setting of the speed controller with the associated filters is dependent, firstly, on the motor parameters, such as mass moment of inertia and torque/force constant, and, secondly, on mechanical factors, such as load inertia/mass, friction, and the rigidity of the connection. Consequently, a manual or automatic optimization is often required.

  • Position control loop:
    The position control loop is dependent on the dynamism of the underlying speed controller, on the setpoint (reference) type and on the jerk, acceleration and interpolation methods.

see: / Basic Settings dialog box /

see: / Analysis (optimization) of torque control /

see: / Position controller setting /


Determining mass inertia

To define the mass inertia of a motor easily, the "automatic mass inertia" function is available.

In the standard motor data set the speed controller is preset for a moderately rigid mechanism. For load adaptation the coupled mass moment of inertia of the system is equal to the motor's moment of inertia (load to motor ratio 1:1). This setting corresponds to an approximation value in practice. Consequently, the speed controller must be additionally adapted to the moment of inertia and the rigidity of the mechanism.
The automatic inertia detection function is started when the hardware has been enabled. Clicking the "Automatic Inertia Detection" button enters the latest value obtained in SCD_Jsum.

Method: Determining mass inertia

  • Open the Loop control dialog box
  • Enable hardware (ISDSH, ENPO)
  • Click "Basic setting" button
  • Click the "Automatic Inertia Detection" button
  • Hardware enable required
  • The new value of the mass inertia is displayed in P 1516 SCD_Jsum.
  • Save setting in device

While the mass inertia is being determined the motor shaft executes rotary movements. There is a risk that the plant and the motor may be destroyed.

see: / Control basic setting /

see: / Basic Settings dialog box /


Basic Settings dialog box

The basic control settings are selected from the "Basic Settings" dialog box and parameterized in the subsequent dialog boxes.

Parameter P 0300 CON_CFG_Con specifies the control mode with which the drive is to be run. This parameter takes effect online. Uncontrolled online switching can cause an extreme jerk, a very high speed or an overcurrent, which may cause damage to the system.

"Motor control basic setting"

Clicking the "Basic setting" button opens the dialog box from which the assistant used to determine the mass inertia and to navigate to the individual control loops is accessed.

Adaptation of mass inertia

  • If the mass inertia value is not known, the assistant can be used to determine it. When you click the "Automatic inertia detection" button a safety notice prompt is displayed. Once it has been confirmed, the mass inertia is automatically determined.
While the mass inertia is being determined the motor shaft executes rotary movements. There is a risk that the plant and the motor may be destroyed.

Adaptation to the rigidity of the drive train

  • By setting the rigidity the settings of the speed and position control with pre-control are automatically determined. The values are adapted with the aid of assistants after clicking the buttons for the various controls. In the assistant the rigidity is indicated as a percentage.
    A setting < 100 % reduces the dynamism of the controller setting (such as for a toothed belt drive).
    A setting > 100 % increases the dynamism of the controller setting (low play and elasticity).
  • The speed controller gain is scaled separately with the percentage value of KP-Scale.
  • The control attenuation is influenced by way of the speed filter.

After a power-off the speed and position control settings remain stored. The percentage value of the rigidity is reset to 100 % however.

see: / Determining mass inertia /

see: / Analysis (optimization) of torque control /

see: / Speed controller setting /

see: / Position controller setting /

see: / Control basic setting /


Adaptation of torque control

Adaptation of torque control / Saturation characteristic

In the high overload range, saturation effects reduce the inductance of many motors. Consequently, the current controller optimized to the rated current may oscillate or become unstable. As a remedy, it can be adapted to the degree of magnetic saturation of the motor. The gain of the current controller can be adapted to the load case by way of four interpolation points. In the lower area of the dialog box the values for the interpolation points are entered.
On the left are the inductance values, and on the right the values for the overload ( > 100% of rated current).

Scaling of q-inductance L in [%]

P. no. | Parameter name | Function
P 0472 | MOT_LsigDiff | Scaling of q-stator inductance
0-3 |  | Scaling of q-stator inductance in [%]; interpolation points 0 to 3.
4-7 |  | Scaling of rated current in [%]; interpolation points 4 to 7.

Between the interpolation points the scaling factor is interpolated in linear mode. The current scaling of the inductance is displayed in the scope variable "74_Is_ActVal" .

see: / Analysis (optimization) of torque control /


Limitation/Overmodulation

Limitation:

Limitation of the voltage components "usqref" and "usdref". This enables so-called overmodulation (limitation to hexagon instead of circle) in order to make better use of the inverter voltage.

(3) Hexagon modulation:
Setting of the output amplitude and phase of the drive controller

Representation of the 8 vectors of the three-phase voltage system (3 half-bridges each with 2 states [23])

The vectors correspond to the DC link voltage UZK and form a voltage hexagon.

Uzk = DC link voltage

The maximum output voltage which can be set for each phase angle results from the circle which fits in the voltage hexagon (diagram below).

By setting the hexagon modulation (3) "Hex Phase", the length of the vector for the output voltage can be placed in the area of the DC link voltage (red).

As a result only two of the three half-bridges are switched in each switching interval. The third remains at the upper or lower potential of the DC link voltage for a period of 60°; of the output frequency.
This method has only two thirds of the switching losses of modulation with all three phases.
Disadvantages of it are higher harmonics of the motor currents and so less smooth running at high motor speeds.

UN = rated voltage

Ul = voltage at inductor

Uu = inverter voltage

Uzk = DC link voltage

α = phase angle

P. no. | Parameter name | Function
P 0431 | CON_CCON_VLimit | Voltage limit of the current controller
P 0432 | CON_CCONMode | Selector for the mode of voltage limitation of "usqref" and "usdref".
(0), (1) | PRIO(0.1) | Hard switch from d-priority (motorized) to q-priority (regenerative). A portion of the voltage is held in reserve; the amount can be specified via parameter P 0431 CON_CCON_VLimit.
(2) | Phase(2) | Phase-correct limitation
(3) | HEX, Phase (3) | Hexagon modulation with phase-correct limitation. More voltage is available for the motor. The current exhibits a higher ripple at high voltages however (see diagram).
(4) | D_PRIO(4) | Pure priority of the d-current controller

see: / Sketch of expanded torque control /


Observer

To increase the torque control dynamism and reduce the tendency to oscillation, there is a so-called observer.

P. no. | Parameter name | Function
P 0433 | CON_CCON_ObsMod | Switching the observer on and off for torque control
(0) | Off(0) | Observer is off
(1) | Time Const(1) | The currents determined from the observer are used for the motor control. The configuration is based on presetting of an observer time constantP 0434 CON_CCON_ObsPara, index 0
(2) | Direct(2) | Direct parameterization of the observer feedback via P 0434 CON_CCON_ObsPara(1) = KP and P 0434 CON_CCON_ObsPara(2) = Tn
P 0434 | CON_CCON_ObsPara | Observation parameter
(0) | TP (0) | Observer time constant
(1) | KP (0) | Gain
(2) | TN (2) | Integration time constant, lag time

see: / Sketch of expanded torque control /


Sketch of expanded torque control

There are additional functions to improve the control dynamism of current and speed controllers.

  • Limitation/Overmodulation
  • Adaptation of torque control/Saturation characteristic
  • Observer/Current observer

see: / Adaptation of torque control /

see: / Limitation/Overmodulation /

see: / Observer /


Analysis (optimization) of torque control

In order to optimize the current control loop, two rectangular reference steps are preset.

The object of the optimization is a current controller with moderate dynamism

  • The current controller acting time: < 1 ms and the
  • overshoot: < 5 %

Current controller optimization method:

  • The first step (stage 1, time 1) moves the rotor to a defined position.
  • The second step (stage 2, time 2) is used to optimize the torque control (step response). The level of the second step should not be selected too large, to prevent the voltage reference from going to the limit (small signal response required).
  • The current and time settings automatically adjust to the motor data. The current in stage 2 corresponds to

  • ISDSH and ENPO (hardware enable) must be set to "High".
  • Click "Start test signal" button
  • Observe the security prompt: When you confirm the security prompt a step response is executed.
  • The oscilloscope is set automatically.

The faster the actual value approaches the setpoint (reference), the more dynamic is the controller setting.

During settling, the overshoot of the actual value should be no more than 5-10 % of the reference (guide value).

see: / Control basic setting /


Design: Torque control with defined bandwidth

It is possible, based on the bandwidth, to carry out a torque controller draft design. In this, the controller gains can be determined by activating test signals (Autotuning). The calculations and the relevant autotuning are carried out in the drive controller. The advanced settings are made in parameters P 1530 SCD_SetMotorControl, P 1531 SCD_Action_Sel and P 1533 SCD_AT_Bandwidth.

  • The bandwidth is specified as 3 dB of the closed loop.
  • Appropriate bandwidth settings:
    • At 8 kHz switching frequency up to approx. 2000 Hz,
    • At 8 kHz switching frequency up to approx. 2000 Hz.

    P. no. | Parameter name | Function
P1530 | SCD_SetMotorControl | Torque controller setting with defined bandwidth
(-1) | Fault(-1) | Error during calculation
(0) | Ready(0) | Calculation ended
(1) | Calc_CON(1) | PI calculation of torque controller parameters based on the motor data
(2) | Calc_ASM(2) | PI calculation of torque controller parameters based on the motor nominal data
(3) | BANDWIDTH(3) | PI calculation of the torque controller parameters based on the motor data and the specified bandwidth
(4) | DEADBEAT(4) | This setting parameterizes a dead-beat controller. The structure is switched to feedback with observer, the observer is designed (to a specific equivalent time constant - for setting see parameter CON_CCON_ObsPara (0)) and the speed controller gains are calculated accordingly.
P1531 | SCD_Action_Sel | Start conditions to determine the torque controller settings
(-1) | FAULT (-1) | Function set in P 1530 SCD_SetMotorControl stops with an error message
(0) | READY(0) | Start function
(1) | ENC_OFFSET(1) | Start encoder offset definition (power stage is activated)
(2) | MOT_ID(2) | Start motor identification (power stage is activated)
(3) | IMP(3) | Start impedance measurement
(4) | LH_TUNE(4) | Tune Lm characteristics
(5) | ASM_OP(5) | ASM operating point setting
(6) | BANDWIDTH(6) | Optimization of torque controller gain with band-pass: TuneCCon Activation of sinusoidal test signals and adaptation of the current controller parameters based on the specified bandwidth
(7) | MOTPHASE(7) | Check motor phases
(8) | COM_ALL(8) | Definition of: motor ID, encoder offset, mass inertia and test of motor phases
(9) | J_SUM(9) | Definition of the overall (reduced) mass inertia
(10) | CANCEL(10) | Reset speed control gain
P1533 | SCD_AT_Bandwidth | Bandwidth preset for speed control loop: Setting range: 10 - 4000 Hz


Detent torque compensation

In order to compensate for detent torques (caused by non-sinusoidal EM curves), the torque-forming q-current is entered in a table and "taught-in" for one pole pitch division.
After elimination of the offsets (compensated table), the q-current is inverted and fed-in as the pre-control value of the control. The compensation function can be described by means of compensating currents (q-current, scope signal "isqref") dependent on a position (electrical angle, scope signal "epsRS"). A "teach-in" is used to import the values into a table. With parameter P 0382 CON_TCoggComp the method to be used is selected:

  • OFF(0), switched off
  • EPSRS(1), compensation referred to electrical angle (maximum 250 values).
  • ABSPOS(2), compensation referred to a freely definable position (maximum 4000 values).

The interpolation between the table values is linear. The characteristic is not saved automatically; it must be saved manually. The progress of the teach process and the compensation can be tracked on the scope. The signal 55_isqCoggingTeach indicates the momentary output value of the teach table during teach mode, while 56_isqCoggingAdapt contains the momentary value from the compensation table.

Method for filling out the table (Teach EPSRS):

  • Open manual mode window
  • Speed control setting (set high rigidity, for smooth running)
  • Set parameter P 0385 CON_TCoggTeachCon to "TeachTab(1)" for EPSRS.
  • Start control
  • Move the motor at low speed (< 1 rpm) until table P 0383 CON_TCoggTeach1 (EPSRS) has been completely populated
  • Stop control
  • Set parameter P 0385 CON_TCoggTeachCon to "CalCorrTab(3)" for EPSRS. This imports all values into the compensation table.
  • With P0382 CON_TCoggComp activate the process.
  • Save device data

Method for filling out the table (Teach ABSPOS):

  • Open manual mode window
  • Speed control setting (set high rigidity, for smooth running)
  • Set parameter P 0385 CON_TCoggTeachCon to "TeachTab(1)" for TeachTab(2) for ABSPOS.
  • Parameter P 0442 CON_TAB_PosStart:Define start position
  • Parameter P 0443 CON_TAB_PosDelta: Define position delta: Start position +(position delta*4000)=end position
  • Parameter P 0445 CON_TAB_TeachDir: Define direction of rotation: (pos-/neg-/both-direction)
  • Start control
  • Move the motor at low speed (< 1 rpm) until parameter P 0440 CON_TAB_TabIndex > 4000 (table ABSPOS is not visible).
  • Stop control
  • Set parameter P 0385 CON_TCoggTeachCon to COMPTab(5) for ABSPOS. This imports all values into the compensation table.
  • With P 0382 P0382 CON_TCoggComp activate the process.
  • Save device data

P. no. | Parameter name | Function
P 0380 | CON_TCoggAddTab | Taught-in values (EPSRS)
P 0382 | CON_TCoggComp | Compensated table values are imported into the control
(1) | EPSRS | Compensation referred to the electrical angle; example - three-pole pair motor: The table in P 0380 CON_TCoggAddTab is populated three times within one mechanical motor revolution. The compensation is effected with the averaged table values.
(2) | ABSPOS | Compensation referred to a freely definable position.
P 0383 | CON_TCoggTeach1 | Compensated values (EPSRS)
P 0385 | CON_TCoggTeachCon | Start of teach function to fill table
(1) | TeachTab(1) | Activation of teach function EPSRS
(2) | TeachTab(2) | Activation of teach function APSPOS
(3) | CalcCorTab(3) | Calculation of compensation EPSRS
(4) | RESET(4) | Reset table values
(5) | COMPTAB(5) | Calculation of compensation APSPOS
P 0440 | CON_TAB_TabIndex | Compensation table: Index
P 0441 | CON_TAB_TabVal | Compensation table: Actual
P 0442 | CON_TAB_PosStart | Compensation table: Start position
P 0443 | CON_TAB_PosDelta | Compensation table: Position delta
P 0445 | CON_TAB_TeachDir | Compensation table: Direction of rotation teach mode
P 0446 | CON_TAB_OutVal | Compensation table: Output value


Analysis of speed control

This section will be revised shortly. The dialog box will also change as a result. Consequently, no detailed description is presented here.

For additional information follow these links:

see: / Speed controller setting /

see: / Expanded speed control (single-mass observer) /

see: / Speed controller gain reduction at low speeds /

see: / Digital filter /


Digital filter

To filter any noise on the actual speed value, or to damp resonance frequencies, the following filter settings can be made.

A range of filter variants are available. The coefficients of the transfer function are automatically determined as soon as the values for the middle and cut-off frequency and the width have been entered.

P. no. | Parameter name | Function
P 0325 | CON_SCON_FilterFreq | Cut-off frequencies
(0) | 1 - 8000 Hz | 1. Middle, cut-off frequency
(1) | 1 - 8000 Hz | Width
(2) | 1 - 8000 Hz | 1. Middle, cut-off frequency
(3) | 1 - 8000 Hz | Width
P 0326 | CON_SCON_FilterAssi | Filter selector
(0) | Off | No filter active
(1) | USER | Manual writing of filter coefficients
(2) | Notch | Selection of a notch filter with the cut-off frequency from P 0325(0) CON_SCON_FilterFreq and the bandwidth from P 0325(1).
(3) | Notch_Notch | Selection of a notch filter with the cut-off frequency from P 0325(0) and bandwidth from P 0325(1) in series with a notch filter with the cut-off frequency fromP 0325(2) and bandwidth fromP 0325(3)
(4) | Notch_PT1 | NOTCH_PT1(4) and NOTCH_PT2(5): A notch filter with the blocking frequency in P 0325(0) and bandwidth in P 0325(1) in series with a low-pass filter with cut-off frequency in P 0325(2).
(5) | Notch_PT2
(6) | PT1 | PT1(6), PT2(7), PT3(8), PT4(9): A low-pass filter with the cut-off frequency in P 0325(2)At lower frequencies higher-order filters (PT3, PT4) should not be used.
(7) | PT2
(8) | PT3
(9) | PT4
P 0327 | CON_SCON_FilterPara | Coefficients of the digital filter
(0) | FilterPara | The transfer function allows the output signal of the transfer system to be calculated from the input signal and the transfer function.
(1) | FilterPara
(2) | FilterPara
(3) | FilterPara
(4) | FilterPara
(5) | FilterPara
(6) | FilterPara
(7) | FilterPara
(8) | FilterPara

Note that the filters not only have an effect on the amount but also on the phase of the frequency response. At lower frequencies higher-order filters (PT3, PT4) should not be used, as the phase within the control bandwidth is negatively influenced.

The coefficients can also be specified directly via parameter P 0327 CON_SCON_FilterPara. They take effect directly, so changing them is only recommended when the control is switched off.

Frequency responses of PT1, PT2, PT3, PT4 filters

Signal analysis method:

  1. Scope setting:
    isq (unfiltered, torque-forming current) Set shortest sampling time Create scope plot without notch filtering
  2. On the oscilloscope click the "Mathematical functions" > FFT (Fourier analysis) icon. From the following pop-up menu choose isq. Interference frequency is displayed.
  3. "Select filter": Select filter
  4. "center/cutoff": Enter cut-off frequency
  5. "width": Enter the bandwidth of the cut-off frequency; the width has no effect when using PTx filters
  6. Create scope plot with notch filtering

A higher bandwidth results in less attenuation of the cut-off frequency because of the filter structure.

Example of an unwanted current spike at 410 Hz without filtering.

FFT without filtering:

FFT with filtering:

Using a suitable filter compensates for the current spike at 410 Hz.


Speed controller setting

Acceleration and braking phases generate a variation which the speed control has to balance out. The necessary acceleration or braking moment determined from the change in speed over time is applied to the output of the position controller.
If the travel range is not limited, it is advisable to optimize the speed controller by means of step responses. In this, the motor model must be adapted precisely to the individual motor. In the standard motor data set the speed controller is preset for a moderately rigid mechanism. The speed controller may still need to be adapted to the moment of inertia and the rigidity of the mechanical system. For load adaptation the coupled mass moment of inertia of the system is equal to the motor's moment of inertia (load to motor ratio 1:1).

The parameters are adjusted in the dialog box.

  • Gain
  • Lag time
  • Filter time

All parameters take effect online. The scaling parameter P 0322 CON_SCON_KpScale is transferred in defined real time (according to the speed controller sampling time).

Gain scaling

The gain can be set separately or by way of the scaling factor P 0322 CON_SCON_KpScale. The default setting of the scaling factor is 100 %. The recommended setting of actual speed value filter P 0351 CON_SCALC_TF for a resolver is 1-2 ms. For an encoder with 1 Vss (e.g. 2048 lines per revolution) the filter time is 0.3 - 0.6 ms.

Controller optimization method

The speed controller is set up using step responses. They are recorded with the oscilloscope and used to analyze the setup quality. To activate step responses the controller can be operated in speed control mode "SCON" from the manual mode window. The important factor here is that the speed controller shows low-level signal response, which means that the q-current reference is not allowed to reach the limitation during the step. In this case the magnitude of the reference step must be reduced.

The motor executes rotary movements in the event of a reference step.

Settling

Manual mode window setting

Manual mode window | Setting
Control mode | Speed control
Acceleration ramp | 0 rev/min/s
Reference step | Small signal response: Reference step not maximum

Oscilloscope setting

Oscilloscope | Setting
Channel setting |
Channel 0 | Speed reference [nref]
Channel 1 | Actual speed value [nact]
Channel 2 | Torque-forming current [isq ref]
Trigger setting |
Trigger signal | Speed reference [nref]
Mode | Rising edge
Level | (resolver approx. 30 rpm)
Pretrigger | 10 %
Time |
Sampling time | A multiple of the base time 6.25E-0.5 s
Recording time | 0-1 second


Expanded speed control (single-mass observer)

Benefits of the single-mass observer function:

The phase shifts in the feedback branch over time (P 0324(0) CON_SCON_TFd acceleration feedback, P 0324(1) CON_SCON_TFd speed difference feedforward) generate high-frequency noise and resonance.
The single-mass observer reduces this high-frequency interference and increases the control dynamism.
The function of the observer is based on the mathematical description of the controlled system which calculates the trend over time of the state variables under the influence of the input variables. The difference between the measured and estimated state variables is fed back to the estimated state variables by way of a feedback matrix. The aim is to equalize the estimated state variables as quickly as possible to the measured variables.

Method of activating the single-mass observer:

  • Select filter method P 0350(0) CON_SCALC_SEL = "Single-mass observer"
  • Select feedback P 0350(1) CON_SCALC_SEL = "Feedback from observer"
    see: / Speed controller setting /

Optimizing the observer

  • The mass moment of inertia must be determined.
  • The dynamism is set via the equivalent time constant P 0353(0) CON_SCALC_Obs DesignPara, which behaves in a similar way to the actual speed filter time constant: Increasing the time constant enhances the noise suppression, but also reduces the dynamism.
  • By writing the design assistant P 0354 CON_SCALC_ObsDesignAssi = Def the observer is reconfigured. This change takes effect online.
  • An optimization can be made iteratively (in steps) by adapting the equivalent time constant, linked with rewriting of the calculation assistant.
  • Time constant setting P 0353(0) CON_SCALC_Obs DesignPara (default 1 ms)

P. no. | Parameter name | Function
P 0350 | CON_SCALC_SEL | Selection of speed calculation method
(0) | SEL_ObserverMethod |
 | Filter(0) | Signal from observer system; actual value filter activated PT filter
 | OBS1(1) | Single-mass observer
 | OBSACC(2) | Observer with acceleration sensor
 | OBS2(3) | Dual-mass observer
(1) | SEL_FeedbackMethod |
 | OBS(0) | Observer activation
 | Filter(1) | Filter activation
P 0353 | CON_SCALC_Obs DesignPara | Equivalent time constant of observer
(0) | TF | Time constant 1 ms For single- and dual-mass observers
(1) | Alpha | Setting parameter for the dual-mass observer. Only on request!
(2) | Load point
(3) | TF1
(4) | TF2
(5) | TFosc
(6) | AccGain |
P 0354 | CON_SCALC_ObsDesignAssi | Calculation assistant for observer
(0) | user | Not active
(1) | DEF | Start calculation
(2) | DR | Not active
(3) | TIMES | Not active


Speed controller gain reduction at low speeds

If the speed controller is set very dynamically, at low speeds or speed zero unwanted oscillation of the speed controller may occur. The tendency to oscillate is reduced by suitable setting of parameter P 0336 CON_SCON_KpScaleSpeedZero.

Speed controller gain reduction:

P. no. | Parameter name | Function
P 0336 | CON_SCON_KpScaleSpeedZero | Reduction in speed gain at low speeds or speed 0. To avoid oscillation. The preset action range applies to positive and negative speeds.
(0) | Index 0 [%] | Weighting of the speed controller gain reduction in percent
(1) | Index 1 [rpm] | Action range of reduction: Speed limit for "speed zero reached" (standstill window).
(2) | Index 2 [ms] | Filter time for speed transition from 0 to nmax
(3) | Index 3 [ms] | Filter time for speed transition from nmax to 0


Position controller setting

The higher the dynamism of the speed controller, the more dynamically the position controller can be set and the tracking error minimized. The variables for the pre-control of the speed and position controller are additionally determined either from the change in reference values or alternatively are already calculated and outputted by the motion control. The time-related values for the position, speed and torque are transmitted to the drive control.
If the dynamic change in these values is within the limits which the drive is able to follow dynamically, the load on the controllers is significantly reduced.

In order to improve the dynamism of the position controller, the parameters listed in the dialog box below are available to optimize the speed and acceleration pre-control.

Prediction:
Owing to the time-discrete mode of operation of the control circuits and the limited dynamism of the current control circuit, the prediction is necessary to prevent the individual control circuits from oscillating against one another.

see: / Position controller pre-control /

see: / Speed controller setting /

see: / Friction torque compensation /

Optimization of the position controller via the manual mode window:

The reference values for the necessary reference steps for controller optimization can be easily preset in the manual mode window (control mode: position control, reversing). To assess the controller dynamism, the digital oscilloscope must be deployed accordingly.

When a standard motor data set is read-in, the position controller gain is also adopted. The setting equates to a controller with a medium rigidity.
In the default setting no smoothing is selected!


Position controller pre-control

The pre-control of the acceleration torque relieves the strain on the speed controller and optimizes the control response of the drive. To pre-control the acceleration torque, the mass inertia reduced to the motor shaft must be known.
If the parameter for the overall mass inertia of the system P 1516 SCD_Jsum has a value ≠ 0, that value will be automatically used to pre-control the acceleration torque.
The pre-control of the speed reference is preset by default to 100 % via parameter P 0375 CON_IP_SFF_Scale. This value should not be changed.

The acceleration torque pre-control can be optimized with P 0376 CON_IP_TFF_Scale. Reducing this reduces the pre-control value; conversely, increasing this value also increases the pre-control value. The position tracking error can be further reduced by predictive torque and speed pre-control - that is, in advance of the position reference setting. Owing to the time-discrete mode of operation of the control circuits and the limited dynamism of the current control circuit, this prediction is necessary to prevent the individual control circuits from oscillating against one another. Prediction in pre-control is achieved by retarding the speed and position controller reference setpoints P 0374 CON_IP_EpsDly.

Pre-control parameters:

P. no. | Parameter name | Function
P 0360 | CON_PCON_KP | Gain of position controller
P 0372 | CON_IP_SFFTF | Filter time for speed controller pre-control
P 0374 | CON_IP_EpsDly | Prediction (delay time) for position controller pre-control
P 0375 | CON_IP_SFFScale | Speed controller pre-control scaling factor
P 0376 | CON_IP_TFFScale | Torque controller pre-control scaling factor
P 0378 | CON_IP_ACC_FFTF | Filter time for torque controller pre-control
P 0386 | CON_SCON_TFric | Scaling factor for friction compensation
P 0387 | CON_SCON_TFricZeroSpeed | Standstill window for friction compensation
P1516 | SCD_Jsum | Reduced mass inertia

  • When using linear interpolation pre-control is inactive.
  • The overall mass moment of inertia in P 1516 SCD_Jsum must not be changed to optimize the pre-control, because this would also have an effect on other controller settings!
  • In multi-axis applications requiring precise three-dimensional axis coordination, such as in the case of machine tools, the delay of the position signal must be equally set on all axes via parameter P 0374-IP_EpsDly. Otherwise the synchronization of the axes may suffer, leading to three-dimensional path errors.

see: / Position controller setting /

see: / Friction torque compensation /


Friction torque compensation

It is advisable to compensate for higher friction torques in order to minimize tracking error when reversing the speed of the axis. The drive controller enables compensation of friction components dependent on the reference speed "nref_FF". The speed controller can compensate for the other (e.g. viscous) friction components because of their lower change dynamism. The compensation can be effected step-by-step as a percentage of the rated motor torque by means of P 0386 CON_SCON_TFric. Below the standstill window P 0387 CON_SCON_TFricZeroSpeed the compensation is reduced by way of an internal ramp.

Friction torque compensation method:

  • Execute a fast movement
  • Set scope:
    ----------------------------------------------
    Pre-control:
    Reference torque pre-control mref_FF
    Actual torque mact
    ----------------------------------------------
    Reference current isqref_FF
    Actual current isq
    ----------------------------------------------
    Tracking error:
    MPRO_FG_UsrPosDifff
    ----------------------------------------------
    Actual speed:
    CON_SCALC_ActSpeed
    ----------------------------------------------
    Trigger:
    Reference speed in user units
    MPRO_FG_UsrRefSpeed
  • Adapt friction torque compensation via P 0386
  • Adapt standstill window via P 0387
  • Observe tracking error

see: / Position controller setting /

see: / Position controller pre-control /


Field-weakening of the asynchronous machine

Up to rated speed the asynchronous motor runs with a full magnetic field and so is able to develop a high torque. Above rated speed the magnetic field is reduced because the maximum output voltage of the inverter has been reached and the motor is run in the so-called field-weakening range with reduced torque.

For field-weakening of asynchronous motors, the motor parameters must be known very precisely. This applies in particular to the dependency of the main inductance on the magnetizing current. It is essential to carry out a motor identification and an optimization in the basic setting range for field-weakening mode. In the process, default values for the control circuits and the "magnetic operating point" are set based on the rated motor data and the magnetizing current presetting in P 0340 CON_FM_Imag. Two variants are available for operation in field-weakening mode.

Field-weakening of the asynchronous machine

Variant 1:

Combination of "pre-control via 1/n characteristic" + voltage controller. The motor identification sets the voltage controller so that the voltage supply in the field-weakening range is adequate. If the drive controller is at the voltage limit, it reduces the d-current and thus the rotor flux.

Since the controller has only limited dynamism, and starts to oscillate if larger gain factors are set, it is possible to use variant 2.

Variant 2:

Combination of "pre-control with modified 1/n characteristic" (isd=f(n)) + voltage controller.

This characteristic describes the magnetizing current as a percentage of the nominal value of P 0340 CON_FM_Imag dependent on the speed.

The choice between the modified 1/n characteristic and the static characteristic is based on parameter P 0341 CON_FM_ImagSLim.

P 0341 ≠ 0 signifies selection of the 1/n characteristic (default )

P 0341 = 0 signifies selection of the modifizied 1/n characteristic isd = f(n).

After a motor identification the voltage controller is always active, as the controller parameters are preset. With P 0345 CON_FNVConKp = 0 the voltage controller is deactivated.

Parameterizing variant 2:

Setting the d-current dependent on the speed. The speed is specified relative to the rated speed in P 0458 MOT_SNom, the d-current relative to the magnetizing current in parameter P 0340. Up to the field-weakening speed, a constant magnetizing current is injected P 0340.

Voltage controller:

see: / Voltage controller - Asynchronous machine field-weakening /

Method: Selection of modified characteristic

  • P 0341 = 0 (selection of modified characteristic) + voltage controller
  • Approach desired speeds slowly
  • Adjust scope: Isdref
  • SQRT2*Imag = %-speed value
  • The maximum amount of the "field-forming" d-current is defined by parameter
    P 0340 CON_FM_Imag (specification of effective value).
  • Enter values in table; P 0342 CON_FM_SpeedTab

Example:

Index | P 0348 rated speed P 0340 Imageff | P 0342 (0-7) Field-weakening speed in [%] | P 0343 (0-7) Magnetizing current in field-weakening mode in [%]
(0) | nrated= 1800 rpm Imag eff = 100 % | 100 | 100
(1) |  | 110 | 100
(2) |  | 120 | 100
(3) |  | 130 | 100
(4) |  | 140 | 90
(5) |  | 150 | 70
(6) |  | 160 | 55
(7) |  | 170 | 0

Parameters:

P. no. | Parameter name | Function
P 0340 | CON_FM_Imag | Effective value of the rated current for magnetization
P 0341 | CON_FM_ImagSLim | Field-weakening activation point (as % of P 0348 MOT_SNom). This effects the switch to the 1/n characteristic (P 0341 ≠ 0). For P 0341 = 0 the field-weakening works via the modified characteristic isd = f(n). For a synchronous machine this value must be set to 0.
P 0342 | CON_FM_SpeedTab | Speed values scaled as % of P 0458 nrated to populate the modified table.
P 0343 | CON_FM_ImagTab | d-current scaled as % of P 0340 Imag eff. to populate the modified table.


Voltage controller - Asynchronous machine field-weakening

The voltage controller is overlaid on the selected characteristic. When using the voltage controller, a portion of the available voltage is used as a control reserve. The more dynamic the running, the more control reserve is required. In this case it may be that the voltage for rated operation is not sufficient, and also that the controller starts to oscillate.
The PI voltage controller can be optimized by adaptation of the P gain P 0345 CON_FM_VConKp, lag time P 0346 CON_FM_VConTn and filter time constant for motor voltage feedback P 0344 CON_FM_VConTF. Parameter P 0347 CON_FM_VRef sets the voltage reference, though the threshold needs to be reduced in response to rising demands as this maintains a kind of voltage reserve for dynamic control processes. A certain voltage reserve is necessary for stable operation. It is specified by way of parameter P 0347 CON_FM_VRef (< 100 %). The value should be set high ( <= 90 %) where there are high demands in terms of dynamism. For less dynamic response, the maximum attainable torque can be optimized by higher values (> 90 %).

If the control reserve is too small, the inverter typically shuts off with an overcurrent error.

P. no. | Parameter name | Function
P 0344 | CON_FM_VConTF | Time constant of voltage controller actual value filter
P 0345 | CON_FM_VConKp | Voltage controller gain factor Kp
P 0346 | CON_FM_VConTn | Voltage controller lag time Tn
P 0347 | CON_FM_VRef | Voltage controller reference (as % of the current DC link voltage) If the value 0 % is set, the controller is not active.
P 0458 | MOT_SNom | Rated speed of the motor

see: / Field-weakening of the asynchronous machine /


Field-weakening of the synchronous machine

Synchronous motors can also be operated above their rated speed at rated voltage, by reducing their voltage consumption based on injection of a current component.

Features:

  • The method is relatively robust against parameter fluctuations.
  • The voltage controller can only follow rapid speed and torque changes to a limited degree.
  • A non-optimized voltage controller may cause oscillation; the controller must be optimized.

Conditions:

To effectively reduce the voltage consumption, the ratio of stator inductance
P 0471 MOT_Lsig multiplied by the rated current P 0457 MOT_CNom to rotor flux P 0462 MOT_FluxNom must be sufficiently large.

In contrast to field-weakening of asynchronous motors, synchronous motors can also be operated in the "field-weakening range" with full rated torque at the nominal value of the q-current. Power beyond the rated power output can therefore be drawn from the machine in field-weakening mode, even at rated current. This must be taken into consideration when configuring the motor.

If the speed achieved by field-weakening is so high that the induced voltage exceeds the overvoltage threshold of the device (for 400 V devices approximately 800 V, for 230 V devices approximately 400 V), this will result in DESTRUCTION of the servocontroller if no additional external safety measures are applied.

Field-weakening for the synchronous motor:

There are also two variants for field-weakening of synchronous motors. The choice of variant 1 or 2 is made via parameter P 0435 FWMode

Variant 1: "Characteristic isd = f(n)"

Variant 2: "Calculated map"

Voltage controller:

Variant 1 method: Characteristic isd = f(n)

  • Deactivate table: P 0341 CON_FM_ImagSlim = 0
  • P 0435 CON_FM_FWMode = (1) Select table
  • Approach desired speeds slowly
  • Adjust scope: Isdref/SQU2*Imag = % = field-weakening speed. The maximum amount of the "field-weakening"
    d-current is defined by parameter P 0340 CON_FM_Imag (specification of effective value).
  • Enter values in table P 0342 CON_FM_SpeedTab

Variant 2 method: "Calculated map"

In the case of very rapid speed or load changes in the field-weakening range, the setting
P 0435 CON_FM_FwMode = 2 is selected. A characteristic for a higher control dynamism is calculated internally.

Features of this method:

  • Very fast adaptations, with high dynamism, are possible (open-loop control method).
  • Motor parameters must be known quite precisely.
  • If continuous oscillation occurs (voltage limit) the preset negative d-current value is then not sufficient. Scaling parameter P 0436 CON_FW_SpeedScale > 100 % is used to evaluate the map at higher speeds.

The voltage controller overlaid over the map (setting as described in variant 1).

The set combination of voltage controller and map entails more commissioning commitment, but it enables the best stationary behaviour (highest torque relative to current) and the best dynamic response to be achieved.

When configuring projects, it must be ensured that the speed NEVER exceeds the value of P 0458 MOT_SNom* P 0328_CON_SCON_SMax. It should fundamentally be ensured that the induced voltage does not exceed the voltage limits - that is to say, the maximum system speed must not be exceeded.

Example:

Index | P 0348 rated speed P 0340 Imageff | P 0342 (0-7) Field-weakening speed in [%] | P 0343 (0-7) Magnetizing current Isdref in field-weakening mode in [%]
(0) | nrated= 1800 rpm Imag eff = 100 % | 100 | 0
(1) |  | 110 | 55
(2) |  | 120 | 70
(3) |  | 130 | 90
(4) |  | 140 | 100
(5) |  | 150 | 100
(6) |  | 160 | 100
(7) |  | 170 | 100

The speeds in P 0342 CON_FM_SpeedTab must continuously increase from index 0 -7.

Parameters:

P. no. | Parameter name | Function
P 0435 | CON_FM_FWMode | Selection mode for field-weakening of synchronous motors
(0) | None | Field-weakening is off, regardless of other settings.
(1) | Table | Field-weakening is effected by a characteristic which specifies the d-current dependent on the speed isd = f(n) P 0342 CON_FM_SpeedTabParameter and P 0343 Con_TAB_POSDelta.
(2) | Calc | Field-weakening is effected by way of a characteristic which is set internally via the motor parameters. The d-current reference is then calculated dependent on the speed AND the required q-current: isd = f(n, isq_ref). The inaccuracies with regard to the motor parameters, the available voltage etc. can be compensated by way of the Scale parameter P 0436 CON_FW_SpeedScale.

In mode 1 and mode 2 the voltage controller can be overlaid. It is also possible in mode 1 to disable the characteristic and run solely with the action of the voltage controller.

If no high control dynamism is specified, the table and the voltage controller should be disabled P 0345 CON_FM_VCONKp.

see: / Voltage controller in field-weakening on the synchronous machine /


Voltage controller in field-weakening on the synchronous machine

The voltage controller is overlaid on the selected characteristic. When using the voltage controller, a portion of the available voltage is used as a control reserve. The more dynamic the running, the more control reserve is required. In this case it may be that the voltage for rated operation is not sufficient, and also that the controller starts to oscillate.

If the voltage controller oscillates the gain must be reduced. If substantial variations between the q-current reference and actual values occur during run-up to reference speed in the field-weakening range, the drive may be at the voltage limit. In this case, a check should first be made as to whether the preset maximum value P 0340 CON_FM_Imag has already been reached and can be increased. If the maximum value has not yet been reached, the voltage controller is not dynamic enough and the gain
P 0345 CON_FM_VConKp must be increased.

If no suitable compromise can be found, the voltage threshold as from which the voltage control intervenes must be reduced by the scaling parameter P 0347 CON_FM_VRef . If the response with voltage controller is unproblematic and no particular demands are made in terms of dynamism, the available torque can be optimized by setting P 0347 CON_FM_VRef to values up to 98 %.

see: / Field-weakening of the synchronous machine /


Autocommutation on synchronous machines

For field-oriented regulation of permanently excited synchronous machines with a purely incremental measuring system, the commutation position must be determined once when the control is started (adjustment of current rotor position to encoder zero [encoder offset]).

This procedure is executed by the "Autocommutation" function after initial enabling of the control when the mains voltage has been switched on for the first time. It can also be forced during commissioning by changing a parameter, which causes a complete controller initialization (e.g. change of autocommutation parameters, change of control mode, etc.).
Owing to the differing requirements arising from the applications, various commutation methods are provided. The selection is made via the selector P 0390 CON_ICOM.

IENCC(1)

In this method the rotor aligns in the direction of the injected current and thus in a defined position. The relatively large movement (up to half a rotor revolution) must be taken into consideration. This method cannot be used near end stops or limit switches! It is advisable to use the rated current Inom for the injected current. The time should be set so that the rotor is at rest during the measurement. For control purposes, the commutation process can be recorded with the Scope function.

IECON(4)

The motor shaft motion can be minimized by a shaft angle controller. The structure and parameters of the speed controller are used for the purpose. The gain can be scaled via parameter P 0391 CON_ICOM_KpScale. The precondition is a preset speed control loop. Increasing the gain results in a reduction of the motion.

An excessively high gain will result in oscillation and noise. In both methods (1) and (4), the flux forming current "Isdref" is injected as a test signal. The diagram illustrates the IECON(4) method.

Parameters:

P. no. | Parameter name | Function
P 0390 | CON_ICOM | Selection of commutation variant
(0) | OFF (0) | No commutation
(1) | IENCC(1) | Autocommutation IENCC (1) with movement: Motor moves as far as half a rotor revolution, or half a pole pitch period (with p = 1).
(2) | LHMESS(2) | Autocommutation LHMES (2) with braked machine: The machine must be blocked by a suitable brake during autocommutation. The occurring torques and forces may attain the rated torque and force of the machine. Apply the method only in consultation with LTi DRiVES GmbH.
(3) | IECSC(3) | Not selectable
(4) | IECON(4) | Autocommutation IECON (4) with minimized movement: Here, too, the rotor must be able to move. However, an appropriate parameter setting can reduce the rotor motion to a few degrees/mm.
(5) | HALLS(5) | Not selectable
(6) | HALLSdigital(6) | Digital Hall sensor

  • Inexperienced users should always choose the rated motor current (amplitude) as the current and a time of at least 2000 ms.
  • The motor may move jerkily during autocommutation. The coupled mechanical system must be rated accordingly. If the axis is blocked, meaning the rotor is unable to align itself, the method will not work correctly. As a result, the commutation angle will be incorrectly defined and the motor may perform uncontrolled movements.
  • When calculating the data sets of linear motors the values for time and current adjust automatically.

LHMES(2) method

With this method, saturation effects in stator inductance are evaluated. Two test signal sequences are used for this purpose, whereby the position of the rotor axis is known after the first sequence and the direction of movement after the second.

This method is suitable for determining the rotor position with braked rotors or motors with a high mass inertia.

Precondition:

The rotor must be firmly braked. It must not move when the rated current is applied.

The stator of the machine must be iron-core.

Example:

P1503 | Direct component | 3.1 A
P1505 | Amplitude | 1 A
P1506 | Frequency of test signal | f = 333 Hz
P1508 | Number of periods | 50

It is advisable to parameterize speed tracking error monitoring with the "Power stage off" error reaction. This monitoring feature prevents the motor from racing.

Parameters of the "Autocommutation" subject area may only be changed by qualified personnel. If they are set incorrectly the motor may start up in an uncontrolled manner.


Autotuning

The drive controller is able to automatically determine the moment of inertia reduced to the motor shaft by means of a test signal. However, this requires that the mass moment of inertia only fluctuates very little or not at all during motion.

Effect of mass moment of inertia on control response:

  • It is taken into account when calculating the speed controller gain.
  • In pre-control the mass moment of inertia is used to translate the acceleration into force/torque or q-current.
  • With a parameterized observer, it represents a model parameter and the calculation of the observer gain factors is based on the set value.

To determine the mass inertia, the drive controller generates a pendulum movement of the connected motor and uses the ratio of acceleration torque to speed change to determine the mass inertia of the overall system.

Autotuning method:

  • P 1517 SCD_AT_JsumCon = "Start(2)" Determining mass inertia.
    The drive executes a short pendulum movement by accelerating several times with the parameterized torque P 1519 SCD_AT_SConHysTorq to the parameterized speed
    P 1518 SCD_AT_SConHysSpeed.
  • P 1517 SCD_AT_JsumCon = "Start(0)"If the torque and speed have not been parameterized (setting zero), the process uses default values determined on the basis of the rated speed and nominal torque.
  • The mass moment of inertia determined for the entire system is calculated after the end of the test signal and entered in parameter P 1516 SCD_Jsum.

P. no. | Parameter name | Function
P1515 | SCD_ConDesign | Rigidity of the mechanism
P1516 | SCD_Jsum | Mass moment of inertia (motor and load)
P1517 | SCD_AT_JsumCon | Automatic estimation of mass inertia, control word
P1518 | SCD_AT_SConHysSpeed | Torque limitation
P1519 | SCD_AT_SConHysTorq | Speed limitation

see: / Torque control with defined bandwidth /

see: / Test signal generator (TG) /


Test signal generator (TG)

The TG is a function for optimization of the control loops over a protracted period of motion with a reference value sequence. It is possible to form various signal types and transfer them to the control. This function is independent of the control mode, and acts directly on the control.

Flowchart for selection of output signal P 1501 SCD_TSGenCon:

P. no. | Parameter name Setting | Function | Figure
P1500 | SCD_TSGenCon | Control word of test signal generator |
(0) | OFF | Test signal generator deactivated |
(1) | Stop | Test signal stopped |
(2) | Start | Test signal started |
P1501 | SCD_TSGenCon | Test signal generator output selector |
(0) | Off | Output not used |
(1) | isdref | Output connected to flux-forming current controller |
(2) | mref | Output connected to torque-forming current controller |
(3) | sref | Output connected to speed controller |
(4) | epsref | Output connected to position controller |
(5) | sramp | Output connected to ramp generator |
P1502 | SCD_TSIG_Cycles | Number of repeat cycles |
P1503 | SCD_TSIG_Offset | Offset of square signal
(0) |  | Offset of square signal stage 1
(1) |  | Offset of square signal stage 2
P1504 | SCD_TSIG_Time | Period of square signal
(0) |  | Time t1
(1) |  | Time t2
P1505 | SCD_TSIG_Amp | Amplitude of sine signal |
P1506 | SCD_TSIG_Freq | Frequency of sine signal
P1507 | SCD_TSIG_SetPhase | Phase angle of signal: Start phase of current space vector in VFCON and ICON mode |
P1508 | SCD_TSIG_ PRBSTime | PRBS signal generator, sampling time | A PRBS (Pseudo-Random Binary Sequence) noise signal with presetting of amplitude P 1509 SCD_TSIG_PRBSAmp and cycle time P 1508 SCD_TSIG_ PRBSTime. This enables different frequency responses to be plotted.
P1509 | SCD_TSIG_ PRBSAmp | PRBS signal generator, amplitude
P1510 | SCD_TSIG_SignalType | Signal shape: Sine/delta |
P1511 | SCD_TSIG_BreakTime | Break time |

Example of overlaying a sine signal over a square signal:

Example of PRBS signal

The PRBS signal is suitable for achieving a high-bandwidth system excitation with a test signal. A binary output sequence with parameterizable amplitude P 1509 SCD_TSIG_ RBSAmp and a "random" alternating frequency is generated with the aid of a looped-back shift register.

see: / Autotuning /

see: / Torque control with defined bandwidth /


Current controller tuning

see: / Analysis (optimization) of torque control /


Torque control with defined bandwidth

It is possible, based on the bandwidth, to carry out a current controller draft design. In this, the controller gains can be determined by activating test signals (Autotuning). The calculations and the relevant autotuning are carried out in the drive controller. The advanced settings are made in parameters P 1530 SCD_SetMotorControl, P 1531 SCD_Action_Sel and P 1533 SCD_AT_Bandwidth.

P. no. | Parameter name | Function
P1530 | SCD_SetMotorControl |
(3) | 3- SCD_SetCCon_by Bandwidth | Setting 3: CalcCCon_PI Calculation of the current controller parameters based on the motor data and the specified bandwidth
(4) | SCD_SetCCon_Deadbeat | This setting parameterizes a dead-beat controller. The structure is switched to feedback with observer, the observer is designed (to a specific equivalent time constant - for setting see parameter CON_CCON_ObsPara - index 0) and the current controller gains are calculated accordingly.
P1531 | SCD_Action_Sel |
(6) | SCD_Action_Sel_TuneCCon | Setting 6: TuneCCon Activation of sinusoidal test signals and adaptation of the current controller parameters based on the specified bandwidth
P 1533(0) | SCD_AT_Bandwidth | Bandwidth specification for current control loop: Setting range: 10 - 4000 Hz

  • The bandwidth corresponds to the frequency at which the transfer function of the closed control loop is reduced by 3 dB.
  • Advisable bandwidth settings at 8 kHz switching frequency are up to approximately 2000 Hz; at 16 kHz switching frequency up to approximately 3000 Hz.
  • The P-gain CCON_Kp is calculated according to the amount optimum. The lag time CCON_Tn is interpolated between the amount optimum and the symmetrical optimum.

see: / Autotuning /

see: / Test signal generator (TG) /


VFC mode

In VFC mode it is possible to run a simple test indicating to the user whether a motor is connected correctly and moving in the right direction (linear drive: clockwise/anti-clockwise). If the direction has been reversed, the motor is stopped or executing uncontrollable movements, the termination and the motor data must be checked.
As a test mode, a voltage/frequency control system is implemented in such a way that the closed-loop speed control circuit is replaced by open-loop control. So the reference in this case is also the speed reference; the actual speed is set equal to the reference. A linear characteristic with two interpolation points is implemented, with a fixed boost voltage setting P 0313 CON_VFC_VBoost at 0 Hertz. As from the rated frequency P 0314 CON_VFC_FNom the output voltage remains constant. An asynchronous machine is thus automatically driven into field-weakening as the frequency rises.

In the "Initial commissioning" section it is possible to perform a wiring test with the VFC mode setting.

see: / Initial commissioning - Rotary system /

see: / Initial commissioning - Linear system /


Function of process controller

The process controller function enables a measured process variable to be controlled to a reference (setpoint) value.

Features:

  • Process controller calculation in speed controller cycle
  • Process controller as PI controller with Kp adaptation
  • Process controller actual value selectable via selector
  • Filtering and offset correct of reference and actual values
  • Process controller output can be connected to different points in the general control structure
  • Process controller is usable in all control modes

Control structure of the process controller:

Method of using the process controller:

  • Set process controller reference value:
    P 2666 CON_PRC_REFVAL: Reference input in user units (this parameter can be written cyclically over a field bus).
  • Scaling of process controller reference value:
    P 2667 CON_PRC_REFSCALE; The reference P 2666 CON_PRC_REFVAL can be scaled (taking into account the user units, see Application Manual, "Scaling".
  • Select actual value sources:
    P 2668 CON_PRC_ACTSEL: The actual value source must be set to the desired reference source (e.g. field bus). The field bus writes the actual value to parameter
    P 2677 CON_PRC_ACTVAL_FIELDBUS
  • Select offset (optional) P 2669 CON_PRC_ACTOFFSET: Setting of an offset for actual value calibration
  • Scaling of process controller actual value:
    P 2670 CON_PRC_ACTTF; filter time for actual value filter [ms]. The actual value is smoothed via the lag time of the PT-1 filter. (Taking into account the user units)
  • Inversion of the control difference
    P 2665 CON_PRC_CDIFF_SIGN: Adaptation of control difference sign
  • Activate process controller:
    P 2681 CON_PRC_CtrlWord: Control word bit 0 = 1 (process controller active). This bit must be reset after every restart. The bit is not stored in the data set.
  • Optimization of controller setting:
    P 2659 CON_PRC_Kp: Controller gain
    P 2660 CON_PRC_KP_SCALE: Scaling of gain
    P 2661 CON_PRC_Tn: TN lag time: If the lag time is set to the permissible maximum value, the I-component of the controller is inactive (10000 ms = off).
  • Offset for the process controller output
    P 2662 CON_PRC_REFOFFSET: Then the totalled variable is connected via a limitation to the output of the process control loop. The user can parameterize the limitation via parameter P 2663 CON_PRC_LIMPOS for the positive limit and P 2664 CON_PRC_LIMNEG for the negative limit.

Parameters:

P. no. | Parameter name | Function
P2659 | CON_PRC_Kp | P-gain of the process controller
P2660 | CON_PRC_KP_SCALE | Adaptation of the P-gain
P2661 | CON_PRC_Tn | Process controller lag time
P2662 | CON_PRC_REFOFFSET | Offset for the process controller output
P2663 | CON_PRC_LIMPOS | Positive process controller limitation
P2664 | CON_PRC_LIMNEG | Negative process controller limitation
P2665 | CON_PRC_CDIFF_SIGN | Adaptation of control difference sign
P2666 | CON_PRC_REFVAL | Process control reference value
P2667 | CON_PRC_REFSCALE | Scaling factor for the process controller reference
P2668 | CON_PRC_ACTSEL | Selection of the actual value source
(0) | ISA00 | Analog input 0
(1) | ISA01 | Analog input 1
(2) | Fieldbus | Field bus parameter CON PRC_ACTVAL_Fieldbus-ID 2677
(3) | REFSPEED | Actual speed [rpm]
(4) | REFPOS | Actual position [increments]
(5) | ISQREF | Rack and Pinion Drive Control (RPDC) describes a method of controlling a rack and pinion drive or planetary gear drive with two motors. The aim here is, firstly, to achieve a tension between the two motors so as to compensate for slack between the gear wheels. The control configuration should be a master/slave combination, so that the slave supports the master in positioning when the torque request is greater than the tension moment. In this case the slave drive is run as a result of the previously compensated slack so as to support the master in a positioning operation. This function requires further parameter settings - see "Rack and Pinion Drive Control (RPDC)" document (contact LTi DRiVES GmbH for details).
P2669 | CON_PRC_ACTOFFSET | Offset for actual value calibration
P2670 | CON_PRC_ACTTF | Filter time for actual value filter
P2671 | CON_PRC_ACTSCALE | Scaling for the filtered process actual value
P2672 | CON_PRC_OUTSEL | Selection parameter for the process controller output
(0) | OFF | OFF
(1) | REFTORQUE | Additive torque reference
(2) | REFSPEED | Additive speed reference
(3) | REFPOS | Additive position reference
(4) | MOPRO_Output to P 2678 | Value for MotionProfile (CON_PRC_OUTSEL_MOPRO - ID 2678)
P2673 | CON_PRC_RAW_ACTVAL | Actual value of the selected actual value source
P2674 | CON_PRC_ACTVAL | Momentary actual value of the process controller after filtering and scaling
P2675 | CON_PRC_CDIFF | Control difference of the process control loop
P2676 | CON_PRC_OUTVAL | Process controller control variable
P2677 | CON_PRC_ACTVAL_FIELDBUS | Parameter to which an actual value can be written from the field bus
P2678 | CON_PRC_OUTSEL_MOPRO | Parameter to which the control variable can be written in order to be subsequently used in the motion profile.
P2679 | CON_PRC_RefReached | "Reference reached" window
P2680 | CON_PRC_RateLimiter | Steepness limitation of the control variable
(0) | RateLimiter | Steepness limitation in standard user units controller operation; unit: [Userunits/ms]
(1) | RateLimiter | Steepness limitation to reduce the process controller I-component; unit: [user units/ms]
P2681 | CON_PRC_CtrlWord | Control word of the process controller
(0) | PRC_CTRL_ON | START; switch on process controller
(1) | PRC_CTRL_ResetIReady | Reset I-component via ramp after P 2680 /subindex 1
(2)-(7) | PRC_CTRL_FREE | Reserve
P2882 | CON_PRC_StatWord | Status word of the process controller
(0) | PRC_STAT_On | Switch on process controller
(1) | PRC_STAT_ResetIReady | I-component of the process controller is reduced
(2)-(7) | PRC_STAT_FREE | Reserve
P2683 | CON_PRC_REFSEL | Selection of reference source
(0) | USER | User reference of P 2684
(1) | RPDC | Reference of planetary gear
(2) | ISA00 | Reference of analog input ISA00
(3) | ISA01 | Reference value of analog input ISA01
P2684 | CON_PRC_REFVAL_User | User input of process control reference

see: / RateLimiter /


RateLimiter

Downstream of the control variable limiter there is another limitation which limits the changes to the control variable per sampling segment. By way of field parameter P 2680 CON_PRC_RateLimiter the limitation of the control variable steepness per millisecond can be parameterized.
By way of index (0) the limitation is active in standard process controller operation. By way of index (1) reduction of the I-component is activated (see table).
With P 2672 CON_PRC_OUTSEL = 3 the process controller delivers an additive position reference value. The Ratelimiter limits the possible control variable change. The control variable change each time interval by the process controller results in a speed change on the motor shaft.

Example:

The amount of the process controller to change the speed on the motor shaft should not be higher than 100 revolutions per minute. To achieve this, the value of parameter P 2680 (0) CON_PRC_RateLimiter must be parameterized with a value corresponding to the user unit. The unit of this parameter is [x/ms]. The x stands for the respective unit of the process controller output variable. In this example the control variable (additive position reference) has the unit "Increments"
(see also parameter P 270 MPRO_FG_PosNorm). This parameter indicates how many increments correspond to one motor revolution.

Example: Conversion from [rpm] to [Inc/ms]:

nchange = 100 rpm

P 0270 MPRO_FG_PosNorm in inc/rev
Internal position resolution = 1048576 inc/rev (default)

P 2680 CON_PRC_RateLimiter = n change*1048576 *1/60000

P 2680 [Inc/ms] = 100 [rpm] * P 0270 [inc/rev] * 1/60 [min/s] * 1/1000 [s/ms]

To reduce the I-component, the same method is applicable P 2680(1) CON_PRC_RateLimiter(1) [Inc/ms]).

Parameters:

P. no. | Parameter name | Function
P2672 | CON_PRC_OUTSEL | Process controller output selector
(0) | OFF (0) | No reference selected
(1) | Additive torque reference (1) | Additive torque reference must be given in [Nm]
(2) | Additive speed reference (2) | Additive speed reference must be given in [rpm]
(3) | Additive position reference (3) | Additive position reference must be given in [increments]
(4) | Value for MotionProfile P 2678 CON_PRC_OUTSEL_MOPRO | P 2678 CON_PRC_OUTSEL_MOPRO is the parameter to which the control variable can be written in order to be subsequently used in the motion profile.
P2680 | CON_PRC_RateLimiter | Steepness limitation of the control variable
(0) | RateLimiter | Steepness limitation in standard process controller operation; unit [user unit/ms]
(1) | RateLimiter | Steepness limitation to reduce the process controller I-component; unit [user unit/ms]
P 0270 | MPRO_FG_PosNorm | Internal position resolution [incr/rev]

If a change in control variable is not desired, P 2680 CON_PRC_RateLimiter must be parameterized with the value zero.

Scope signals for visualization of the process control loop

No. | Parameter name | Function
P2675 | CON_PRC_Cdiff_ | Control difference of the process controller
P2666 | CON_PRC_RefVal | Process controller reference
P2673 | CON_PRC_Raw_ActVal | Actual value of the selected actual value source
P2674 | CON_RPC_Actval | Momentary actual value of the process controller; after filtering and scaling
P2676 | CCON_PRC_Outval | Process controller control variable

see: / Function of process controller /


Modulo weighting

If Modulo (indexing table application) is to be selected, the number range of the position data (modulo value) must be entered. When the modulo value is exceeded the actual position is reset to 0.

see: / Indexing table function setting "as linear" /

see: / Indexing table function setting "Direction of rotation" /

see: / Indexing table function "Infinite "driving job" /

see: / Indexing table function "Relative driving job" /

see: / Indexing table function "Path-optimized movement" /


Acceleration weighting

The schematic "Weighting of acceleration data" shows the layout of the individual dialog boxes for scaling using the SERCOS assistant.

If "no weighting" is selected, the weighting factor and weighting exponent are irrelevant.

Example of linear preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting (LSB) | Parameter weighting (LSB)
Linear | m/s2 | 1 | E-6 |

Example of rotary preferential weighting:

Weighting method | Unit | Rotary position resolution | Preferential weighting | Parameter weighting (LSB)
Rotary | rad/s2 | 3 600 000 | E-3 |


Speed weighting

The schematic "Weighting of speed data" shows the layout of the individual dialog boxes for scaling using the SERCOS assistant.
If "no weighting" is selected, the weighting factor and weighting exponent are irrelevant.

Speed polarity:

The polarity of the speed data can be inverted according to the application. A positive speed reference indicates clockwise rotation (looking at the motor shaft).

Example of linear preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting (LSB) | Parameter weighting (LSB)
Linear | m/min | 1 | 0.001 m/min |

Example of rotary preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting | Parameter weighting (LSB)
Rotary | Degrees | 3 600 000 | 0.001 m/min |


Weighting of position data

The schematic "Weighting of position data" shows the layout of the individual dialog boxes for scaling using the SERCOS assistant.

If "no weighting" is selected, the weighting factor and weighting exponent are irrelevant.

Position polarity:

The polarity of the position data can be inverted according to the application. An increasing actual position value indicates clockwise rotation (looking at the motor shaft).

Example of linear preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting (LSB) | Parameter weighting (LSB)
Linear | m | 1 | E-7 | 0.1 m

Example of rotary preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting | Parameter weighting (LSB)
Rotary | Degrees | 3 600 000 | 0.0001 m |


Force/torque weighting

The schematic "Weighting of force/torque data" shows the layout of the individual dialog boxes for scaling using the SERCOS assistant.

If "no weighting" is selected, the weighting factor and weighting exponent are irrelevant.

In percentage weighting the permanently permissible standstill torque of the motor is used as the reference value. All torque/force data is given in [%] with one decimal place.

Torque polarity:

The polarity of the torque can be inverted according to the application. A positive torque reference indicates clockwise rotation (looking at the motor shaft).

Example of linear preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting (LSB) | Parameter weighting (LSB)
Linear | Nm | 1 | 0 | LSB = Unit * Exponent

Example of rotary preferential weighting:

Weighting method | Unit | Weighting factor | Preferential weighting (LSB) | Parameter weighting (LSB)
Rotary | Nm | 1 | 0.01 Nm | LSB = Unit * Exponent


Weighting via the SERCOS profile

When using the SERCOS profile, the term "weighting" is used in defining the units.

The weighting describes the physical unit and the exponent with which the numerical values of the parameters exchanged between the master control system and the drives are to be interpreted.
The method of weighting is defined by the parameters for position, speed, torque and acceleration weighting.

Weighting via SERCOS profile

The SERCOS scaling assistant is used to set the position, speed, torque and acceleration.

So as not to have to display all individual dialog boxes, the following schematic views are presented:

  • Schematic 1 : Position data weighting method
  • Schematic 2 : Speed data weighting method
  • Schematic 3 : Force/torque weighting method
  • Schematic 4 : Acceleration weighting method

see: / Scaling /

see: / Acceleration weighting /

see: / Speed weighting /

see: / Modulo weighting /

see: / Weighting of position data /

see: / Force/torque weighting /


User-defined scaling

No assistant is available for user-defined scaling. The following schematic is provided as an aid to parameter setting. Calculation of the factors for position, speed and acceleration is dependent on the selected user unit and the feed constant or gear ratio.

User-defined scaling

P. no. | Parameter name | Function | Default setting for rotary motor: | Internal unit
P 0270 | MPRO_FG_PosNom | Increments per revolution | 1048576 [incr/rev] |
P 0271 | MPRO_FG_Nom | Numerator | 1[rev] | Pos/1
P 0272 | MPRO_FG_Den | Denominator | 360°; [POS] | Position per revolution
P 0273 | MPRO_FG_Reverse | Reverse direction | False = clockwise |
P 0274 | MPRO_FG_SpeedFac | Speed factor | 1[rpm] | rpm
P 0275 | MPRO_FG_AccFac | Acceleration factor | 1/60 = 0.01667 [rpm/s] | U/s2
P 0284 | MPRO_FG_PosUnit | Unit for position value | mdegree |
P 0287 | MPRO_FG_SpeetUnit | Unit for speed value | rev/min |
P 0290 | MPRO_FG_AccUnit | Unit for acceleration value | rev/min/s |

Example of scaling of a rotary motor:

Default: 1 motor revolution corresponds to 360°; or 1048576 increments

  • Velocity in [rpm]
  • Acceleration in [rpm/s]
  • Positioning in [°;degrees]

Given:
Position unit P 0284 MPRO_FG_PosUnit = [m]

Speed unit P 0287 MPRO_FG_SpeedUnit = [m/s]

Acceleration unit P 0290 MPRO_FG_AccUnit = [m/s2]

Feed constant: 0.1 mm = 1 rev

Gearing: 1 drive revolution = 3 motor revs

Parameter setting:

P 0284 MPRO_FG_PosUnit = 1 m = 1/1000 mm = 10/1000 rev (output) = 30/1000 rev (motor)

P 0271 MPRO_FG_Nom = 3

P 0272 MPRO_FG_Den = 100

P 0287 MPRO_FG_SpeedUnit = 1 m/s = 1000 mm/s = 10 000 rev/s (output) = 30 000 rev/s (motor)*60 (min) = 1 800 000 rev/min

P 0275 MPRO_FG_SpeedFac = 1 800 000

P 0290 MPRO_FG_AccUnit = 1 m/s2 = 1000 mm/s = 10 000 rev/s (output) = 30 000 rev/s2 (motor)*60 (min) = 1 800 000 rev/min

===================================================================================

Example of scaling of a linear motor:

Given:

Default: One revolution corresponds to 32 mm pitch

  • Travel in [m]
  • Speed in [mm/sec]
  • Acceleration in [mm/s2]

Parameter setting:

P. no. | Parameter name | Description | Default setting for linear motor:
P 0270 | MPRO_FG_PosNorm | Increments/revolution | 1048576
P 0271 | MPRO_FG_Num | Numerator | 1
P 0272 | MPRO_FG_Den | Denominator | 32000 m
P 0273 | MPRO_FG_Reverse | Direction of rotation | False (clockwise)
P 0274 | MPRO_FG_SpeedFac | Speed factor | 1.875 rps corresponding to 1 mm/s, 1/32 mm = 0.03125 rps2 0.03125 rps2*60 s = 1.875 rps
P 0275 | MPRO_FG_AccFac | Acceleration factor | 1/32 mm = 0.03125 rps2 corresponding to 1 mm/s2

see: / Scaling /


Indexing table function setting "Direction of rotation"

The indexing table function is set up in the "Motion profile scaling" subject area. For the upper position a limit value must be entered specifying the point at which a revolution is complete.

.

Example of a revolution with a circumferential length of 360°;, setting "Direction of rotation anti-clockwise/clockwise:

The circumferential length is set to 360°;. In positive direction, after reaching 360°; the actual position is set to 0°;. The same applies to the negative direction. On reaching 0°; the actual position is set to 360°;.

Direction anti-clockwise/clockwise

see: / Scaling /

see: / Indexing table function setting "as linear" /

see: / Indexing table function "Infinite "driving job" /

see: / Indexing table function "Relative driving job" /

see: / Indexing table function "Path-optimized movement" /


Indexing table function setting "as linear"

The indexing table function is set up in the "Motion profile scaling" subject area. For the upper position a limit value must be entered specifying the point at which a revolution is complete.

Example of a revolution with a circumferential length of 360°;, setting "as linear":
The circumferential length is set to 360°;. In positive direction, after reaching 360°; the actual position is set to 0°;. The same applies to the negative direction.

It is not necessary to preset a negative reference for the reversal of direction.

On reaching 0°; the actual position is set to 360°;.

see: / Indexing table function setting "Direction of rotation" /

see: / Indexing table function "Infinite "driving job" /

see: / Indexing table function "Relative driving job" /

see: / Indexing table function "Path-optimized movement" /


Indexing table function "Infinite "driving job"

In the case of infinite driving jobs the drive moves at constant speed, regardless of a transmitted target position, until the mode is deactivated or is overwritten by a new driving job. On switching to the next driving set (absolute or relative), the new target position is approached in the current direction of movement.

Any path optimization setting is ignored when indexing table is active.

see: / Indexing table function setting "Direction of rotation" /

see: / Indexing table function setting "as linear" /

see: / Indexing table function "Relative driving job" /

see: / Indexing table function "Path-optimized movement" /


Indexing table function "Relative driving job"

Relative driving jobs may relate to the current target position or to the actual position. For more information see "Field bus" user manuals.
In the case of relative driving jobs greater travel distances than the circumferential length are possible.

Example without gear ratio:

  • Circumferential length = 360°;
  • Relative target position = 800°;
  • Start position = 0°;
  • Movement:
    The drive performs two motor revolutions (720°;) and stops on the third at 80°; (800°; - 720°;).

see: / Indexing table function setting "Direction of rotation" /

see: / Indexing table function setting "as linear" /

see: / Indexing table function "Infinite "driving job" /

see: / Indexing table function "Path-optimized movement" /


Indexing table function "Path-optimized movement"

Path-optimized movement

With "Path optimization" activated, an absolute target position is always approached by the shortest path.

Relative movements are not executed "path-optimized".

Travel range

 Effect
Target position less than circumferential length: 120°; < 360°; | The drive moves to the specified target position.
Target position = circumferential length: 120°; = 120°; | The drive stops
Target position greater than circumferential length:

600°; - (1 x 360°;) = 240°;

800°; - (2 x 360°;) = 80°; 		The drive moves to the position within the circumference (target position - (n x circumferential length))

Comparison of indexing table movement without and with path optimization

Without path optimization | With path optimization

see: / Indexing table function setting "Direction of rotation" /

see: / Indexing table function setting "as linear" /

see: / Indexing table function "Infinite "driving job" /

see: / Indexing table function "Relative driving job" /


Scaling

In the "Scaling" subject area reference values can be converted into user-defined distance units. These values are converted into device-internal units. An assistant is provided for scaling in the standard/CiA 402 and SERCOS profiles. To start it, click the "Scaling/units" button. Scaling via USER is only possible by way of the Parameter Editor.

Scaling assistant:

1. Selecting the assistant

Selecting the scaling assistant:

There is no assistant to assist with "User-defined selection". The parameters must be set using the editor.

2. Selecting the units

 Definition of the units for position, speed and acceleration. The scaling is entered using the Exponent syntax.

3. Selecting the direction of rotation

Definition of direction:

Referred to the motor, the positive direction is clockwise as seen when looking at the motor shaft (A-side bearing plate).

4. Feed constant; gear ratio,
resolution of position encoder

Feed constant:
Distance covered is always relative to one revolution on the output side.

Gear ratio:
Ratio of one motor revolution before the gearing to the number of revolutions on the gear output side. The values for the gear ratio are entered in the dialog box as integer fractions.

Singleturn resolution
The single-turn resolution of the position controller can be adapted variably to the application. The default value of 20 bits = 1048576 stands at 11 bits for the multi-turn position until the overflow of the actual position is reached. If a larger range is desired for the multi-turn position, the resolution must be reduced.

P. no. | Parameter name | Function
P 0283 | MPRO_FG_Type | Scaling source
(0) | STD_DS 402 | Scaling based on parameters specified in the DS 402 profile.
(1) | SERCOS | Scaling based on parameters P 0270 to P 0275 specified in the SERCOS profile
(2) | User specific | Scaling based on parameters P 0270 to P 0275


Basic settings

Motion profile selection dialog box
Setting of control location, reference source, start condition, profiles and a possible reversing lock.

Parameter

P. no. | Parameter name / Settings | Function
P 0159 | MPRO_CTRL_SEL | Selection of control location
(0) | OFF (0) | No control location selected
(1) | TERM(1) | Control via terminal
(2) | PARA (2) | via parameter
(3) | (3) | Not defined
(4) | PLC(4) | IEC 61131 (iPLC)
(5) | CiA 402(5) | CiA 402
(6) | SERCOS II(6) | SERCOS II
(7) | PROFIBUS(7) | PROFIBUS
(8) | VARAN |
(9) | SERCOS III |
(10) | TWIN |
P 0144 | MPRO_DRVCOM_Auto_start | Autostart function
(0) | Off(0) | Normal operation: The drive is stopped by cancelling the start condition or in the event of an error.
(1) | ON (1) | The drive automatically starts immediately on completion of initialization, provided the mains voltage is connected.
P 0165 | MPRO_REF_SEL | Selection of reference source
(0) | OFF (0) | No reference selected
(1) | ANA0(1) | Analog input ISA0
(2) | ANA1(2) | Analog input ISA1
(3) | TAB(3) | Table values
(4) | PLC4) | via PLC basic library
(5) | PLC(5) | via PLC open library
(6) | PARA (6) | The reference is preset by parameter
(7) | DS402(7) | DS402
(8) | SERCOS(8) | SERCOS
(9) | PROFIBUS(9) | PROFIBUS
(10) | VARAN | VARAN
(11) | TWIN | TWIN
P 0167 | % | The reference is weighted in percent dependent on the maximum specified reference value
P 0301 | Con_Ref_Mode | Selection of interpolation mode
(0) | PG(0) | PG(0): The internal reference is generated by the Profile Generator. In it, all ramp functions, such as acceleration and braking ramps, jerk, smoothing are implemented. The internal generation is always executed at a sampling time of 1 ms.
(1) | IP(1) | IP(1): The reference input of the higher-level PLC is routed directly to the Fine Interpolator. Adaptation of the sampling time between the PLC and the drive controller is essential.
P 0306 | CON_IpRefTS | Adaptation of sampling time between ext. PLC and drive controller
 | 0.25 ms - 1000 ms |
P 0335 | CON_SCON_DirLock | Reversing lock for actual speed value
P2243 | MPRO_402_Motion_ProfType |
(0) | LinRamp(0) | Linear ramp
(1) | not used(1) | Vacant
(2) | not used(2) | Vacant
(3) | JerkLim(3) | Effect with smoothing time set in P 0166.
P 0370 | CON_IP | Selection of interpolation method
(0) | NoIp(0) | The interpolation methods are described in section 1.2.
(1) | Lin (1) | Linear interpolation
(2) | SplineExtFF(2) | Interpolation with external pre-control value
(3) | SplineII(3) | Cubic spline interpolation
(4) | NonIPSpline(4) | Cubic spline approximation

see: / Initial commissioning - Rotary system /

see: / Initial commissioning - Linear system /


Stop ramps

Each reference source has its own acceleration and braking ramps. There is also the stop ramp (quick-stop ramp) to the DS402 standard. The ramp functions are only effective in certain system states. The required settings can be selected from the dialog box.
Clicking the "Error/fault reactions" button directly accesses the dialog box for the error reactions.

Reaction to "Quickstop"
If the drive needs to be shut down as rapidly as possible due to a malfunction, it must be run down to speed zero on an appropriate ramp.
The "Quickstop" function brakes an ongoing movement differently from the normal braking ramp. The drive controller is in the "Quickstop" system state. This state can be quit during or after braking, depending on the status of the quick-stop command and the respective reaction.

P. no. | Parameter name Setting | Function
P2218 | MPRO_402_QuickStop_OC | Quickstop Option code
(0) | POFF(0) = Disable power stage/drive function | Disable power stages. The drive coasts to a stop
(1) | SDR(1) = Slow down on slow down ramp | The drive brakes with the programmed deceleration ramp, then the power stage is disabled.
(2) | QSR(2) = Slow down on slow quickstop ramp | Braking with quick-stop ramp, then the power stage is disabled. The factory setting QSR(2) incorporates use of a holding brake. If the settings differ from the factory setting, the possible use of a holding brake needs to be taken into account.
(3) | CLIM(3) = Slow down on current limit | Braking with max. dynamism at current limit. The speed reference value is set equal to 0, then the power stage is disabled.
(4) | not implemented(4) | Not defined
(5) | SDR_QS(5) = Slow down on slow ramp and stay in quickstop | Braking with programmed deceleration ramp. The drive remains in the quick stop state, current is applied to the axis at zero speed. 1)
(6) | QSR_QS(6) = Slow down on quickstop ramp and stay in quickstop | Braking with quick-stop ramp. The drive remains in the quick-stop state, current is applied to the axis at speed 0. 1)
(7) | CLIM_QS(7) = Slow down on current limit and stay in quickstop | Braking with max. dynamism at the current limit, the speed reference is set equal to 0. The drive remains in the quick-stop state, current is applied to the axis at speed 0. 1)
(8) | Reserve |
1)Transition to the "Ready for start" state is only possible by resetting the quick stop request. In the "Quick-stop" state cancelling the "Start closed-loop control/drive" signal has no effect as long as the quick-stop request is not reset as well.

Reaction to "shutdown"

P. no. | Parameter name Setting | Function
P2219 | MPRO_402_Shutdown_OC | Shutdown_Optioncode
(-1) | QSOPC(-1) = According Quickstop option code | In the event of a Shutdown command the stop variant selected in In the event of a Shutdown command the stop variant selected in "Reaction at quick-stop command" P 2218 MPRO_BRK_StartTorq is executed.
(0) | POFF(0) = Disable power stage/drive function | Disable power stages; the drive coasts to a stop
(1) | SDR(1) = Slow down with slow down ramp; disable of the drive function | The drive brakes with the parameterized deceleration ramp down to speed zero. Then the holding brake - if fitted - engages according to its parameter setting.

Reaction to "disable Operation"

The "disable operation option code" parameter determines which action is to be executed at the transition from "Operation enable" to "Switched on" (states 4 and 5 of the state machine).

P. no. | Parameter name Setting | Function
P2220 | MPRO_402_DisableOp_OC | Reaction to "disable Operation"
(0) | POFF(0) = Disable power stage/drive function | Disable power stages; drive coasts to a stop
(1) | SDR(1) = Slow down with slow down ramp; disable of the drive function | The drive brakes with the programmed deceleration ramp, then the power stage is disabled.

Reaction to "Halt Operation"

The "Halt" state brakes an ongoing movement for as long as the state is active. During braking the drive can be accelerated back to the previous state. When deactivated, the programmed acceleration ramp is again applied.

P. no. | Parameter name Setting | Function
P2221 | MPRO_402_Halt_OC | Reaction to "Halt Operation"
(1) | SDR(1) = Slow down on slow down ramp | The drive brakes with a programmed deceleration ramp
(2) | QSR(2) = Slow down on slow quickstop ramp | Braking with emergency stop ramp
(3) | CLIM(3) = Slow down on current limit | Braking with max. dynamism at current limit. The speed reference is set equal to 0.
(4) | Free(4) |

Reaction to error / "FaultReaction"

P. no. | Parameter name Setting | Function
P2222 | MPRO_402_FaultReaction_OC | Reaction to error
(1) | SDR(1) = Disabled drive, motor is free to rotate | Disable power stages; the drive coasts to a stop
(2) | QSR(2) = Slow down on slow down ramp | The drive brakes with a programmed deceleration ramp
(3) | CLIM(3) = Slow down on current limit | Braking with max. dynamism at current limit. The speed reference is set equal to 0
(4) | Free(4) |

Ramp for "Quickstop"

P. no. | Parameter name Setting | Function
P2242 | MPRO_402_Quickstop_Dec_OC | Ramp for Quickstop
(0) | Quick stop | Setting of quick-stop ramp


Speed control in PG mode

Profile generator mode / PG mode

  • Select reference source
  • Motion profile adaptation: scaling, ramps and smoothing time.
  • In reference processing by way of the profile generator the fine interpolator is always in use.

Method - Profile generator in speed control:

  • Control mode P 0300 CON_CfgCon: = speed control
  • Under Profile select the profile generator (PG) P 0301 CON_REF_Mode = PG(0)
  • Select reference source P 0165 MPRO_REF_SEL
  • Scaling
  • Select jerk conditions
  • Set stop ramps, smoothing, filter, homing
    see: / Stop ramps /

see: / Speed control in IP mode /

see: / Position control in IP mode /

see: / Position control in PG mode /

see: / Jerk limitation and speed offset /

see: / IP and PG mode /


Speed control in IP mode

Interpolation mode / IP mode

  • Reference values are interpolated in linear mode before being switched to the control loops.
  • The profile generator is inactive.
  • Ramps and smoothing are inactive.
  • The reference values are switched directly to the loop control.
    Note that the mechanism may be destroyed when this is done.

Method - Speed control in IP mode:

  • Control mode P 0300 CON_CfgCon = speed control or setting via Modes of Operation (CAN, EtherCAT)
  • Selection of reference source P 0165 MPRO_REF_SEL
  • Scaling
  • In speed control
  • mode interpolation is always linear.

see: / Speed control in PG mode /

see: / Position control in IP mode /

see: / Position control in PG mode /

see: / Jerk limitation and speed offset /

see: / IP and PG mode /


Position control in PG mode

Profile generator mode / PG mode

Positioning commands are transmitted to the internal profile generator (subject area motion profile "Basic setting").

  • With the values for jerk P 0166 MPRO_REF_JTIME and an override factor P 0167 MPRO_REF_OVR for the positioning speed, the profile generator generates a time-optimized trajectory for the position reference taking into account all limits.
  • The position references are then processed with the selected interpolation method.
  • The position references are used to generate pre-control values for speed and acceleration. These are scanned at the sampling time of the position controller (normally 125 s) and switched to the control loops.

    A positioning command consists of:
    Target position
    Maximum positioning speed
    Maximum acceleration
    Maximum deceleration

  • When using a bus system apply the relevant bus document.

see: / Speed control in IP mode /

see: / Speed control in PG mode /

see: / Position control in IP mode /

see: / Jerk limitation and speed offset /

see: / IP and PG mode /


Position control in IP mode

Interpolation mode / IP mode

  • Position reference values are preset by a higher-level PLC with an appropriate sampling time.
  • The sampling time must be balanced between the PLC and controller P 0306 CON_IpRefTS.
  • The position references are then transferred to the fine interpolator.
  • Pre-control values for speed and acceleration are switched to the control loops.
  • For more information on the sampling time refer to the field bus documentation.

see: / Speed control in IP mode /

see: / Speed control in PG mode /

see: / Position control in PG mode /

see: / Jerk limitation and speed offset /

see: / IP and PG mode /


Jerk limitation and speed offset

The transfer path from the motor to the mechanism may be elastisc and so susceptible to oscillation. For that reason, it is advisable to also limit the maximum rate of change of the torque and thus the jerk.

Due to the jerk limitation the acceleration and deceleration times rise by the smoothing P 0166 MPRO_REF_JTIME. The smoothing setting box appears on-screen as soon as JerkLin(3) is set in parameter P 2243 "MPRO_402_MotionProf type".
With speed override P 0167 MPRO_REF_OVR the maximum preset speed reference can be scaled in percent.

Profile type without smoothing

Red = actual speed

Grey = actual position

The acceleration and braking ramps indicate maximum jerk (red curve)

Profile type with smoothing

Red = actual speed

Grey = actual position

The acceleration and braking ramps indicate the preset smoothing of 2000 ms (red curve)

Parameter

P.no. | Parameter name /Settings | Function
P 0166 | MPRO_REF_JTIME | Setting of smoothing time (jerk limitation)
P 0167 | MPRO_REF_OVR | The reference is weighted in percent dependent on the maximum specified reference value
P2243 | MPRO_402_MotionProfType | The smoothing time is only selectable when the parameter is set to Jerklim(3).

see: / Speed control in IP mode /

see: / Speed control in PG mode /

see: / Position control in IP mode /

see: / Position control in PG mode /

see: / IP and PG mode /


Homing method (-12)

Method (-12)

To set the machine reference point the rotor or linear axis is moved to the machine reference point. The desired actual position is written to the "Offset" parameter P 2234 MPRO_402_Homeoffset. Then the axis must be homed once. Each time the axis is restarted the absolute position is automatically calculated. Each further activation of homing resets the machine reference point at the current position.


Homing method (-10) and (-11)

Method -10

Approach block, clockwise with zero pulse.

With P 0169 MPRO_REF_HOMING_MaxDistance the positioning range in which to search for the block is specified.

After approaching the block, the drive reverses the direction of rotation until a zero pulse is detected.

An offset can be programmed in the dialog box.

Method -11

Approach block, anti-clockwise with zero pulse.

With P 0169 P 0169 MPRO_REF_HOMING_MaxDistance the positioning range in which to search for the block is specified.

After approaching the block, the drive reverses the direction of rotation until a zero pulse is detected.

An offset can be programmed in the dialog box.


Homing method (-8) and (-9)

Method -8

Approach block, clockwise.

With P 169 MPRO_REF_HOMING_MaxDistance the positioning range in which to search for the block is specified.

An offset can be programmed in the dialog box.

Method -9

Approach block, anti-clockwise.

With P 0169 P 169 MPRO_REF_HOMING_MaxDistance the positioning range in which to search for the block is specified.

An offset can be programmed in the dialog box.


Homing method (-7) to (0)

Homing method for increment-coded encoders:

Method (-6): Movement in negative direction

Method (-7): Movement in positive direction

Method (-5) Absolute encoder

This method is suitable for absolute encoders (e.g. SSI-Multiturn encoders). Homing is performed immediately after power-on. The reference position is calculated on the basis of the encoder absolute position plus zero offset. In the case of a SSI multiturn encoder, homing with zero point offset = 0 gives the absolute position of the SSI encoder. Another homing run with unchanged setting of the zero offset does not cause a change in position.

To set the machine reference point homing method (-12) should be used.

Methods (-4) and (-3) are not defined

Method (-2) No homing

No homing is performed. The current position is added to the zero offset. The first time the power stage is switched on the "Homing completed" status is set. This method is suitable for absolute encoders, as long as no zero balancing is required. For zero balancing please select method (-5).

Method (-1) Actual position = 0

The actual position corresponds to the zero point; it is set to 0, meaning the controller performs an actual position reset. The zero offset is added.

Method (0) not defined


Homing method 1 and 2: Limit switch and zero pulse

Method 1: Negative limit switch and zero pulse

  • Start movement anti-clockwise; at this time the hardware limit switch is inactive.
  • The direction of movement reverses on an active hardware limit switch edge.
  • First zero pulse after falling limit switch edge corresponds to zero/reference point.

Method 2: Positive limit switch and zero pulse

  • Start movement clockwise; at this time the hardware limit switch is inactive.
  • The direction of movement reverses on an active hardware limit switch edge.
  • First zero pulse after falling limit switch edge corresponds to zero/reference point.


Homing method 3 and 4: Positive reference cam and zero pulse

Method 3

Start movement in direction of positive (right) hardware limit switch

  • Start movement in direction of positive (right) hardware limit switch; at this time the reference cam is inactive.
  • The direction of movement reverses on an active reference cam edge.
  • First zero pulse after falling cam edge corresponds to zero/reference point.

Method 4

Start movement in direction of negative (left) hardware limit switch

  • Start movement in direction of negative (left) hardware limit switch; at this time the reference cam is inactive.
  • The direction of movement reverses on an active reference cam edge.
  • First zero pulse after falling cam edge corresponds to zero/reference point.


Homing method 5 and 6: Negative reference cam and zero pulse

Method 5: Start movement in direction of positive (right) hardware limit switch

  • Start movement in direction of positive (right) hardware limit switch; at this time the reference cam is active.
  • First zero pulse after falling cam edge corresponds to zero/reference point.
  • The direction of movement reverses on an active reference cam edge.
  • Start movement in direction of negative limit switch if reference cam is inactive.

Method 6: Start movement in direction of negative (left) hardware limit switch

  • Start movement in direction of negative (left) hardware limit switch.
  • The direction of movement reverses on an inactive reference cam edge.
  • First zero pulse after rising cam edge corresponds to zero/reference point.


Homing method 7 to 10: Reference cam, zero pulse and positive limit switch

Method 7

  • The start movement is in the direction of the positive (right) hardware limit switch. It and the reference cam are inactive.
  • The direction is reversed after an active reference cam. The zero corresponds to the first zero pulse after a falling edge.
  • The start movement is in the direction of the negative (left) hardware limit switch. The reference point is set at the first zero pulse after a falling reference cam edge.
  • The first zero pulse after overrunning the reference cam corresponds to the zero point.

Method 8:

  • The zero corresponds to the first zero pulse with an active reference cam.
  • At a falling reference cam edge the direction changes. The zero point corresponds to the first zero pulse after the rising edge of the reference cam.
  • The direction reverses if the reference cam has been overrun. The zero corresponds to the first zero pulse after the rising edge.

Method 9:

  • The direction changes when the reference cam becomes inactive. The zero corresponds to the first zero pulse after the rising edge.
  • The zero corresponds to the first zero pulse with an active reference cam.

Method 10:

  • The reference cam is overrun and the first zero pulse after the falling edge corresponds to the zero point.
  • After a falling reference cam edge: The first zero pulse corresponds to the zero point.
  • After an active reference cam: The zero corresponds to the first zero pulse after a falling edge.


Homing method 11-14: Reference cam, zero pulse and negative limit switch

Method 11

  • Reverse direction after active reference cam. The zero corresponds to the first zero pulse after a falling edge.
  • Zero at first zero pulse after falling edge of reference cam.
  • The reference cam must be overrun, then the first zero pulse corresponds to the zero.

Method 12

  • Zero corresponds to first zero pulse with active reference cam.
  • Reverse direction after falling reference cam edge. The zero point corresponds to the first zero pulse after the rising edge of the reference cam.
  • Reverse direction when reference cam has been overrun. The zero corresponds to the first zero pulse after the rising edge.

Method 13

  • Reverse direction when reference cam has been overrun. The zero corresponds to the first zero pulse after the rising edge.
  • Reverse direction when reference cam becomes inactive. The zero corresponds to the first zero pulse after the rising edge.
  • Zero corresponds to first zero pulse with active reference cam.

Method 14

  • Zero corresponds to first zero pulse after running over reference cam.
  • Zero corresponds to first zero pulse after falling edge of reference cam.
  • Reverse direction after active reference cam. The zero corresponds to the first zero pulse after a falling edge.


Homing method 15 and 16

The two homing methods are not defined.


Homing method 17-30: Reference cam

Method 17-30

The homing method types 17 to 30 are equivalent to types 1 to 14.
Definition of the reference point is independent of the zero pulse. It depends only on the cam or on the limit switches.

Comparison of homing methods

Method 1 corresponds to method 17

Definition of the reference point is independent of the zero pulse.
It depends only on the cam or on the limit switches.
Method 4 corresponds to method 20
Method 8 corresponds to method 24
Method 12 corresponds to method 28
Method 14 corresponds to method 30


Homing method 31 and 32

The two homing methods are not defined.


Homing method 33 and 34: With zero pulse

The zero pulse corresponds to the first zero pulse in the direction of movement.

Method 33 Movement anti-clockwise:

Method 34 Movement clockwise:


Homing method 35

The current actual position corresponds to the reference point.


Homing

Homing serves to establish an absolute position reference (referred to the entire axis), and must usually be performed once after power-up. Homing is necessary when absolute positioning operations are carried out without absolute value encoders (e.g. SSI multiturn encoders). For all other positioning operations (relative, infinite) no homing is required. For zero position adjustment of absolute encoders homing method -5 is available. There are various methods, which can be set according to the application.

The selection of a homing method defines:

  • the reference signal (positive limit switch, negative limit switch, reference cam)
  • the direction of the drive
  • the position of the zero pulse.

Homing dialog box

Matching driving profiles are stored for each selectable homing method. The homing movement is dictated by the speed (velocity) V1 and V2, the acceleration and the maximum positioning range.

Homing methods overview:

P. no. | Function
P2261 | Selection of homing methods
(-12) | Set machine reference point
(-10) - (-11) | Approach block, clockwise/anti-clockwise with zero pulse
(-8) - (-9) | Approach block, clockwise/anti-clockwise.
(-7) | Homing method for increment-coded encoder in positive direction
(-6) | Homing method for increment-coded encoder in negative direction
(-5) | Homing (absolute value encoder)
(-4) | Continuous homing, negative edge of reference cam
(-3) | Continuous homing, positive edge of reference cam
(-2) | No homing; only an offset adjustment is made
(-1) | Current position is set to 0
(0) | Not defined
(1) | Homing negative limit switch and zero pulse
(2) | Homing positive limit switch and zero pulse
(3) | Homing to cam negative edge, positive direction + zero pulse
(4) | Homing to cam positive edge, positive direction + zero pulse
(5) | Homing to cam negative edge, negative direction + zero pulse
(6) | Homing to cam positive edge, negative direction + zero pulse
(7) to (14) | Various homing runs to cam
(15) - (16) | Not defined
(17) | Homing negative limit switch
(18) | Homing positive limit switch
(19) | Homing to cam negative edge, positive direction
(20) | Homing to cam positive edge, positive direction
(21) | Homing to cam negative edge, negative direction
(22) | Homing to cam positive edge, negative direction
(23) to (30) | Various homing runs to cam
(31), (32) | Not defined
(33) | Zero pulse in negative direction
(34) | Zero pulse in positive direction
(35) | Zero is current position

Setting of speed V1 and V2:

The homing speed is preset via parameter P 2262 MPRO_402 HomingSpeed. In this, the user has the possibility to specify two different homing speeds.

P. no. | Parameter name Setting | Function
P2262 | MPRO_402_HomingSpeeds | Setting of speed V1 and V2
(0) | SpeedSwitch(0) | Speed during cam search V1
(1) | SpeedZero(1) | Speed during zero search V2

Acceleration during homing movement

The homing acceleration is preset via P 2263 MPRO_402_HomingAcc.

Zero point offset

The reference point usually has an actual position value defined on the axis side referred to the axis zero. Ideally, the datum point identified on the drive side has the same position as the reference point.
As the position of the datum point is decisively influenced by the encoder mounting, however, the datum and reference points differ. To establish a positional reference to the real axis zero, the desired axis-related actual position value of the reference point should be set via the zero offset P 0525 ENC_HomingOff.

Setting the positioning range in homing

By way of parameter P 0169 MPRO_Homing_MaxDistance the positioning range for the homing can be limited. On overrunning, the axis is stopped with an error message "Overrun".

Reference cam, limit switch

The reference cam signal can be optionally linked to one of the digital inputs. Fast inputs ISD05 to ISD06 are available.

Homing to a limit switch:
The digital input must be set to the available selection parameter LCW(5) for a positive or LCCW(6) negative limit switch.

Homing to a cam:
Set digital input to HOMSW(10) (parameters P 0106 MPRO_INPUT_FS_ISD06 to P 0107 MPRO_INPUT_FS_ISD07).


Jog mode

This function is intended for Setup mode to record (teach-in) positions, for disengaging in the event of a fault, or for maintenance procedures.
A bus system or reference sourcing via terminal can be selected as the reference. The unit corresponds to the selected user unit. Two speeds are available for both directions. For jogging in positive and negative direction two digital input parameters must be set to INCH_P(7) = Jog + and INCH_P(8) = Jog -. If the drive is to be moved at different speeds, both inputs must be active (relevant bits in bus operation). If the "Jog left" input is activated first and then input two, "Quick jog mode left" is started. If the "Jog right" input is activated first, "Quick jog mode right" is started.

Setting of jog speed via Jog mode project tree:

Setting the necessary digital inputs:

Jog via "Manual mode" window:

After opening the manual mode window, click in the tab on "Jog". The jog mode dialog box then opens up. The jog speeds in the manual mode window are oriented to the values of the "Jog speed settings" dialog box - see above. The drive is moved in the negative direction by clicking the "Jog -" button or in the positive direction by clicking the "Jog +" button.


Reference table setting

With the reference table up to 16 reference values can be defined. In the process, the drive moves to its targets in conformance to the respective driving sets. Depending on the selected control mode, each reference in the table assigned a speed, acceleration and deceleration value. The table reference values can be used in any control mode.

Scaling:

The references must be made available in user-defined distance units. This is done by way of the "Scaling" motion profile.

Speed:

In "Infinite positioning" mode the speed can be specified signed. It is limited by parameter P 0328 CON_SCON_SMax.

Ramps:

The acceleration values for starting and braking can be parameterized irrespective of each other. The input must not be zero.

Driving jobs:

The driving jobs from zero up to the value set in "Number of follow-up jobs to be processed" are continuously processed. When the driving set entered in P 0206 MPRO_TAB_MaxIdx is complete, the first data set restarts. For this, P 0205 MPRO_TAB_Modemust be set to "AUTO". Processing is only stopped by removing the start contact.

The positioning mode P 0203 MPRO_TAB_PMode = "REL at once" aborts a current position driving set and moves, as from the current position, to the new reference.

Parameters:

P. no. | Parameter name/Setting | Function
P 0193 | MPRO_TAB_TAcc | Acceleration ramp (torque)
P 0194 | MPRO_TAB_TDec | Braking ramp (torque)
P 0195 | MPRO_TAB_TRef | Reference (torque)
P 0196 | MPRO_TAB_SAcc | Acceleration ramp (speed)
P 0197 | MPRO_TAB_SDec | Braking ramp (speed)
P 0198 | MPRO_TAB_SRef | Reference (speed)
P 0199 | MPRO_TAB_PAcc | Acceleration ramp (position)
P 0200 | MPRO_TAB_PDec | Braking ramp (position)
P 0201 | MPRO_TAB_PSpd | Speed (position)
P 0202 | MPRO_TAB_PPos | Position reference
P 0203 | MPRO_TAB_PMode | Positioning mode
(0) | ABS(0) | Absolute positioning
(1) | REL(1) | Relative positioning after target position reached
(2) | REL at once(2) | The current driving job is interrupted and a new pending job is directly accepted and executed.
(3) | SPEED(3) | Infinite motion, SPD (infinite driving job): If a table value is set to SPD, an infinite driving job is transmitted. If a table value with the setting ABS or REL is additionally selected, the infinite job is quit and the newly selected table value is approached from the current position.
P 0204 | MPRO_TAB_Wait time | In case of follow-up jobs: Wait time until execution of the next driving job.
P 0205 | MPRO_TAB_Mode | Control source
(0) | PARA (0) | Selection of a table value via P 0207 MPRO_TAB_ActIdx
(1) | TERM(1) | Selection of a table value via the digital inputs
(2) | AUTO (2) | Automatic processing of follow-up driving jobs. The number of driving jobs entered in parameter P 0206 MPRO_Tab_MaxIdx is processed in sequence. This operation is repeated until the drive is stopped or the table is disabled.
(3) | BUS(3) | Selection of a table value via PROFIBIUS. No other field bus systems are implemented.
P 0206 | MPRO_Tab_MaxIdx | The number of driving jobs set here is processed in sequence. This operation is repeated until the drive is stopped or the table is disabled.
P 0207 | MPRO_TAB_ActIdx | Display of the currently selected driving job. If parameter P 0205 MPRO_TAB_Mode is set to Para(0), a driving set can be entered and approached directly.

Method for enabling table values:

Settings for reference input via table values:

Activation | Setting | Description
Actuation via digital inputs | Input ISDxx = TBEN | Enable a selected driving set. The selection of a new driving job always interrupts an ongoing positioning and the follow-up job logic.
Actuation via digital inputs | Input ISDxx = TAB0 to TAB3 | The binary significance (20, 21, 22 , 23) results from the TABx assignment. The setting TAB0 has the lowest significance (20) and TAB3 the highest (23). A high level on the digital input activates the corresponding driving set.
Triggering via field bus system | Enable "Execute driving job" bit. | Enable a selected driving set. The selection of a new driving job always interrupts an ongoing positioning and the follow-up job logic.
Triggering via field bus system | "Activate follow-up job" bit | The binary significance (20, 21, 22 , 23) results from the TABx assignment of the control word. The setting TAB0 has the lowest significance (20) and TAB3 the highest (23).


Analog channel

The analog channel setting is described in the "Analog inputs" subject area.

see: / Analog channel settings /


Touchprobe

Recording of defined positions dependent on specific input signals.

The two fast digital inputs ISD05/06 can record a position value in ongoing operation and pass it on for further processing. The processing is carried out either via the iPLC or a bus system. For details refer to the CANopen/EtherCAT user manual.


NAVIGATION: Device Help / Motion profile / Synchronized movement / Cam plate / Parameter setting - Cam plate

Parameter setting - Cam plate

Not available at time of going to press.


Master configuration

Channel selection:

Definition of master encoder:

The master encoder may be a "virtual master", a higher-level PLC, or an encoder system. The channels for an encoder system must be selected accordingly from the list box. Channel 3 can only be used via the external interface X8 (option module).

If a higher-level PLC is used as the master encoder P 1319 MPRO_ECAM_CamMaster_Axis_Type = PARA(2), the resolution must be set referred to one motor revolution P 0250 MPRO_ECAM_PARAMaster_Amplitude.

P. no. | Parameter name Setting | Function
P1319 | MPRO_ECAM_CamMaster_AxisType | Selection of master encoder
(0) | No Axis | No master encoder selected
(1) | Virtual Master | Virtual master
(2) | PARA | Parameter interface
(3) | ENC CH1 | Encoder on channel 1
(4) | ENC CH2 | Encoder on channel 2
(5) | ENC CH3 | Encoder on channel 3

Anti-reverse mode

see: / Anti-reverse mode /

Filter type for guide value:

When using a real master encoder, encoder signals may be subject to noise. The signals can be filtered with a PT1 or a average value filter.

P. no. | Parameter name Setting | Function
P1340 | MPRO_ECAM_CamMaster_SpeedFilTyp | Selection of filter type
(0) | OFF | Not active
(1) | PT1 | PT1 Filter
(2) | AVG | Average value filter

Speed factor:

The master encoder can be assigned an additional speed factor.

Parameter Master:

When using the "Parameter Master", the number of increments per motor revolution P 0250 MPRO_ECAM_ParaMaster_Amplitude must be set.

see: / Synchronization mode /

see: / Parameter setting - "Electronic gearing" /

see: / Engagement and disengagement /

see: / Anti-reverse mode /

see: / Virtual master /


Parameter setting - "Electronic gearing"

The "electronic gearing" function enables synchronism between multiple axes.
Digital control signals are used to provide positionally precise disengagement from the guide value (e.g. with standstill at cycle end) and positionally precise engagement to the current guide value.
An encoder sysem, the virtual master or the parameter interface is selected as the master encoder in the master configuration. With the parameter interface setting it is possible to apply the handling (control word P 1318 MPRO_ECAM_ControlWord, status wort, P 1326 MPRO_ECAM_StatusWord) by way of a field bus system.

The settings for the "electronic gearing" function are made in the following dialog box.

Synchronization mode:

see: / Synchronization mode /

Gear ratio (gearing factor):

The ratio is given as a fraction. This ensures that the position on the drive shaft can be translated onto the motor shaft without rounding errors at any time.

Speed factor: Scaling of speed pre-control

Torque factor: Scaling of torque pre-control

see: / Engagement and disengagement /

see: / Master configuration /

see: / Anti-reverse mode /

see: / Virtual master /


Engagement and disengagement

Engage mode:

P. no. Parameter name Setting Figure Function

P 0253

MPRO_ECAM

_Egear_GearIn_MOD

Master = black curve

Slave = blue curve

 Engage mode

(0)

Direct

Direct engagement:

  • Angle-synchronous
  • Collisional (no ramps engaged)

(1)

ramp

Engage with linear acceleration profile:

  • Not angle-synchronous
  • Jerked

(2)

fade

Engage with fade-in function (5th order polynomial)

  • Not angle-synchronous
  • Jerk limited
  • The position is ignored. A variation between the reference and actual positions always remains.

(3)

Cross-fade

Engage with cross-fade function (5th order polynomial)

  • Angle-synchronous
  • Jerk limited
  • Speed overshoots during engagement.
P 0255

MPRO_ECAM

_Egear_GearIn_Acc

Acceleration mode
P 0257

MPRO_ECAM

_Egear_GearIn_Dist

Engagement distance

  • The actual engagement takes place within the engagement distance (dotted line).

Disengage mode:

P. no. Parameter name Setting Function

P 0254

MPRO_ECAM

_Egear_Gearin_MOD

Master = black curve

Slave = blue curve

 Disengage mode

(0)

Direct

Direct disengagement:

  • Collisional (no ramps engaged)

(1)

Ramp

Disengage with linear acceleration profile:

  • Jerked

(2)

Fade

Disengage with fade-out function (5th order polynomial)

  • Jerk limited
P 0256

MPRO_ECAM

_Egear_GeaOut_Dec

 Deceleration ramp
P 0258

MPRO_ECAM

_Egear_GearOut_Dist

Disengagement distance

  • The actual engagement takes place within the engagement distance (dotted line).
The actual engagement takes place within the engagement distance (dotted line). This area can be set separately for acceleration and braking.

see: / Parameter setting - "Electronic gearing" / see: / Anti-reverse mode /

see: / Master configuration /

see: / Anti-reverse mode /

see: / Virtual master /

see: / Synchronization mode /


Anti-reverse mode

Anti-reverse mode:

In some applications an anti-reverse device, with or without path compensation, is required.

In the sketches the master encoder is represented as a black curve and the master (processed master encoder) as a blue curve.

P. no. Parameter name Setting The curve depicts the position of the master and slave. Function
P1312 MPRO_ECAM_CamMaster_RevLock_Mode

Master = black curve

Slave = blue curve

 Selection of anti-reverse mode
(0) INACTIVE

Anti-reverse mode inactive:

The slave follows the master directly and in every direction.
(1) ACTIVE with PATH COMP

Anti-reverse mode with path compensation:

  • Master rotates in the blocked direction
  • Slave stays still
  • Master rotates in the unblocked direction again.
  • Slave only starts moving along with it again as soon as the master reaches the zero position.

    Example:
    If the master, which has moved two motor revolutions in the direction blocked for the slave, then moves in the unblocked direction again, the slave only moves off when the master has traversed the zero point.
(2) ACTIVE without PATH COMP

Anti-reverse mode without path compensation:

  • Master rotates in the blocked direction
  • Slave stays still
  • Master rotates in the unblocked direction again.
  • The slave follows the master directly in the unblocked direction.

    Example:
    If the master, which has moved two motor revolutions in the direction blocked for the slave, then moves in the unblocked direction again, the slave moves off immediately in the unblocked direction.

see: / Master configuration /

see: / Engagement and disengagement /

see: / Parameter setting - "Electronic gearing" /

see: / Synchronization mode /

see: / Virtual master /


Synchronization mode

Function selection:

  • Cam plate via iPLC or bus system
  • Electronic gearing via iPLC or bus system

Selection variants:

P. no. | Parameter name Setting | Function
P 0242 | MPRO_ECAM_SyncMod | Selection of electronic gearing or cam plate
(0) | OFF | No mode selected
(1) | ECAM_iPLC | Cam plate via iPLC
(2) | EGEAR_iPLC | Electronic gearing via iPLC
(3) | ECAM_PARA | Cam plate via parameter
(4) | EGEAR_PARA | Electronic gearing via parameter

see: / Engagement and disengagement /

see: / Master configuration /

see: / Parameter setting - "Electronic gearing" /

see: / Anti-reverse mode /

see: / Virtual master /


Setting the motion profile

The drive settings are made in the Motion profile subject area. In addition to the control location and reference source, the standardization, homing method, jog mode and motion profile for the application can be configured.

see: / Weighting via the SERCOS profile /

see: / Basic settings /

see: / Stop ramps / see: / Homing /

see: / Jog mode /

see: / Synchronization mode /


Virtual master

If the "virtual master" is selected for the master encoder, the dialog box below opens up under Options. Click "Start" to start the engagement. Stop/halt accordingly with "Stop" and "Halt".

The virtual master must be activated by clicking the "Start" button, and remains active for operation of a synchronized movement.

see: / Parameter setting - "Electronic gearing" /

see: / Synchronization mode /

see: / Engagement and disengagement /

see: / Master configuration /

see: / Anti-reverse mode /


State machine

For more details on the "state machine" refer to the

CANopen/EtherCAT user manual.


Configuration of the inputs and outputs

The buttons provide a user-friendly means of navigating to the individual inputs and outputs. They can also be selected by way of the project tree. Choose "Oscilloscope signals from" to open a window with oscilloscope variable to record the status of the individual inputs and outputs. A highlighted variable can be assigned to a channel and recorded by right-clicking the mouse button. The function of the electronic oscilloscope is described in the DriveManager 5 Help.

Dialog box with the selection fields of the individual input and output buttons:

Double-click on the "Scope signls of" button to open the pop-up below. Select a parameter and right-click to open the scope channel assignment. The scope variable is selected directly in the scope as a result.

see: / Digital outputs /

see: / Digital inputs /


Digital inputs

All digital inputs of the controller are set by way of a function selector. The selector assigns each input a function.
The two inputs ISDSH and ENPO "Enable Power" are reserved for the hardware enable. For the touch probe function the two "fast inputs" ISD05 and ISD06 are available.

Digital input settings:

  • Function selection via list boxes (0)-(29)
  • "Low active": Activation switched from High to Low edge
  • "Digital filters": Switch-on delay [ms]
  • "Options": Depending on the selected function, the Options button gives access to additional parameter settings dialog boxes.

see: / Hardware enable /

P. no. | Parameter name Setting | Function
P 0101- P 0107 | MPRO_INPUT_FS_ISD00 | Digital inputs
(0) | OFF | Input off
(1) | START | Start of closed-loop control Motor is energized. The direction of rotation depends on the reference
(2) | INV | Invert reference
(3) | STOP | Quick-stop as per quick-stop reaction (Low active)
(4) | STOP | The ongoing axis movement is interrupted and resumed as per the "HALT" reaction following resetting.
(5) | LCW | Limit switch evaluation without overrun protection, positive direction. The reaction to limit switch overrun and to interchanged limit switches can be preset.
(6) | LCCW | Limit switch evaluation without overrun protection, negative direction. The reaction to limit switch overrun and to interchanged limit switches can be preset.
(7) | INCH_P | Jog positive
(8) | INCH_N | Jog negative
(9) | HOMST | Start homing: according to the homing method parameterized in P 02261 MPRO_402_Homing Method
(10) | HOMSW | Reference cam to determine the zero for positioning
(11) | E-Ext | Error messages from external devices cause an error message with the reaction determined in parameter P 0030 Error-Reaction Sub Index 11
(12) | WARN | External collective warning
(13) | RSERR | Error messages are reset with a rising edge if the error is no longer present In some special case it is necessary to restart the device in order to reset an error. Settings in "Error reactions" must be observed.
(14) | MAN | In field bus operation switching of the reference source P 0165 CON_CfgCon and the control location P 0159 MPRO_CTRL to "Term" can be set via a digital switch.
(15) | PROBE | Touchprobe: The function can only be executed via the fast inputs ISD05 and ISD06 in conjunction with PLC or CANopen/EtherCAT.
(16) | PLC | Input can be evaluated by PLC program
(17) | PLC_IR | Interruption of the PLC program
(18) | MP_UP | Motor potentiometer: Increase reference value
(19) | MP_DOWN | Motor potentiometer: Decrease reference value
(20) | HALT_PC | Feed stop with subsequent position control
(21) | TBEN | Import and execution of selected table driving set
(22) | TBTEA | Teach-in for position references
(23) | TAB0 | Binary driving set selection (bit 0) , (significance 20) for speed
(24) | TAB1 | Binary driving set selection (bit 1), (significance 21) for speed or positioning
(25) | TAB2 | Binary driving set selection (bit 2), (significance 22) for speed or positioning
(26) | TAB3 | Binary driving set selection (bit 3), (significance 23) for speed or positioning
(27) | EGEAR | Engage electronic gearing
(28) | REFANAEN | Enable analog reference
(29)-(33) | Not defined | Not defined

see: / Error display /

see: / Hardware enable /

see: / Power-up sequence /

see: / Control location selector switching /


Power-up sequence

The power-up sequence must be maintained when the drive starts, regardless of the control mode. If the power-up sequence is followed, the drive starts with a rising edge of the digital input parameterized to "START" or when the corresponding "Start" bit is set via a bus system. The reference polarity determines the direction of rotation.

Power-up sequence | Command | System state
 | Safe Standstill (STO): ISDSH EnablePower: ENPO Bit (0) = START(1) Loop control active | Start inhibit Ready to switch on On Loop control active

see: / Digital inputs /

see: / Hardware enable /


Hardware enable

The controllers support the "STO" (Safe Torque Off) safety function in accordance with the requirements of EN 61800-5-2, EN ISO 13849-1 "PL

e" and EN 61508 / EN 62061 "SIL 3". The safety function "STO" to EN 61800-5-2 describes a safety measure in the form of an interlock or control function. "Category 3" signifies that the safety function will remain in place in the event of a single fault.

The safety-related parts must operate in such a way that:

  • a single fault in any of the said parts does not result in loss of the safety function;
  • the single fault is detected on or before the next request to the safety function.

For the "STO" function the servocontrollers are equipped with additional logic circuits and a feedback contact (terminal RSH on X4). The logic cuts the power supply to the pulse amplifiers to activate the power stage. In combination with the controller enable "ENPO" the system uses two channels to prevent the motor creating a torque.

Testing the STO function

Function testing: The STO function (protection against unexpected starting) must essentially be checked to ensure it is operative:

  • during initial commissioning;
  • after any modification of the system wiring;
  • after replacing one or more items of system equipment.
  • Cancelling one of the two signals "ISDSH" or "ENPO" disables the control and the motor runs down unregulated.

The connected control signals "ISDSH" and "ENPO" must always be tested by the operator or a higher-level PLC for plausibility relative to the feedback (RSH). The occurrence of an implausible status is a sign of a system error (installation or servocontroller). In this case the drive must be switched off and the error rectified.

The plausibility between input signals (ENPO, ISDSH) and feedback (RSH) must always be monitored.

Hardware enable or autostart

The input "ENPO" is reserved for the hardware enable.

At the setting "OFF" the digital input signal "ENPO" is used merely for safe shutdown of the drive and as protection against switching on.
With the setting "START" in combination with parameter P 0144 DRVCOM AUTO_START= "LEVEL" autostart mode is activated.

With "STO active", it is sufficient to enable the "ENPO" in order to start the drive control.
When the "ENPO" is cancelled the drive runs down unregulated.

If the switch-on delay is active, the power stage starts when the preset timer has elapsed.

see: / Digital inputs /

see: / Power-up sequence /


Control location selector switching

Setting a digital input ISDxx = "MAN(14)" allows a change of control location to the reference source selected in P 0164 MPRO_REF_SEL_MAN. This enables fast switching to manual control for setup or emergency running mode for example.
When a digital input set to "MAN(14)" is activated, the control location P 0159 MPRO_REF_SEL switches to "TERM" (switch to TERM is not displayed in DM5). In parallel, the reference source is set to the reference selected via parameter P 0164-MPRO_REF_SEL_MAN. Additionally, the start signal must be connected to a digital input (ISDxx = Start). The control mode P 0300_CON_CfgCon cannot be switched. The "MAN(14)" mode is displayed in the field bus control word.

It is not possible to switch to "MAN" mode when the power stage is active or when the drive in the DriveManager 5 is operated via the manual mode window. A level-triggered START P 0144 MPRO_DRVCOM_AUTO_START=LEVEL (1) is ignored in "MAN" mode. After activation of "MAN" mode, the START input must be reset.
When "MAN" mode is ended the motor control also stops.

P.no. | Parameter name/ Settings | Function
P 0164 | MPRO_REF_Sel_MAN | Selection of motion profile
(0) | OFF | No profile selected
(1) | ANA0 | Reference value of analog input ISA0
(2) | ANA1 | Reference value of analog input ISA1
(3) | TAB | Reference from table
(4) | vacant | Not defined
(5) | PLC | Reference from PLC
(6) | PARA | Reference via parameter
(7) | DS402 | Reference via CiA 402 IEC1131
(8) | SERCOS | Reference via SERCOS
(9) | PROFI | Reference via Profibus
(10) | VARAN | Reference via VARAN
(11) | TWIN | Reference via external option "TWINsync"

see: / Digital inputs /


Digital outputs

The digital standard outputs OSD00 to OSD02 can also be assigned corresponding functions via function selectors P 0122 MPRO_OUTPUT_FS_OSD00 to P 0124 MPRO_OUTPUT_FS_OSD02. The relay output P 0125 MPRO RELOUT1 is intended for the motor brake. It can also be assigned other functions via the function selectors as necessary.

The digital output RELOUT2 is permanently set to the functionality "SH_HSTO". Additional information on the STO function can be found in the "Safety" section of the Operation Manual.

P. no. | Parameter name Setting | Description
P 0122 - P 0127 | MPRO_OUTPUT_FS_OSD0x | Function selection
(0) | OFF | Input off
(1) | ERR | Collective error message
(2) | BRAKE | Output activated according to holding brake function
(3) | ACTIVE | Power stage and control active
(4) | S_RDY | Output is activated when the device is initialized after power-on.
(5) | C_RDY | Output is activated when the device is "Ready to switch on" based on setting of the "ENPO" signal and no error message has occurred. Device ready - ReadyToSwitchOn flag in DriveCom status word set (in states 3, 4, 5, 6, 7)
(6) | REF | The preset reference has been reached (dependent on control mode) see: / REF(6) Target, reference reached /
(7) | HOMATD | Homing complete
(8) | E_FLW | Tracking error
(9) | ROT_R | Motor in standstill window when running clockwise
(10) | ROT_L | Motor in standstill window when running anti-clockwise
(11) | ROT_0 | Motor in standstill window, depending on actual value
(12) | STOP | The drive is in the "﻿Quickstop" state
(13) | STOP | The display system is in HALT state (activated via DS 402 profile, input or PROFIBUS IntermediateStop, SERCOS. Reaction according to HALT option code (P2221 MPRO_402_HaltOC).
(14) | LIMIT | Output is set when a reference value reaches its limit. see: / LIMIT(14) Reference limitation /
(15) | T_GT_Nx | T is greater than Nx where Nx = value in P 0741 MON_Torque/forceThresh
(16) | N_GT_Nx | N is greater than the value in P 0740 MON_SpeedThresh
(17) | P_LIM_ACTIV | Position reference limited (e.g. with parameterized software limit switches)
(18) | N_LIM_ACTIV | Speed reference limitation active
(19) | T_LIM_ACTIV | Torque limitation active
(20) | not defined | Not defined
(21) | ENMO | Motor contactor output (wiring of motor via contactor) see: / ENMO(21) Switching via motor contactor /
(22) | PLC | PLC sets output
(23) | WARN | Collective warning message
(24) | WUV | Warning: undervoltage in DC link
(25) | WOV | Warning: voltage overload in DC link
(26) | WIIT | Warning: I2xt power stage protection reached
(27) | WOTM | Warning: motor temperature
(28) | WOTI | Warning: heat sink temperature of inverter
(29) | WOTD | Warning: internal temperature in inverter
(30) | WLIS | Warning: current threshold reached
(31) | WLS | Warning: speed threshold reached
(32) | WIT | Warning: I2xt motor protection threshold
(33) | WLTQ | Warning: torque limit value reached
(34) | TBACT | Table positioning in "AUTO" and activated state
(35) | TAB0 | Significance 20
(36) | TAB1 | Significance 21
(37) | TAB2 | Significance 22
(38) | TAB3 | Significance 23
(39) | COM_1MS | Set output via field bus in 1 ms cycle
(40) | COM_NC | Set output via field bus in NC cycle
(41)-(54) | not defined | Not used
(55) | SH_S Safe torque off (STO) | STO function active
(56) | BC:Fail | Brake chopper error; triggered with negative edge
(57) | ESYNC | Synchronized movement engaged
Warnings/warning thresholds are set via P 0730 MON_WarningLevel.


ENMO(21) Switching via motor contactor

The motor cable may only be switched with the power cut, otherwise problems such as burnt-out contactor contacts, overvoltage or overcurrent shut-off may occur. In order to assure currentless switching, the contacts of the motor contactor must be closed before the power stage is enabled. In the opposite case the contacts must remain closed until the power stage has been switched off. This can be achieved by implementing the corresponding safety periods for switching of the motor contactor into the control sequence of the machine or by using the special "ENMO" software function of the drive controller.

A power contactor in the motor supply line can be directly controlled by the drive controller via parameter P 0125 MPRO_OUTPUT_FS_MOTO = ENMO. The timer P 0148 MPRO_DRVCOM_ENMO_Ti takes into account the on-and-off delay of the power contactor. This ensures that the reference will only be applied after the start enable when the contactor is closed, or if the motor is isolated from the controller via contactor when the power stage is inactive.

The P 0148 MPRO_DRVCOM_ENMO_Ti timer time should allow additional times for typical contactor bounce. They may be several hundred ms, depending on contactor.


LIMIT(14) Reference limitation

The output function LIMIT(14) detects when a reference value reaches its limit. In this case the output is set. The limit values for maximum torque and maximum speed depend on the preset control system.

Torque control:
Limit value monitoring becomes active when the torque reference exceeds the maximum torque.

Speed control:
Limit value monitoring becomes active when the speed reference exceeds the maximum speed.

Positioning:
Limit value monitoring becomes active when the speed reference exceeds the maximum speed or the torque reference exceeds the maximum torque.

Infinite positioning/speed mode:

Monitoring is activated in infinite positioning (﻿speed mode) when the speed reference has been reached.

If an ongoing positioning operation is interrupted with "HALT", the "Reference reached" message is not sent in this phase. The message only appears after the actual target position has been reached.


REF(6) Target, reference reached

If a digital output is set to REF(6) for torque and speed control as well as positioning, a range can be defined in which the actual value may deviate from the reference without the "Reference reached REF(6)" message becoming inactive.
Reference value fluctuations caused by reference input are thus taken into account.

see: / Digital outputs /


Analog outputs

Analog outputs (AOs) can only be used via the option module CANopen+2AO and are used to feed analog signal values out of the controller for further processing. To set OEA00 and OEA01 the actual value source must be defined. The values can be filtered, scaled and assigned an offset. For more information refer to the CANopen+2AO specification with the ID-Nr. 1108.00B.0-00.

Configuration of function selector

Sampling time 125 s (default)

P. no. | Parameter name Setting | Function
P 0129/ P 0130 | MPRO_Output_FS_OSA0/1 | Function selection
(0) | OFF (0) | No function
(1) | NACT(1) | Actual speed value
(2) | TACT(2) | Actual torque value
(3) | IRMS(3) | Actual current value
(4) | PARA (4) | Value in parameter P 0134 MPRO_OUTPUT_OSAx_Values is outputted directly on the analog output.
(5) | ACTPOS | Actual position
(6) | VDC | DC-link voltage
P 0131 | MPRO_Output_OSAx_Offset | Offset
(0) | Offset | Voltage offset [V]: Offset setting: Changing P 0131 MPRO_OUTPUT_OSA0x_Offset shifts the operating point of the analog outputs out of the 0 point.
(1) | Offset
P 0132 | MPRO_Output_OSA0_Scale | Scale
(0) | Scale | Scaling of the analog output: setting of the Scale function: The scaling function can be used to scale the analog output.
(1) | Scale
P 0133 | MPRO_Output_OSA0_Filter | Filter
(0) | Filter | Filter time of analog output: Filter function setting: Noise and component spread can be compensated.
(1) | Filter


Function selector

The reference processing is selected by way of the function selector. The default setting is the function RERV(-2), with which the reference input +/-10 V is evaluated referred to user units. In addition to torque scaling and override, all digital functions can be used.

P. no. | Parameter name Setting | Function
P 0109/ P 0110 | MPRO_INPUT_FS_ISA00/ISA01 |
(-5) | Not defined | Not defined
(-4) | TLIM(-4) | Torque scaling: 0 to 10 V corresponds to 0-100 % of the maximum set torque. The torque scaling is recorded directly after the analog filter and before the backlash. The analog input describes P 0332 SCON TMaxScale torque limitation. The backlash is therefore not effective for these functions.
(-3) | OVR(-3) | Scaling of the parameterized travel speed in positioning, 0 to 10 V corresponds to 0 - 100 %. The override is tapped directly after the analog filter and before the backlash. At this point the system branches off to parameter P 0167 Profile Speed override factor. The backlash is therefore not effective for these functions!
(-2) | REFV(-2) | Reference input +/-10 V referred to user units.
(-1) | Not defined(-1) | Not defined
(0) | OFF (0) | No function
(1) - (33) | digital Function | Digital functions (see ISDxx). The switching thresholds for safe High level and Low level are: high: > 2.4 V, Low: < 0.4 V

see: / Reference processing via analog inputs /


IP and PG mode

Parameter P 0301 CON_REF_Mode is used to determine whether the reference values are processed via the profile generator (setting PG(0)) or directly (setting IP(1)).

If direct input via IP mode is selected, only the input filters are active. The analog values are in this case scanned and filtered in the torque control cycle and then directly transferred as references for the speed or torque control.

The analog inputs are scanned in a 1 ms cycle. By switching parameter P 0301 CON_REF_Mode from PG(0) to IP(1) Mode, an analog input can be used as a "fast input" (e.g. Touchprobe). The sampling time set in parameter P 0306 CON_IpRefTS for the interpolation takes effect.

see: / Reference processing via analog inputs /

see: / Speed control in IP mode /

see: / Speed control in PG mode /

see: / Position control in IP mode /

see: / Position control in PG mode /

see: / Jerk limitation and speed offset /


Profile generator

see: / Speed control in IP mode /

see: / Speed control in PG mode /

see: / Position control in IP mode /

see: / Position control in PG mode /

see: / Jerk limitation and speed offset /

see: / Reference processing via analog inputs /

see: / Stop ramps /

see: / Reference table setting /

see: / Jog mode /


Scaling

With the scaling of the analog input the analog value can be converted with a factor, offset and backlash to the process variable.

  • Change to input voltage range of analog torque scaling
  • Change to input voltage range of speed override function
  • Change to switching threshold of a digital input function

The illustration shows how the scaling function works. Entering the desired voltage range produces the parameter value for the offset P 0428 ANA0/1 Offset and gain
P 0429 ANA0/1 Gain.

Example: Analog torque weighting:

Default setting (standard controller function):

Input voltage range of torque scaling from

0 V to +10 V corresponds to 0% - 100%.

-10 V to 0 V corresponds to 0%.

Setting of input and offset gain:

Input voltage range (+10 V/-10 V)

-10 V corresponds to 0%

+10 V corresponds to 100% of the torque scaling

Settings:

-10 V input voltage: Torque scaling = 0 %

Inmin = -10 corresponds to 0 V output voltage: Outmin = 0 V

+10 V input voltage: Torque scaling = 100 %
Inmax = +10 V corresponds to +10 V output voltage, OUTmax = 10 V

Result:

Gain: G = 0.5

Offset: O = 5 V

see: / Reference processing via analog inputs /


Analog channel settings

  • Assignment: +/- 10 corresponds to the maximum reference value (e.g. 3000 rpm).
  • Component spread can be compensated by way of the offset function.
  • The backlash setting can be used to suppress movement of the axis in the standstill range.
  • The setting for specifying torque references is made via the analog channel, as in speed control.
  • The braking and acceleration ramp corresponds to the ramp for torque rise and fall, and to the acceleration and braking ramp for the speed.

see: / Reference processing via analog inputs /

Parameter

P. no. | Parameter name Setting | Function
P 0173/ P 0183 | Scaling factor | Scaling/Weighting
(0) | MPRO_ANAX_TScale | Scaling of torque reference
(1) | MPRO_ANAX_SScale | Scaling of speed reference
(2) | MPRO_ANAX_PScale | Scaling of position reference
P 0174/ P 0184 | Offset |
(0) | MPRO_ANAX_TOffset | Torque reference offset
(1) | MPRO_ANAX_SOffset | Speed reference offset
(2) | MPRO_ANAX_POffset | Position reference offset
P 0175/ P 0185 | Backlash |
(0) | MPRO_ANAX_TThreshold | Torque reference backlash
(1) | MPRO_ANAX_SThreshold | Speed reference backlash
(2) | MPRO_ANAX_PThreshold | Position reference backlash
P 0176/ P 0186 | Acceleration/braking ramp for torque |
(0) | MPRO_ANAX_TRamp | Torque acceleration ramp
(1) | MPRO_ANAX_TRamp | Torque braking ramp
P 0177/ P 0187 | Acceleration/braking ramp for speed |
(0) | MPRO_ANAX_SRamp | Speed acceleration ramp
(1) | MPRO_ANAX_SRamp | Speed braking ramp
P 0405/ P 0406 | CON_ANA_filtx | Filter time (0-100 ms)


Reference processing via analog inputs

Two analog inputs are available (ISA00, ISA01). They can be used for analog reference input (negative index) or as digital inputs (positive index). The structure of the reference processing is shown in the schematic below.

Reference processing functions:

  • Weighting
  • Fault isolation filter
  • Profile mode (PG/IP mode)
  • Function selector
  • Scaling of the analog input
  • Profile generator to set ramps

Method for configuring inputs:

  1. Select ISA00 or ISA01
  2. Set filter time [ms]

  3. Scaling:
    see: / Analog channel settings /
    see: / Scaling / see: / Analog channel settings /
  4. Reference processing via PG/IP mode (see also Profile generator)
  5. Function selector P 0109/P 0110: MPRO_INPUT_FS_ISA00/ISA01= REFV (-2)
    see: / Function selector /

  6. Analog channel setting:
    - Select input function
    - Scaling V/[unit]
    - Voltage offset [V]
    - Filter time
  7. Set acceleration/braking ramps, stop ramps
    see: / Analog channel settings /
    see: / Stop ramps / see: / Reference table setting /

Schematic of reference processing:

see: / Scaling /

see: / Scaling /

see: / IP and PG mode /

see: / Function selector /

see: / Analog channel settings / see: / Scaling /


Motor brake output

An optional holding brake built-in to the motor provides protection against unwanted motion when the power is cut and in case of error. If the brake is mounted on the axis mechanism and not directly on the shaft, note that undesirably severe torsional forces may occur on sudden engagement of the brake.

Output P 0125 MPRO_OUTPUT_FS_Motor_Brake should be preferentially used in conjunction with a motor brake. On this output the current is explicitly monitored and wire break monitoring can be enabled. The brake function can also be used in the other digital outputs, though without current and wire break monitoring.
If the output is set to BRAKE(2), the brake can be configured by way of the option field. The brake response can be adapted to the requirements of the application as shown in the following illustration and using the parameters listed. This function can be used in both speed as well as position controlled operation.

Please check the settings of the stop ramps if use of a holding brake is specified.
see: / Stop ramps /

Brake output:

Parameter

P. no. | Parameter name Setting | Function
P 0125 | MPRO_OUTPUT_FS_MOTOR_BREAK | Output for use of a motor brake. If no brake is used, the output can be used for a wide variety of other functions.
(2) | BRAKE | Setting for use of a brake
P 0147 | MPRO_DRVCOM_EPCHK | Switch-on condition (hardware switch)
(0) No Check Hardware enable "ENPO" is switched via the
"ENMO" function.
(1) | Check | ENPO must be switched via a digital input.
P 0148

MPRO_DRVCOM_ENMO

[0-65535 ms]

 The timer "ENMO" (Enable motor contactor) generates an On/Off-delay of the motor contactor and thus of the power stage. The effect is active when setting and resetting the "START" command and in case of error. The parameter is in the "Motion profile" subject area.
P 0213

MPRO_BRK_LiftTime

[0-10000 ms]

 "Brake release time" is the mechanically dictated opening time of the brake. An applied reference will only be activated when this timer has elapsed.
P 0214

MPRO_CloseTime

[0-10000 ms]

After cancellation of the "START" command the "Brake close time" starts. When it ends the "Brake closed" signal is sent. In the event of an error, the brake engages immediately without any closure time.
P 0215

MPRO_RiseTime

[0-10000 ms]

 The "Torque rise time" is the rise of the ramp to build up the reference braking torque "Mref".
P 0216

MPRO_BRK_FadeTime

[0-10000 ms]

 The "torque fade time" is the descending ramp to reduce the
reference torque "Mref" to 0.
P 0217

MPRO_BRK_LastTorqFact

[0-100 %]

If the load changes, it is advisable to apply factor 1-100 % to the last actual torque stored (0 % = function off).
P 0218 MPRO_BRK_StartTorq

If the moving load always remains constant, "Mref" is set by way of parameter P 0218 MPRO_BRK_StartTorq "Starttorque".

Mref =lasttorque * lasttorque-factor+ starttorque

When setting the Lasttorque factor = 0 according to the formula, only the Starttorque setting is used. If Starttorque is set to 0, the Lasttorque is used. On the very first operation there is no Lasttorque though. In this case StartTorque is set to 0 and the LastTorque factor unequal to 0 and then the control is started.
P 0219 | MPRO_BRK_LastTorq | Display parameter of the last recorded torque. It is reduced further as necessary with a percentage value by the Scale factor P 0217 MPRO_BRK_LastTorq.
P 0220 | MPRO_BRK Lock | Only for testing. Manual setting of this parameter causes the brake to engage.


Limit value settings

To protect the device, the motor and the complete plant it is necessary to limit variables such as current, torque and speed. They act independently of other limitations within the motion profile.
The limits are specified as percentages of the rated quantities (current, torque, speed,...), so that following calculation logical default settings are available. The default settings refer to 100% of the rated values and the parameters must thus be adapted to the application and motor.

Limitations in loop-controlled mode:

  • Torque/force limitation:
  • Rotation speed/velocity limitation
  • Position limitation

Torque limitation:

To protect against overspeed, when the maximum rotation speed P 0329 CON_SCON_TMax is reached a speed governor is activated which limits the speed to the configured maximum. The parameter is not changeable online.
It is possible to limit the negative P 0330 CON_SCON_TMaxNeg and the positive torque P 0331 CON_SCON_TMaxPos independently of each other online.

P. no. | Parameter name/Setting | Function |
P 0329 | CON_SCON_TMax | Scaling of the maximum torque, referred to the rated torque P 0460 MOT_TNom (not changeable online). |
P 0330 | CON_SCON_TMaxNeg | Torque limitation in negative direction (changeable online) | Changeable online
P 0331 | CON_SCON_TMaxPos | Torque limitation in positive direction (changeable online) | Changeable online
P 0332 | CON_SCON_TMaxScale | Percentage torque weighting, default 100% (changeable online) |
P 0460 | MOT_TNom | Motor rated torque |
P 0741 | MON_TorqueThresh | Setting of limit for torque threshold (e.g. digital output). |

Speed limitation:

The following illustration shows the structure of speed limitation. The speed can be limited in relation to the rated speed by the scaling parameter P 0328 CON_SCON_SMax. It is possible to limit the negative P 0333 CON_SCON_SMaxNeg and the positive torque P 0334 CON_SCON_SMaxPos independently of each other online.

An activated reversing lock P 0337 CON_SCON_DirLock (not changeable online) also has an effect on the limitations with respect to the reference speeds for the control. The setting "POS" locks the positive reference values and "NEG" the negative references.

With P 0745 MON_RefWindow the standstill window is parameterized for the speed.

P. no. | Parameter name/Setting | Function |
P 0328 | CON_SCON_Max | Scaling to rated speed |
P 0333 | CON_SCON_S_MaxNeg | Speed limitation in negative direction (changeable online) | Changeable online
P 0334 | CON_SCON_S_MaxPos | Speed limitation in positive direction (changeable online) | Changeable online
P 0335 | CON_SCON_DirLock | Reversing lock, left and right (not changeable online) |
P 0337 | CONSCON_S_MaxScale | Percentage speed weighting (default 100%) |
P 0740 | MON_SpeedThresh | Setting of threshold for maximum speed |
P 0744 | MON_SDiffMax | Setting of threshold for maximum speed tracking error. |
P 0167 | MPRO_REF_OVR | Setting of override factor (speed limitation) |

Position limitation:

P. no. | Parameter name/Setting | Function
P 0743 | MON_UsrPosDiffMax | Limit value for the maximum permissible tracking error in user units.
P 0746 | MON_UsrPosWindow | Standstill window for position reached

see: / Power stage setting /

see: / Limitation by software limit switch /

see: / LIMIT(14) Reference limitation /

see: / REF(6) Target, reference reached /


Limitation by software limit switch

The software limit switches are only applicable in positioning mode, and are only activated once homing has been completed successfully. The software limit switches are parameterized in the "Digital inputs" subject area.

see: / Digital inputs /

P. no. | Parameter name/Setting | Function
P2235 | MPRO_402_SoftwarePosLimit | Positive and nega tive software limit switch
(0) | Software Position Limit | Negative limit switch
(1) | Software Position Limit | Positive limit switch

Positioning mode | Reaction
Absolute | Before enabling an absolute driving job, a check is made whether the target is in the valid range - that is, within the software limit switches. If the target is outside, no driving job is signalled and the programmed error reaction as per P 0030 P 0030 Error Reactions is executed.
Relative
Infinite (speed-controlled) | The drive travels until a software limit switch is detected. Then the programmed error reaction as per is executed.

The response to reaching a software limit switch depends on the preset error reaction (see parameter
P 0030 Error-Reaktion.

see: / Error reactions /

see: / Limit value settings /

see: / Power stage setting /


Voltage threshold for power failure response

If the value of the DC link voltage drops below the value set in parameter P 0747 MON_PF_OnLimit, the error ERR-34 "Power failure detected" is reported and the parameterized error reaction is triggered. By parameterizing a quick stop as the error reaction with a sufficiently steep deceleration ramp, the DC link voltage can be maintained above the undervoltage threshold (power failure bridging). This reaction lasts until the drive has been braked to a low speed.

The default setting is 0 V (function "Off").

P. no. | Parameter name/Setting | Function
P 0747 | MON_PF_ONLimit | Voltage threshold for power failure response
P 0749 | MON_Def_OverVoltage | DC link overvoltage


Warning status

Warnings are displayed in the "Warning status" dialog box.
Parameter P 0730 MON_WarningLevel defines the response thresholds for triggering of a warning.

see: / Warnings /


Warnings

In order to get timely information on excessive or inadequate values via an external controller or the drive's internal PLC, warning thresholds can be freely parameterized with P 0730 MON_WarningLevel. Each warning is assigned on and off thresholds. This enables parameterization of a hysteresis meeting the requirement of the application. When a warning is triggered, the corresponding bit is entered in parameter P 0034 ERR_WRN_State. The binary value enables a status interrogation. Warnings can also be programmed onto digital outputs.

Variables for which warnings can be issued:

P 0034 Bit no. | Warning thresholds
0 | I2xt integrator (motor) warning threshold exceeded
1 | Heat sink temperature
2 | Motor temperature
3 | Interior temperature
4 | Reserved for SERCOS
5 | Overspeed
6 | Reserved for SERCOS
7 | Reserved for SERCOS
8 | Reserved for SERCOS
9 | Undervoltage
10 | Reserved for SERCOS
11 | Reserved for SERCOS
12 | Reserved for SERCOS
13 | Reserved for SERCOS
14 | Reserved for SERCOS
15 | Reserved for SERCOS
16 | I2xt integrator (device) exceeded
17 | Monitoring of apparent current
18 | Overvoltage
19 | Protection of brake chopper, warning threshold exceeded
20 | Overtorque
21 | Reserve
22 | Reserve
23 | Reserve
24 | Speed reference limitation active
25 | Current reference limitation
26 | Right limit switch active
27 | Left limit switch active
28 | External warning via input
29 | Reserve
30 | Reserve
31 | Reserve

Adaptation of switching hysteresis (warning thresholds):

No message is issued in the hysteresis range. So when a warning is parameterized the hysteresis window must be adapted for the corresponding warning. The upper and lower limits of the window must be programmed.

P. no. P 0730 | Parameter name | Thresholds
0 | UnderVoltage_ON | Undervoltage
1 | UnderVoltage_OFF
2 | OverVoltage_ON | Overvoltage
3 | OvervVoltage_OFF
4 | Current_ON | Motor current
5 | Current_OFF
6 | Device I2xt_ON | I2xt device protection
7 | Device I2xt_OFF
8 | Motor I2xt_ON | I2xt motor protection
9 | Motor I2xt_OFF
10 | Torque ON | Torque limit reached
11 | Torque OFF
12 | Speed ON | Speed limit reached
13 | Speed OFF
14 | TC ON | Heat sink temperature reached
15 | TC OFF
16 | T_int ON | Housing internal temperature reached
17 | T_int OFF
18 | MotorTemp_ON | Motor temperature reached (temperature sensor on X5)
19 | MotorTemp_OFF
20 | MotorTemp_ON X6 | Motor temperature reached (temperature sensor on X6)
21 | MotorTemp_OFF X6

see: / Warning status /


Error display

Errors are shown on the drive controller display (for D1/2 display see Operation Manual) and in parallel in the DriveManager 5.

7-segment display on controller:
Each error code consists of the repeating sequence:

  • -Er-
  • -Error number-
  • -Error location-

and is indicated on the display D1/D2.

Example:

Display | Meaning
 | Device error Errors marked with a dot on the display D1/D2 can only be reset when the cause of the fault has been eliminated.
Display changes after 1 second.
 | Error number (decimal) Error 45
Display changes after 1 second.
 | Error location (decimal) Error location 01: "Movement requested which was limited by reversing lock, limit switch or reference value limitation".
Display changes after 1 second back to ER.

Error window in DriveManager 5

When an error occurs, the window opens indicating:

  • Error name
  • Error location
  • Error cause
  • The green status indicator in the "Drive Status Window" turns red.

"Error history" button

Click the "Error history" button in the "Drive Status" window to call up a memory buffer list displaying the last 20 occurring errors. When the 21st error occurs, the oldest error in the list is overwritten.

Error reset:

Errors can be reset according to their programmed reaction. To reset choose "Menu/DM Restart" or disconnect the 24 V control voltage (X9/X10). Errors marked with a dot on the display D1/D2 in the controller can only be reset when the cause of the fault has been eliminated.

see: / Error reactions /


Error reactions

Each of the errors listed in parameter P 0030 Error Reaction (index 0-47) can be assigned one of the error reactions listed below.
Not every error has every selection option.

P.no. | Parameter name/ Settings | Function
P 0030 | Programmable reaction in case of failure | Error reaction
(0) | Ignore | The error is ignored
(1) | Specific1 | The error is ignored
(2) | Specific 2 | Error reaction external: An error is signalled immediately (DriveCom change of state after Fault reaction active (7) ), reference input still possible in IP Mode. The shutdown is effected when standstill has been reached or the timeoutP 0154 MPRO_DRCOM_ROT_0_Time has elapsed. The default is 100 ms, but may be up to 65 s. When the error is detected the power stage is shut down at the end of the time or at standstill (if reached first). The change of state (DriveCom) takes place from Fault reaction active (7) to Fault (8).
(3) | Notify error, reaction as given by fault reaction option codes | The error is registered. The error reaction is based on the value set in object 605Eh "Fault reaction option code".
(4) | ServoStop | Quick stop, wait for control restart
(5) | ServoHaltAndLock | Quick stop, block power stage, secure against switching on
(6) | Servo Halt | Block power stage
(7) | ServoHaltAndLock | Block power stage, block enable
(8) | WaitERSAndReset | Block power stage, reset only by switching the 24 V control voltage on and off.

see: / Error display /

see: / Error list /


Error list

Error number P 0030 | Error location | Description of error | Emergency code as per DS402 | Error Register DS402 | Error Register SERCOS
0 | (0) no error | No error | 0xFF00 | 1 | 0x8000
1 | (1) RunTimeError | Runtime error | 0x6010 | 1 | 0x1
 | (2) RunTimeError_DynamicModules | Internal error in device initialization | 0x6010 | 1 | 0x1
 | (3) RunTimeError_Flashmemory | Error in flash initialization | 0x6010 | 1 | 0x1
 | (4) RunTimeError_PLC | PLC runtime error | 0x6010 | 1 | 0x1
2 | ParaList |  |  |  |
 | (1) ParameterInit | Error in parameter initialization | 0x6320 | 1 | 0x1
 | (2) ParameterVirginInit | Basic parameter initialization (factory setting) | 0x6320 | 1 | 0x1
 | (3) ParameterSave | Parameter data backup | 0x5530 | 1 | 0x1
 | (4) ParameterAdd | Registration of a parameter | 0x6320 | 1 | 0x1
 | (5) ParameterCheck | Check of current parameter list values | 0x5530 | 1 | 0x1
 | (6) ParameterListAdmin | Management of parameter list | 0x6320 | 1 | 0x1
 | (7) ParaList_PST | Non-resettable errors from power stage: EEPROM data error | 0x5400 | 1 | 0x1
 | (8) ParaList_PST_VL | Error in power stage initialization; selected device voltage not supported | 0x6320 | 1 | 0x1
3 | OFF |  |  |  |
 | (1) Off_MON_Device | Undervoltage | 0x3120 | 1 | 0x200
4 | Overvoltage |  |  |  |
 | (1) OverVoltage_MON_Device | Overvoltage | 0x3110 | 1 | 0x100
5 | Overcurrent |  |  |  |
 | (1) OverCurrent_HardwareTrap | Overcurrent shut-off by hardware | 0x2250 | 1 | 0x80
 | (2) OverCurrent_Soft | Overcurrent shut-off (fast) by software | 0x2350 | 1 | 0x80
 | (3) OverCurrent_ADC | Measuring range of AD converter exceeded | 0x2350 | 1 | 0x80
 | (4) OverCurrent_WireTest | Short-circuit test on initialization | 0x2350 | 1 | 0x80
 | (5) OverCurrent_DC | (Fast) Overcurrent shut-off "below 5 Hz" | 0x2350 | 1 | 0x80
 | (6) OverCurrent_Zero | Total current monitoring | 0x2350 | 1 | 0x80
 | (7) OverCurrent_I2TS | Fast I2xt at high overload | 0x2350 | 1 | 0x80
6 | Overheating |  |  |  |
 | (1) OvertempMotor_MON_MotTemp | Calculated motor temperature above threshold value | 0x4310 | 1 | 0x4
 | (2) OvertempMotor_MON_Device_DIN1 | PTC to DIN1 | 0x4310 | 1 | 0x4
 | (3) OvertempMotor_MON_Device_DIN2 | PTC to DIN2 | 0x4310 | 1 | 0x4
 | (4) OvertempMotor_MON_Device_DIN3 | PTC to DIN3 | 0x4310 | 1 | 0x4
7 | Heat sink overheating |  |  |  |
 | (1) OvertempInverter_MON_Device | Heat sink temperature too high | 0x4210 | 1 | 0x2
8 | Interior overheating |  |  |  |
 | (1) OvertempDevice_MON_Device | Interior temperature monitor | 0x4210 | 1 | 0x40
9 | I2xt motor |  |  |  |
 | (1) I2tMotor_MON_I2t | I2xt integrator has exceeded motor protection limit value (permissible current/time area) | 0x2350 | 1 | 0x1
10 | Power stage monitor |  |  |  |
 | (1) I2tPowerAmplifier_MON_Device | I2xt power stage protection limit value exceeded | 0x2350 | 1 | 0x1
 | (2) Internal brake resistor was overloaded | The internal braking resistor was overloaded | 0x2350 | 1 | 0x1
11 | External error |  |  |  |
 | (1) External_MPRO_INPUT | External error message | 0xFF0 | 1 | 0x8000
12 | CAN |  |  |  |
 | (1) ComOptCan_BusOff | CAN option: BusOff error | 0x8140 | 1 | 0x8000
 | (2) ComOptCan_Guarding | CAN option: Guarding error | 0x8130 | 1 | 0x8000
 | (3) ComOptCan_MsgTransmit | CAN option: Unable to send message | 0x8100 | 1 | 0x8000
 | (4) ComOptCan_HeartBeat | CAN option: Heartbeat error | 0x8130 | 1 | 0x8000
 | (5) ComOptCan_Addr | CAN option: Invalid address | 0x8110 | 1 | 0x8000
 | (6) ComOptCan_PdoMappingError | CAN option: Mapping error | 0x8200 | 1 | 0x8000
 | (7) ComOptCan_SyncTimeoutError | CAN option: Synchronization error | 0x8140 | 1 | 0x8000
13 | SERCOS |  |  |  |
 | (1) ComOptSercos_HardwareInit | SERCOS: Hardware initialization | 0xFF00 | 1 | 0x1000
 | (2) ComOptSercos_IllegalPhase |  | 0xFF00 | 1 | 0x1000
 | (3) ComOptSercos_CableBreak |  | 0xFF00 | 1 | 0x1000
 | (4) ComOptSercos_DataDisturbed |  | 0xFF00 | 1 | 0x1000
 | (5) ComOptSercos_MasterSync |  | 0xFF00 | 1 | 0x1000
 | (6) ComOptSercos_MasterData |  | 0xFF00 | 1 | 0x1000
 | (7) ComOptSercos_Address- Double |  | 0xFF00 | 1 | 0x1000
 | (8) ComOptSercos_PhaseSwitchUp |  | 0xFF00 | 1 | 0x1000
 | (9) ComOptSercos_PhaseSwitchDown | SERCOS: Faulty phase switching (Down shift) | 0xFF00 | 1 | 0x1000
 | (10) ComOptSercos_PhaseSwitchAck | SERCOS: Faulty phase switching (missing acknowledgement) | 0xFF00 | 1 | 0x1000
 | (11) ComOptSercos_InitParaList | SERCOS: Faulty initialization of SERCOS parameter lists | 0xFF00 | 1 | 0x1000
 | (12) ComOptSercos RunTimeError | SERCOS: Various runtime errors | 0xFF00 | 1 | 0x1000
 | (13) ComOptSercos_Watchdog | SERCOS: Hardware watchdog | 0xFF00 | 1 | 0x1000
 | (14) ComOptSercos_Para | SERCOS: Error in parameterization (selection of OP mode, IP times, etc...) | 0xFF00 | 1 | 0x1000
14 | EtherCat: |  |  |  |
 | (1) ComOptEtherCat_Sm_Watchdog0 | EtherCat: Sync-Manager0 - Watchdog | 0x8130 | 1 | 0x8000
 | (2) ComOptEtherCat_Wrong EepData | EtherCat: Parameter error, parameter data implausible | 0x8130 | 1 | 0x8000
 | (3) ComOptEtherCat_RamError | EtherCat: Internal RAM error | 0x8130 | 1 | 0x8000
15 | Parameter |  |  |  |
 | (1) Parameter_MON_Device_Current | Error in current monitoring initialization | 0x2350 | 1 | 0x8000
 | (2) ComOptEtherCat_Wrong EepData | EtherCat: Parameter error, parameter data implausible | 0x2350 | 1 | 0x8000
 | (3) ComOptEtherCat_RamError | EtherCat: Internal RAM error | 0xFF00 | 1 | 0x8000
 | (4) Parameter_CON_FM | Field model | 0xFF00 | 1 | 0x8000
 | (5) Parameter_CON_Timing | Basic initialization of control | 0xFF00 | 1 | 0x8000
 | (6) Parameter_MPRO_FG | Error calculating user units | 0x6320 | 1 | 0x8000
 | (7) Parameter_ENC_RATIO | Error initializing encoder gearing | 0x6320 | 1 | 0x8000
 | (8) Parameter_Nerf | Speed detection / observer | 0x8400 | 1 | 0x8000
 | (9) Parameter_ObsLib | Error in matrix library | 0xFF0 | 1 | 0x8000
 | (10) Parameter_CON_CCON | Torque control | 0x8300 | 1 | 0x8000
 | (11) Parameter_reserved1 | Not used | 0xFF00 | 1 | 0x8000
 | (12) Parameter_Inertia | Moment of inertia is zero | 0xFF00 | 1 | 0x8000
 | (13) Parameter_MPRO | PARA_WatchDog in control via user interface | 0xFF00 | 1 | 0x8000
 | (14) Parameter_DV_INIT | DV_INIT: Error in system initialization | 0xFF00 | 1 | 0x8000
16 | Speed tracking error |  |  |  |
 | (1) SpeedDiff_MON_SDiff | Speed tracking error above threshold value | 0x8400 | 1 | 0x8000
 | (2) SpeedDiff_MON_NAct | Current speed above maximum speed of motor | 0x8400 | 1 | 0x8000
17 | Position tracking error |  |  |  |
 | (1) PositionDiff_MON_ActDelta | Position tracking error too large | 0x8611 | 1 | 0x8000
18 | Motion profile |  |  |  |
 | (1) MotionControl_MC_HOMING_LimitSwitchInterchanged | Homing: Limit switches interchanged | 0x8612 | 1 | 0x8000
 | (2) MotionControl:MC_HOMING: Unexpected home switch event | Homing: Limit switch tripped unexpectedly | 0x8612 | 1 | 0x8000
 | (3) MotionControl_MC_HOMING_ErrorLimitSwitch | Homing: Limit switch error | 0x8612 | 1 | 0x8000
 | (4) MotionControl_MC_HOMING_UnknownMethod | Homing: Wrong homing method, homing method not available | 0x8612 | 1 | 0x8000
 | (5) MotionControl_MC_HOMING_MethodUndefined | Homing: Homing method available but not defined | 0xFF00 | 1 | 0x8000
 | (6) MotionControl_MC_HOMING_DriveNotReadyHoming | Homing: Drive not ready for homing | 0xFF00 | 1 | 0x8000
 | (7) MotionControl_MC_HOMING_DriveNotReadyJogging | Homing: Drive not ready for jog mode | 0xFF00 | 1 | 0x8000
 | (8) MotionControl_MC_HOMING_WrongConMode | Homing: Control mode does not match homing method | 0xFF00 | 1 | 0x8000
 | (9) MotionControl_MC_HOMING_EncoderInitFailed | Homing: Encoder initialization error | 0xFF00 | 1 | 0x8000
 | (10) MotionControl_MC_HOMING_MaxDistanceOverrun | Homing: Homing travel exceeded | 0xFF00 | 1 | 0x8000
 | (11) MotionControl_MPRO_REF_EnabledOperationFailed | Max. permissible tracking error on "Start control" exceeded | 0xFF00 | 1 | 0x8000
 | (12) MotionControl_MPRO_REF_SSP_StackOverflow | Memory overflow for table values | 0xFF00 | 1 | 0x8000
 | (13) MotionControl_MC_HOMING_RestoreBackupPos | Error initializing last actual position after restart. | 0xFF00 | 1 | 0x8000
19 | Fatal Error |  |  |  |
 | (1) FatalError_PowerStage_Limit_Idx | PST: Data index too large | 0x5400 | 1 | 0x8000
 | (2) FatalError_PowerStage_SwitchFreq | PST: Error in switching frequency-dependent data | 0x5400 | 1 | 0x8000
 | (3) FatalError_PowerStage_DataInvalid | PST: Invalid EEPROM data | 0x5400 | 1 | 0x8000
 | (4) FatalError_PowerStage_CRC | PST: CRC error | 0x5400 | 1 | 0x8000
 | (5) FatalError_PowerStage_ErrorReadAccess | PST: Error reading power stage data | 0x5400 | 1 | 0x8000
 | (6) FatalError_PowerStage_ErrorWriteAccess | PST: Error writing power stage data | 0x5400 | 1 | 0x8000
 | (7) FatalError_MON_Chopper | Current in braking resistor even though transistor switched off | 0x5420 | 1 | 0x8000
 | (8) FatalError_HW_Identification | Hardware identification error | 0x5300 | 1 | 0x8000
 | (9) FatalError_FlashMemory | Error in flash memory | 0x5300 | 1 | 0x8000
20 | Hardware limit switches |  |  |  |
 | (1) HardwareLimitSwitch_Inter- changed | Limit switches interchanged | 0x8612 | 1 | 0x8000
 | (2) HardwareLimitSwitch_LCW | Hardware limit switch LCW | 0x8612 | 1 | 0x8000
 | (3) HardwareLimitSwitch_LCCW | Hardware limit switch LCCW | 0x8612 | 1 | 0x8000
21 | Encoder initialization | General encoder initialization (locations which cannot be assigned to a channel) |  |  |
 | (1) EncoderInit_CON_ICOM_EpsDelta | Encoder general initialization: Autocommutation: excessive motion | 0x7300 | 1 | 0x20
 | (2) EncoderInit_CON_ICOM_Tolerance | Encoder general initialization: Autocommutation: excessive tolerance | 0x7300 | 1 | 0x20
22 | Encoder channel 1 initialization |  |  |  |
 | (1) EncCH1Init_Sincos_Lines | Encoder channel 1 initialization, Sincos: Plausibility check 'Lines' from PRam_ENC_CH1_Lines | 0x7305 | 1 | 0x20
 | (2) EncCH1Init_Sincos_ABSquareSum | Encoder channel 1 initialization, Sincos: Getting AB-SquareSum, Timeout | 0x7305 | 1 | 0x20
 | (3) EncCH1Init_Sincos_EncObs | Encoder channel 1 initialization, SinCos: Encoder monitoring Sincos | 0x7305 | 1 | 0x20
 | (4) EncCH1Init_EnDat2.1_NoEnDat2.1 | Encoder channel 1 initialization, EnDat2.1: No EnDat2.1 encoder (encoder may be SSI) | 0x7305 | 1 | 0x20
 | (5) EncCH1Init_EnDat2.1_Line5 | Encoder channel 1 initialization, EnDat2.1: Plausibility check 'Lines' from encoder | 0x7305 | 1 | 0x20
 | (6) EncCH1Init_EnDat2.1_Multiturn | Encoder channel 1 initialization, EnDat2.1: Plausibility check 'Multiturn' from encoder | 0x7305 | 1 | 0x20
 | (7) EncCH1Init_EnDat2.1_Singleturn | Encoder channel 1 initialization, EnDat2.1: Plausibility check 'Singleturn' from encoder | 0x7305 | 1 | 0x20
 | (8) EncCH1Init_EnDat2.1_CrcPos | Encoder channel 1 initialization, EnDat2.1: CRC error position transfer | 0x7305 | 1 | 0x20
 | (9) EncCH1Init_EnDat2.1_CrcData | Encoder channel 1 initialization, EnDat2.1: CRC error data transfer | 0x7305 | 1 | 0x20
 | (10) EncCH1Init_EnDat2.1_WriteToProt | Encoder channel 1 initialization, EnDat2.1: An attempt was made to write to the protection cells in the encoder! | 0x7305 | 1 | 0x20
 | (11) EncCH1Init_EnDat2.1_SscTimeout | Encoder channel 1 initialization, EnDat2.1: Timeout on SSC transfer | 0x7305 | 1 | 0x20
 | (12) EncCH1Init_EnDat2.1_StartbitTimeout | Encoder channel 1 initialization, EnDat2.1: Timeout, no start bit from encoder | 0x7305 | 1 | 0x20
 | (13) EncCH1Init_EnDat2.1_PosConvert | Encoder channel 1 initialization, EnDat2.1: Position data not consistent | 0x7305 | 1 | 0x20
 | (14) EncCH1Init_SSI_Lines | Encoder channel 1 initialization, SSI: Plausibility check 'Lines' from encoder | 0x7305 | 1 | 0x20
 | (15) EncCH1Init_SSI_Multiturn | Encoder channel 1 initialization, SSI: Plausibility check 'Multiturn' from encoder | 0x7305 | 1 | 0x20
 | (16) EncCH1Init_SSI_Singleturn | Encoder channel 1 initialization, SSI: Plausibility check 'Singleturn' from encoder | 0x7305 | 1 | 0x20
 | (17) EncCH1Init_SSI_ParityPos | Encoder channel 1 initialization, SSI: Parity error position transfer | 0x7305 |  | 0x20
 | (18) EncCH1Init_SSI_SscTimeout | Encoder channel 1 initialization, SSI: Timeout on SSC transfer | 0x7305 | 1 | 0x20
 | (19) EncCH1Init_SSI_PosConvert | Encoder channel 1 initialization, SSI: Position data not consistent | 0x7305 | 1 | 0x20
 | (20) EncCH1Init_SSI_EncObs | Encoder channel 1 initialization, SSI: Encoder monitoring bit | 0x7305 | 1 | 0x20
 | (21) EncCH1Init_Hiperface_NoHiperface | Encoder channel 1 error initializing Hiperface interface | 0x7305 | 1 | 0x20
 | (22) EncCH1Init_Hiperface_Common | Encoder channel 1 initialization, Hiperface: Interface, general error | 0x7305 | 1 | 0x20
 | (23) EncCH1Init_Hiperface_Timeout | Encoder channel 1 initialization, Hiperface: Interface, Timeout | 0x7305 | 1 | 0x20
 | (24) EncCH1Init_Hiperface_CommandMismatch | Encoder channel 1 initialization, Hiperface: Encoder, impossible COMMAND in response | 0x7305 | 1 | 0x20
 | (25) EncCH1Init_Hiperface_EStatResp_Crc | Encoder channel 1 initialization, Hiperface: CRC error in error status response | 0x7305 | 1 | 0x20
 | (26) EncCH1Init_Hiperface_EStatResp_Com | Encoder channel 1 initialization, Hiperface: Error status response returns communication error | 0x7305 | 1 | 0x20
 | (27) EncCH1Init_Hiperface_EStatResp_Tec | Encoder channel 1 initialization, Hiperface: Error status response returns technology or process error | 0x7305 | 1 | 0x20
 | (28) EncCH1Init_Hiperface_EStatResp_None | Encoder channel 1 initialization, Hiperface: Error status response returns no error(!) | 0x7305 | 1 | 0x20
 | (29) EncCH1Init_Hiperface_Response_Crc | Encoder channel 1 initialization, Hiperface: CRC error in response | 0x7305 | 1 | 0x20
 | (30) EncCH1Init_Hiperface_Response_Com | Encoder channel 1 initialization, Hiperface: Response with error bit: Status returns communication error | 0x7305 | 1 | 0x20
 | (31) EncCH1Init_Hiperface_Response_Tec | Encoder channel 1 initialization, Hiperface: Response with error bit: Status returns technology or process error | 0x7305 | 1 | 0x20
 | (32) EncCH1Init_Hiperface_Response_None | Encoder channel 1 initialization, Hiperface: Response with error bit: Status returns no error | 0x7305 | 1 | 0x20
 | (33) EncCH1Init_Hiperface_Status_Com | Encoder channel 1 initialization, Hiperface: Status telegram reports communication error | 0x7305 | 1 | 0x20
 | (34) EncCH1Init_Hiperface_Status_Tec | Encoder channel 1 initialization, Hiperface: Status telegram returns technology or process error | 0x7305 | 1 | 0x20
 | (35) EncCH1Init_Hiperface_TypeKey | Encoder channel 1 initialization, Hiperface: Type identification of encoder unknown | 0x7305 |  | 0x20
 | (36) EncCH1Init_Hiperface_WriteToProt | Encoder channel 1 initialization, Hiperface: An attempt was made to write to the protection cells in the encoder! | 0x7305 | 1 | 0x20
 | (37) EncCH1Init_TTL_IncompatibleHardware | Encoder channel 1 initialization, TTL: Control pcb does not support TTL evaluation | 0x7305 |  | 0x20
 | (38) EncCH1Init_EnDat2.1_PositionBits | Encoder channel 1 initialization, EnDat2.1: Plausibility check 'position bits' from encoder | 0x7305 | 1 | 0x20
 | (39) EncCH1Init_EnDat2.1_TransferBits | Encoder channel 1 initialization, EnDat2.1: Plausibility check 'Transfer Bits' of transfer | 0x7305 | 1 | 0x20
 | (40) EncCH1Init_Np_NominalIncrement | Encoder channel 1 initialization, NP: Plausibility check 'Lines' and 'Nominal-Increment' | 0x7305 | 1 | 0x20
 | (41) EncCh1Init_Endat21_Common | Encoder channel 1 initialization, Endat2.1: Interface general error | 0x7305 | 1 | 0x20
 | 42) EncCh1Init_SSI_Common | Encoder channel 1 initialization, SSI: Interface general error | 0x7305 | 1 | 0x20
 | 43) EncCh1Init_Sincos_Common | Encoder channel 1 initialization, Sincos: Interface general error | 0x7305 | 1 | 0x20
23 | Encoder channel 2 initialization |  |  |  |
 | (1) EncCH2Init_Res_Lines | Encoder channel 2 initialization, Res: Plausibility check 'Lines' from PRam_ENC_CH2_Lines | 0x7306 | 1 | 0x20
 | (2) EncCH2Init_Res_ABSquareSum_TimeOut | Encoder channel 2 initialization, Res: Getting AB-SquareSum, Timeout | 0x7306 | 1 | 0x20
 | (3) EncCH2Init_Res_EncObs | Encoder channel 2 initialization, Res: Encoder monitoring resolver | 0x7306 | 1 | 0x20
24 | Encoder channel 3 initialization |  |  |  |
 | (1) EncCH3Init_Module IdentificationFailed | Encoder channel 3 initialization: No module inserted or wrong module | 0x7307 | 1 | 0x20
 | (2) EncCH3Init_Common_EO_Error | Encoder channel 3 initialization: General EO error (encoder option) | 0x7307 | 1 | 0x20
 | (3) EncCH3Init_SSI_EncObs_20c | Encoder channel 3 initialization: Encoder monitoring | 0x7307 | 1 | 0x20
 | (4) EncCH3Init_EnDat2.1_NoEnDat2.1 | Encoder channel 3 initialization, EnDat2.1: No EnDat2.1 encoder (encoder may be SSI) | 0x7307 | 1 | 0x20
 | (5) EncCH3Init_EnDat2.1_Lines | Encoder channel 3 initialization, EnDat2.1: Plausibility check 'Lines' from encoder | 0x7307 | 11 | 0x20
 | (6) EncCH3Init_EnDat2.1_Multiturn | Encoder channel 3 initialization, EnDat2.1: Plausibility check 'Multiturn' from encoder | 0x7307 | 1 | 0x20
 | (7) EncCH3Init_EnDat2.1_Singleturn | Encoder channel 3 initialization, EnDat2.1: Plausibility check 'Singleturn' from encoder | 0x7307 | 1 | 0x20
 | (8) EncCH3Init_EnDat2.1_CrcPos | Encoder channel 3 initialization, EnDat2.1: CRC error position transfer | 0x7307 | 1 | 0x20
 | (9) EncCH3Init_EnDat2.1_CrcData | Encoder channel 3 initialization, EnDat2.1: CRC error data transfer | 0x7307 | 1 | 0x20
 | (10) EncCH3Init_EnDat2.1_WriteToProt | Encoder channel 3 initialization, EnDat2.1: An attempt was made to write to the protection cells in the encoder! | 0x7307 | 1 | 0x20
 | (11) EncCH3Init_EnDat2.1_SscTimeout | Encoder channel 3 initialization, EnDat2.1: Timeout on SSC transfer | 0x7307 | 1 | 0x20
 | (12) EncCH3Init_EnDat2.1_StartbitTimeout | Encoder channel 3 initialization, EnDat2.1: Timeout, no start bit from encoder | 0x7307 | 1 | 0x20
 | (13) EncCH3Init_EnDat2.1_PosConvert | Encoder channel 3 initialization, EnDat2.1: Position data not consistent | 0x7307 | 1 | 0x20
 | (14) EncCH3Init_SSI_Lines | Encoder channel 3 initialization, SSI: Error initializing SSI interface | 0x7307 | 1 | 0x20
 | (15) EncCH3Init_SSI_Multiturn | Encoder channel 3 initialization, SSI: Plausibility check 'Multiturn' from encoder | 0x7307 | 1 | 0x20
 | (16) EncCH3Init_SSI_Singleturn | Encoder channel 3 initialization, SSI: Plausibility check, Singleturn from encoder | 0x7307 | 1 | 0x20
 | (17) EncCH3Init_SSI_ParityPos | Encoder channel 3 initialization, SSI: Parity error position transfer | 0x7307 | 1 | 0x20
 | (18) EncCH3Init_SSI_SscTimeout | Encoder channel 3 initialization, SSI: Timeout on SSC transfer | 0x7307 | 1 | 0x20
 | (19) EncCH3Init_SSI_PosConvert | Encoder channel 3 initialization, SSI: Position data not consistent | 0x7307 | 1 | 0x20
 | (20) EncCH3Init_SSI_EncObs | Encoder channel 3 initialization, SSI: Encoder monitoring bit | 0x7307 | 1 | 0x20
 | (38) EncCH3Init_EnDat2.1_PositionBits | Encoder channel 3 initialization, EnDat2.1: Plausibility check Position Bits from encoder | 0x7307 | 1 | 0x20
 | (39) EncCH3Init_EnDat2.1_TransferBits | Encoder channel 3 initialization, EnDat2.1: Plausibility check 'Transfer Bits' of transfer | 0x7307 | 1 | 0x20
 | (40) EncCH3Init_Np_ NominalIncrement | Encoder channel 3 initialization, NP: Plausibility check 'Lines' and 'Nominal-Increment' | 0x7307 | 1 | 0x20
 | (41) EncCH3Init_Endat21_Common | Encoder channel 3 initialization, EnDat2.1: Interface, general error | 0x7307 | 1 | 0x20
 | (42) EncCH3Init_SSI_Common | Encoder channel 3 initialization, SSi: Interface, general error | 0x7307 | 1 | 0x20
 | (43) EncCH3Init_Sincos_Common | Encoder channel 3 initialization, Sincos: Interface, general error | 0x7307 | 1 | 0x20
 | (50) EncCH3Init_TOPT_cfg | Encoder channel 3 initialization, interface, general error | 0x7307 | 1 | 0x20
25 | EncoderCycl | Autocommutation |  |  |
 | (1) EncoderCycl_CON_ICOM_Epsdelta | Encoder general cyclic: Autocommutation: excessive motion | 0xFF00 | 1 | 0x20
 | (2) EncoderCycl_CON_ICOM_Tolerance | Autocommutation: excessive tolerance | 0xFF00 | 1 | 0x20
26 | EncCh1Cycl | Plausibility check CH1 |  |  |
 | (1) EncCH1Cycl_Np_Distance | Encoder channel 1 cyclic, NP: Plausibility check ,CounterDistance | 0x7305 | 1 | 0x20
 | (2) EncCH1Cycl_Np_DeltaCorrection | Encoder channel 1 cyclic, NP: Delta correction not possible | 0x7305 | 1 | 0x20
 | (3) EncCH1Cycl_Np_Delta | Encoder channel 1 cyclic, NP: Plausibility check CounterDelta | 0x7305 | 1 | 0x20
27 | EncCh2Cycl | Plausibility check CH2 |  |  |
 | (1) EncCH2Cycl_NoLocation | Not used | 0x7306 | 1 | 0x20
28 | EncCh3Cycl | Plausibility check CH3 |  |  |
 | (1) EncCH3Cycl_NoLocation | Not used | 0x7307 | 1 | 0x20
29 | TC (TriCore) |  |  |  |
 | (1) TC_ASC | TriCore ASC | 0x5300 | 1 | 0x8000
 | (2) TC_ASC2 | TriCore ASC2 | 0x5300 | 1 | 0x8000
 | (3) TC_FPU | TriCore floating point error | 0x5300 | 1 | 0x8000
 | (4) TC_FPU_NO_RET_ADDR | TriCore floating point error, no return address available | 0x5300 | 1 | 0x8000
30 | InitCon | Initialization error |  |  |
 | (1) InitCon_AnaInput | Initialization error analog input | 0x5300 | 1 | 0x8000
 | (2) InitCon_FM_GetKM | Initialization error calculating motor torque constant | 0x5300 | 1 | 0x8000
 | (3) InitCon_FM_ASM | Initialization error asynchronous motor | 0x5300 | 1 | 0x8000
 | (4) InitCon_FM_ASM_FW | TriCore floating point error, no return address available | 0x5300 | 1 | 0x8000
31 | PLC |  |  |  |
 | (1) PLC_Location 0...65536 | User-specific: Errors generated in PLC program | 0xFF00 | 1 | 0x8000
32 | Profibus |  |  |  |
 | (1) ComOptDp_Timeout | PROFIBUS DP: Process data timeout | 0xFF00 | 1 | 0x8000
33 | Timing | Task overflow |  |  |
 | 1) Timing_ADCTask_ReEntry | ADC task automatically interrupted | 0x5300 | 1 | 0x8000
 | (2) Timin_ControlTask | Control task exceeded scan time | 0x5300 | 1 | 0x8000
34 | PowerFail | Power failure detection |  |  |
 | PowerFail | Power failure detection; supply voltage error | 0x3220 | 1 | 0x8000
35 | EncObs | Encoder cable break |  |  |
 | (1) EncObs_CH1_Sincos | Cable break: Encoder channel 1 | 0xFF00 | 1 | 0x20
 | (2) EncObs_CH2_Resolver | Cable break: Encoder channel 2 | 0xFF00 | 1 | 0x20
 | (3) EncObs_CH3_Sincos | Cable break: Encoder channel 3 | 0xFF00 | 1 | 0x20
 | (4) EncObs_CH1_SSI | Cable break: Encoder channel 1 | 0xFF00 | 1 | 0x20
36 | VARAN |  |  |  |
 | (1) ComOptVARAN_InitHwError | Error in hardware initialization: VARAN option | 0x5300 | 1 | 0x8000
 | (2) ComOptVARAN_BusOffError | "Bus off" error; no bus communication: VARAN option | 0x5300 | 1 | 0x8000
37 | Synchronization controller |  |  |  |
 | (1) RatioError | The ratios between interpolation, synchronization and/or speed control time do not match | 0x6100 | 1 | 0x8000
38 | Brake chopper monitoring |  |  |  |
 | (1) BC_Overload | Brake chopper overloaded | 0x4210 | 1 | 0x0000
39 | TwinWindow | Monitoring of speed and torque |  |  |
 | (1) TwinWindow_Speed | Speed deviation between Master and Slave |  |  |
 | (2) TwinWindow_Torque | Torque deviation between Master and Slave |  |  |
40 | Twin-Sync-Module | Communication fault TECH option |  |  |
 | (1) TOPT_TWIN_CommLost | Error in "TwinSync" technology option | 0x7300 | 1 | 0x8000
 | (2) TOPT_TWIN_SwitchFreq | Error in "TwinSync" technology option | 0x7300 | 1 | 0x8000
 | (3) TOPT_TWIN_ModeConflict | Error in "TwinSync" technology option | 0x7300 | 1 | 0x8000
 | (4) TOPT_TWIN_RemoteError | Error in "TwinSync" technology option | 0x7300 | 1 | 0x8000
41 | DC link fast discharge | Maximum period for fast discharge |  |  |
 | (1) FastDischarge_Timeout | Maximum period for fast discharge exceeded (35 s) | 0x7300 | 1 | 0x8000
42 | EtherCAT Master Implementation | Error EtherCat Master |  |  |
 | (1) Location cant specified CommError | Communication error EtherCat Master, cannot be localized. | 0x6100 | 1 | 0x8000
43 | Ethernet interface | Error in Ethernet configuration |  |  |
 | (1) Ethernet_Init | Initialization error TCP/IP communication | 0x6100 | 1 | 0x8000
44 | Cable break detected |  |  |  |
 | (1) WireBreak_MotorBrake | No consumer on output X13 (motor holding brake) | 0x6100 | 1 | 0x8000
45 | LERR_LockViolate |  |  |  |
 | (1)LERR_LockViolate | Movement requested which was limited by reversing lock, limit switch or reference value limitation | 0x8612 | 1 | 0x8000
 | (2)LERR_LockViolate | Movement requested which was limited by reversing lock, limit switch or reference value limitation. Lock active in both directions | 0x8612 | 1 | 0x8000
46 | LERR_positionLimit |  |  |  |
 | (1) Position Limit_neg. | Negative software limit switch approached | 0x8612 | 1 | 0x2000
 | (2) Position Limit_pos | Positive software limit switch approached | 0x8612 | 1 | 0x2000
 | (3) Position Limit_Overtravel | Reference value outside software limit switches | 0x8612 | 1 | 0x2000
47 | LERR_FSAFE | Reserved |  |  |


CANopen

The CANopen communication profile is documented in CiA 301. It differentiates between Process Data Objects (PDOs) and Service Data Objects (SDOs). The Communication Profile additionally defines a simplified network management system. Based on the communication services of CiA 301 (Rev. 4.01) the device profile for variable-speed drives DS402 was created. It describes the operation modes and device parameters supported.

For a detailed description of the CANopen field bus system refer to the separate "CANopen User Manual".


SERCOS

The basis for SERCOS implementation is the "Specification SERCOS Interface Version 2.2".

Features:

  • Data transfer by fibre-optic cable
  • Transfer rate: optionally 2, 4, 8 or 16 MBaud
  • Automatic baud rate detection
  • Transmission power adjustable by DIP switches
  • SERCOS address programmable via buttons and display
  • Cyclic data exchange of references and actual values with exact time equidistance
  • SERCOS sampling time of 125 s to 65 ms (multiples of 125 s programmable)
  • Multi-axis synchronization between reference action times and actual value measurement times of all drives in the loop.
  • Full synchronization of all connected drives with the PLC
  • Free configuration of telegram content
  • Maximum configurable data volume in MDT: 20 bytes
  • Maximum configurable data volume in DT: 20 bytes
  • Programmable parameter weighting and polarity for position, speed, acceleration and torque
  • Modulo weighting
  • Additive speed and torque references
  • Fine-interpolation (linear or cubic) inside the drive
  • Optionally PLC-side (external) or in-drive generation of rotation speed and acceleration pre-control
  • Service channel for parameter setting and diagnostics
  • Support for touch probes 1 and 2
  • Support for configurable real-time status and control bits
  • Support for configurable signal status and control word

For a detailed description of the SERCOS field bus system refer to the separate "SERCOS User Manual".


Profibus

Short description of PROFIBUS DP interface

The implementation in the controller is based on the PROFIdrive profile version 4.0.

Features:

  • Data transfer using two-wire twisted pair cable (RS 485)
  • Transfer rate: max. 12 MBaud
  • Automatic baud rate detection
  • PROFIBUS address can be set using the rotary coding switches or alternatively using the addressing parameters
  • Cyclic data exchange reference and actual values using DPV0
  • Acyclic data exchange using DPV1
  • Synchronization of all connected drives using freeze mode and sync mode
  • Reading and writing drive parameters using the PKW channel or DPV1

For a detailed description of the PROFIBUS field bus system refer to the separate "Profibus User Manual".